Jump to content

When loading a world FML becomes corrupted


Recommended Posts

2013-05-19 22:39:58 [sEVERE] [ForgeModLoader] The ForgeModLoader state engine has become corrupted. Probably, a state was missed by and invalid modification to a base classForgeModLoader depends on. This is a critical error and not recoverable. Investigate any modifications to base classes outside ofForgeModLoader, especially Optifine, to see if there are fixes available.

2013-05-19 22:39:58 [iNFO] [sTDERR] Exception in thread "Server thread" java.lang.RuntimeException: The ForgeModLoader state engine is invalid

2013-05-19 22:39:58 [iNFO] [sTDERR] at cpw.mods.fml.common.LoadController.transition(LoadController.java:134)

2013-05-19 22:39:58 [iNFO] [sTDERR] at cpw.mods.fml.common.Loader.serverStopped(Loader.java:800)

2013-05-19 22:39:58 [iNFO] [sTDERR] at cpw.mods.fml.common.FMLCommonHandler.handleServerStopped(FMLCommonHandler.java:468)

2013-05-19 22:39:58 [iNFO] [sTDERR] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:531)

2013-05-19 22:39:58 [iNFO] [sTDERR] at net.minecraft.server.ThreadMinecraftServer.run(SourceFile:573)

 

When loading a world if there has been item id changes, it will prompt you asking if you still want to load, upon clicking on no, looking a tthe multimc console it reads the above, is there anyway to fix this without rebuilding the jar. Using Forge 689, even thought it says to use the latest (which do not work).

Link to comment
Share on other sites

Using the following mods (ignore "/")

 

Requirements

Forge in jar /

Code Chicken Core coremods /

Cofh core coremods /

iChun util /

power crystals core coremods /

forge essentials

mob spawn control /

den lib coremods /

bee speakers core /

coro ai /

config mod /

dragon api /

 

Lag fixes

Optifine in jar /

fps++ in jar /

item frame lag fix in jar /

stackie /

entity and lighting fixes in jar /

tick threading server only

 

Tweaks

Single player commands in jar /

better anvil /

inventory tweaks /

matmos /

rotten flesh to leather /

wild grass

zombie awareness /

shader mod

 

UI

NEI Coremods /

plugins

redpower plugin

ars magica plugin

Rei’s mini map /

damage indicators /

 

Misc

enchanting plus /

obsidian plates /

doggy talents /

chococraft /

nether ores /

Iron Chests /

Chicken chunks /

natura /

tropicraft

crystal wing /

bams double door /

tinkerers construct /

gravestone /

biomes o plenty /

BOP integration

biblio craft /

 

Magic

runic dust mod

Equivalent Exchange /

Myst craft

Thaum craft /

thaumic tinkerer /

essentia everything /

Souls shards /

Aether

ars magica /

Twilight forest /

 

Tech

Industrial Craft /

Modular power suits /

modular power suits addon /

nuclear control /

advanced machines /

Advanced solars /

Mffs classic /

gregtech /

applied energistics /

Red Power 2

factorisation /

Wireless redstone

Addon

Redpower addon

Build craft /

Thermal expansion /

Omni tools /

power convertors /

Forestry /

Extra bees /

Thaumic bees /

plugins for forestry /

xycraft

portal gun /

Rail craft /

Steves carts /

laser mod

rotary craft /

 

Oh in case you are wondering, "/" means added, its a list for myself of all the mods I have added, oh and for OCD people, I do have it so everything is lined up, its just weird on websites.

Link to comment
Share on other sites

hm, there are a bunch of jar mods you have. Try without them and see if it works. Most likely a conflicting jar mod.

Don't ask for support per PM! They'll get ignored! | If a post helped you, click the "Thank You" button at the top right corner of said post! |

mah twitter

This thread makes me sad because people just post copy-paste-ready code when it's obvious that the OP has little to no programming experience. This is not how learning works.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Minecraft java and forge seem to have it out for me, any ideas? I have had issues with exit code 1 while loading forge -fabric was having the same issues, but I seemed to fix it in these repairs? (tried different versions upwards from 1.19 to 1.20.2 for forge, nothing worked and I'm confident older versions wouldn't either) -The launcher itself loads fine, it will load the game within the launcher, and then crash the moment it tries to load outside of the launcher. I have tried the default launcher, legacy launcher, and the curse forge launcher, none have worked! (all have had the same problem) I think this started when I took a break and upgraded to windows 11 and wonder if that changed anything? I have tried the following: uninstalled & reinstalled java, (I have having issues where I download jdk 17 but only 8 would show up (would not show up anywhere but the control panel, not even the official uninstaller, I *think* I got that fixed) tried jarfix uninstalled & reinstalled minecraft tried alternate launchers -forge & legacy, & repaired them too. tried without mods updated game drivers uninstalled and reinstalled forge -including completely wiping it from my system changed java excutable path followed everything in the error code 1 post completely reset my pc I tried to change the launch path but couldn't seem to get it to work -the default launcher wont let me even see properties as an option, i have yet to try with the other two (i did try on legacy but it was being weird) I want to include my debug log; but its over the max size? sorry my brains gone numb from trying to fix this for the past 2 days
    • I personally create registries using DataPackRegistryEvent.NewRegistry. It's pretty powerful as long as you know how to make codecs. In some class, make a registry key like so: public static final ResourceKey<Registry<MyDataType>> MY_REGISTRY = ResourceKey.createRegistryKey(new ResourceLocation(MyMod.MOD_ID, "registry_name")); This will make a registry that holds objects of type "MyDataType". JSON files stored in data/<datapack_namespace>/modid/registryname/ will be parsed and put into this registry. Note that the directory structure has a folder named after your mod inside your datapack directory, so the actual path would look like: data/my_mod/my_mod/registry_name (or if another mod uses your registry: data/their_mod/my_mod/registry_name. To register this registry, subscribe to the DataPackRegistryEvent.NewRegistry event on the MOD event bus and call event.dataPackRegistry() for every registry you have. An example of what I'm doing for my mod (this is in the constructor for the main mod file): IEventBus bus = FMLJavaModLoadingContext.get().getModEventBus(); bus.addListener((DataPackRegistryEvent.NewRegistry event) -> { event.dataPackRegistry(ModRegistries.INSULATOR_DATA, InsulatorData.CODEC); }); CODEC is a public static field inside the class for the custom data type I am registering. It holds a Codec<InsulatorData> that tells Minecraft how to serialize/deserialize the data. Most of my data so far can be represented by records, so I use RecordCodecBuilder.create() to do this: public static final Codec<InsulatorData> CODEC = RecordCodecBuilder.create(instance -> instance.group( // Yadda yadda ).apply(instance, InsulatorData::new)); What exactly to put here depends on what you're trying to do, so that's up to you. But basically you're just defining a list of codecs that correspond to the parameters of the record (data type). Most primitive data types have records in the Codec class (ex. Codec.INT) that you can use, and other classes like ResourceLocation have their own codecs as a static field (ex. ResourceLocation.CODEC). Hopefully this is what you're looking for, and that this helps.
    • Good days  I finnaly manage to fix and get a working gui from BlockItem and from BlockEntity the next issues i have to fix is this the block Entity model for some reason is moved to the south west  this briefcase model must be centered but is moved to a side, i have nothing weird in the code but this is happening // ########## ########## ########## ########## @Override public RenderShape getRenderShape(BlockState blkstate) {     return RenderShape.MODEL; } the block model is out of place However The hitBox of the block is right in place   ########################################################################################################### This next issue  Mi gui also adds the 5 slots from the player equipment the thing is theres no filter to determine whats can be put in an armor slot and what not      i have this method that draws the slots for the armor, the part i dont get i slike wheres the code that responds when you set an item in a item slot to do checks and allow the item to be set or not  //########## ########## ########## //Draw Player Armor private void addPlayerArmorSlots(Inventory playerInventory) { // 36 this.addSlot(new Slot(playerInventory, 39, 8, 8)); this.addSlot(new Slot(playerInventory, 38, 8, 26)); this.addSlot(new Slot(playerInventory, 37, 8, 44)); this.addSlot(new Slot(playerInventory, 36, 8, 62)); this.addSlot(new Slot(playerInventory, 40, 26, 53)); }   theres must be a method that triggers when you set a itemstack inside an slot and allows to do a check if its a valid item for that slot                                             
    • No like how do I use my new PreperableReloadListener, I know how to set it up now and register it, I just need to know how to use it in other classes.
    • Completely out of the blue my forge loader is lagging, although at 120 fps. Like when I turn it lags, or hit mobs it lags, or run sometimes although staying at 120 fps. I found another person having a similar problem:  But there was no solution I dont think. I tried everything from: 1. Updating my computer 2. Updating/reinstalling forge 3. Testing if allocated memory was problem (if it was low or high or mid nothing changed) 4. Adding various performance mods 5. Deleting most of my profiles if storage was a problem.   Really not sure what to do next or if forge is just broken for ever for me now.  
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.