• Recently Browsing

    No registered users viewing this page.

  • Posts

    • Ok so I've heard that if you download the library files from the Error window, they should one by one not appear on the error window anymore. It worked for me, but there is this one file that doesn't seem to work. It is "de.oceanlabs.mcp:mcp_config:1.16.1-20200625.160719@zip". I've also went to the forge website to download it, I saw it and downloaded it and put it in the folder where it is supposed to be. And when I tried to download forge, it still said that library was failed to download. I've even tried renaming it to .zip and .jar. It is a folder though so that might be the problem. Anyways, I really need help. If someone could help and respond to me it would be appreciated!   Also here's the error log (the second one, not the first) forge-1.16.1-32.0.61-installer.jar.log
    • Hello, I've been having a problem with the newer versions of forge like 1.15.2 and 1.16. Every time I try to start minecraft with forge it always crashes on me. I've updated java and also my drivers. I also add a little bit of extra ram to minecraft but it still doesn't seem to work. I have nothing in my mods folder as well. What's weird is that older versions of minecraft like 1.12.2 work perfectly on forge. I'm not sure what's going on, but I would love if someone can help me. Thank you :)
    • Hey, guys. So, I'm entering the world of Minecraft Modding now and have some doubts. I'm learning through O'Reilly's book, but the forgw version he uses is fairly old (I develop in the Forge 1.14.4). I'm in a part of the book that I need to change the MotionY and the best solution I came was this one:   package mod.stardev.mod1.init; import mod.stardev.mod1.tutorialmod; import net.minecraft.entity.player.PlayerEntity; import net.minecraft.util.math.Vec3d; import net.minecraftforge.event.entity.living.LivingEvent; import net.minecraftforge.fml.common.Mod; @Mod.EventBusSubscriber(modid = tutorialmod.MODID, bus = Mod.EventBusSubscriber.Bus.FORGE) public class supers { public static void superjump(LivingEvent.LivingJumpEvent event) { if (!(event.getEntity() instanceof PlayerEntity)) { return; } PlayerEntity player = (PlayerEntity) event.getEntity(); Vec3d v = player.getMotion(); player.setMotion(v.x, v.y * 5.0D, v.z); } }   But it's not working, no matter what I change. Please, help me.   The Main file:   package mod.stardev.mod1; import net.minecraftforge.fml.common.Mod; import org.apache.logging.log4j.LogManager; import org.apache.logging.log4j.Logger; @Mod(tutorialmod.MODID) public final class tutorialmod { public static final String MODID = "tutorialmod"; public static final Logger LOGGER = LogManager.getLogger(MODID); public tutorialmod() { LOGGER.debug("Hello from TutorialMod."); } }
    • https://github.com/MistaOmega/Opes/blob/master/src/main/java/mistaomega/opes/tiles/GrinderTile.java#L79 You need to clone this stack or things will go very wrong indeed.   https://github.com/MistaOmega/Opes/blob/master/src/main/java/mistaomega/lib/inventory/outputStackHandler.java#L7 This class should start with a capital letter to follow naming convention   https://github.com/MistaOmega/Opes/blob/master/src/main/java/mistaomega/lib/inventory/outputStackHandler.java#L17 You do not need to override this method, you're not doing anything that the base implementation does not already do.   https://github.com/MistaOmega/Opes/blob/master/src/main/java/mistaomega/lib/inventory/ProcessingBlockItemHandler.java#L10 This comment is objectively wrong. The int passed there is how many slots the handler has, so this "won't be shown" stuff is bollocs.   https://github.com/MistaOmega/Opes/blob/master/src/main/java/mistaomega/opes/tiles/GrinderTile.java#L80 This line assumes that all outputs are size 1. This may or may not be true.   And finally, you have no data assets which use your recipe type, but the above issues not withstanding, your grinder is compatible with any mod that has a recipe that matches your grinder recipe.
    • Because you never know when a static block will execute, and if it executes too early, Forge can't insure that it has full control over the object. (Forge does lots of lots of behind the scenes magic and dangerous sorcery that you, as a modder, don't need to worry about, but that if it isn't done in order, things break)
  • Topics

  • Who's Online (See full list)