• Recently Browsing

    No registered users viewing this page.

  • Posts

    • Alright, but I don't think any of the server stuff changes too much with the version, I just need a hand
    • You won't get any support since 1.12.x is not supported any more on this forum you need to use a higher version of minecraft 1.14.x - 1.16.1 Note: If anyone would help you they would need your debug.log log and not this one
    • Hello! I am still very new to creating servers but today I was trying to make one so that me and my brother could play with mods. I created a forge server and allowed it to install, I also made a run.bat file though had to delete it afterwards as it stopped working, not sure why. Now the server itself does work, but whenever I try to place a modded block it just seems to vanish here are my latest logs:  [19:21:45] [Server thread/INFO]: Starting minecraft server version 1.12.2 [19:21:45] [Server thread/INFO]: Loading properties [19:21:45] [Server console handler/ERROR]: Exception handling console input java.io.IOException: The handle is invalid     at java.io.FileInputStream.readBytes(Native Method) ~[?:?]     at java.io.FileInputStream.read(Unknown Source) ~[?:?]     at java.io.BufferedInputStream.read1(Unknown Source) ~[?:?]     at java.io.BufferedInputStream.read(Unknown Source) ~[?:?]     at sun.nio.cs.StreamDecoder.readBytes(Unknown Source) ~[?:?]     at sun.nio.cs.StreamDecoder.implRead(Unknown Source) ~[?:?]     at sun.nio.cs.StreamDecoder.read(Unknown Source) ~[?:?]     at java.io.InputStreamReader.read(Unknown Source) ~[?:?]     at java.io.BufferedReader.fill(Unknown Source) ~[?:?]     at java.io.BufferedReader.readLine(Unknown Source) ~[?:?]     at java.io.BufferedReader.readLine(Unknown Source) ~[?:?]     at nz$2.run(SourceFile:100) [minecraft_server.1.12.2.jar:?] [19:21:45] [Server thread/INFO]: Default game type: SURVIVAL [19:21:45] [Server thread/INFO]: Generating keypair [19:21:45] [Server thread/INFO]: Starting Minecraft server on 192.168.0.150:25565 [19:21:45] [Server thread/INFO]: Using default channel type [19:21:46] [Server thread/INFO]: Preparing level "world" [19:21:46] [Server thread/INFO]: Loaded 488 advancements [19:21:46] [Server thread/INFO]: Preparing start region for level 0 [19:21:47] [Server thread/INFO]: Preparing spawn area: 48% [19:21:48] [Server thread/INFO]: Done (1.771s)! For help, type "help" or "?" [19:22:01] [User Authenticator #1/INFO]: UUID of player Nyxistaken is 0609cbac-80f9-45a0-8fe0-0c261d3ef31b [19:22:01] [Server thread/INFO]: Nyxistaken[/192.168.0.150:55368] logged in with entity id 190 at (37.5, 63.0, 252.5) [19:22:01] [Server thread/INFO]: Nyxistaken joined the game [19:22:33] [Server thread/INFO]: Set Nyxistaken's game mode to Survival Mode [19:22:47] [Server thread/INFO]: Set Nyxistaken's game mode to Creative Mode I have about 13 mods that I am using including an NPC mod and the Aether mod. My brother has these installed as well, I have them installed on my main game and in the server folder so I'm not sure why it isn't working
    • I am rendering an entity in 1.16.2, but the texture is getting FileNotFoundExceptions. I added loot tables and lang files but they didn't work either, so I think my resource folder is just not getting recognized. I made sure everything in my java code is correct, such as modid, but I'm not too sure about build.gradle and the other non-java files. Here is my build.gradle:  buildscript { repositories { maven { url = 'https://files.minecraftforge.net/maven' } jcenter() mavenCentral() } dependencies { classpath group: 'net.minecraftforge.gradle', name: 'ForgeGradle', version: '3.+', changing: true } } apply plugin: 'net.minecraftforge.gradle' apply plugin: 'eclipse' apply plugin: 'maven-publish' version = '1.16.2-0.9.0.0' group = 'com.david.minecraft.testmod' archivesBaseName = 'testmod' sourceCompatibility = targetCompatibility = compileJava.sourceCompatibility = compileJava.targetCompatibility = '1.8' println('Java: ' + System.getProperty('java.version') + ' JVM: ' + System.getProperty('java.vm.version') + '(' + System.getProperty('java.vendor') + ') Arch: ' + System.getProperty('os.arch')) minecraft { mappings channel: 'snapshot', version: '20200514-1.16' runs { client { workingDirectory project.file('run') property 'forge.logging.markers', 'SCAN,REGISTRIES,REGISTRYDUMP' property 'forge.logging.console.level', 'debug' mods { testmod { source sourceSets.main } } } server { workingDirectory project.file('run') property 'forge.logging.markers', 'SCAN,REGISTRIES,REGISTRYDUMP' property 'forge.logging.console.level', 'debug' mods { testmod { source sourceSets.main } } } data { workingDirectory project.file('run') property 'forge.logging.markers', 'SCAN,REGISTRIES,REGISTRYDUMP' property 'forge.logging.console.level', 'debug' args '--mod', 'testmod', '--all', '--output', file('src/generated/resources/') mods { testmod { source sourceSets.main } } } } } dependencies { minecraft 'net.minecraftforge:forge:1.16.2-33.0.3' } jar { manifest { attributes([ "Specification-Title" : "testmod", "Specification-Vendor" : "david", "Specification-Version" : "1", "Implementation-Title" : project.name, "Implementation-Version" : "${version}", "Implementation-Vendor" : "david", "Implementation-Timestamp": new Date().format("yyyy-MM-dd'T'HH:mm:ssZ") ]) } } jar.finalizedBy('reobfJar') publishing { publications { mavenJava(MavenPublication) { artifact jar } } repositories { maven { url "file:///${project.projectDir}/mcmodsrepo" } } } What have I done wrong?
  • Topics

  • Who's Online (See full list)