Jump to content

Armor texture is janky - 1.15.2


Recommended Posts

So blah blah blah I'm doing custom armor models, the models are done in Tabula and then manually edited so it works for this version. Anyways the model and textures all look good and the texture offsets are set correctly, as can be seen here:




And then in my model class everything is parented correctly, and renders. However, I noticed that there are random texture artifacts for some reason in-game. This happens on every armor piece, this one is without the chestplate:




I thought it might be some kind of texture offset problem so I tried making the texture size bigger and more spread out, but it still happens. What could be causing this?


Link to comment
Share on other sites

Post your code.

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.


Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.


DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

12 hours ago, Draco18s said:

Post your code.

This is the model straight from Tabula, body and leg are on separate textures too:

        this.textureWidth = 64;
        this.textureHeight = 64;

        this.ll_shoulder_r = new ModelRenderer(this, 36, 8);
        this.ll_shoulder_r.mirror = true;
        this.ll_shoulder_r.setRotationPoint(0.0F, 0.0F, 0.0F);
        this.ll_shoulder_r.addBox(-4.0F, -2.5F, -2.5F, 5, 5, 5, 0.0F);
        this.ll_elbow_l = new ModelRenderer(this, 0, 18);
        this.ll_elbow_l.mirror = true;
        this.ll_elbow_l.setRotationPoint(3.0F, 3.0F, 0.0F);
        this.ll_elbow_l.addBox(-1.0F, 0.0F, -2.5F, 2, 2, 5, 0.0F);
        this.ll_elbow_r = new ModelRenderer(this, 0, 18);
        this.ll_elbow_r.mirror = true;
        this.ll_elbow_r.setRotationPoint(-3.0F, 3.0F, 0.0F);
        this.ll_elbow_r.addBox(-1.0F, 0.0F, -2.5F, 2, 2, 5, 0.0F);
        this.ll_collar = new ModelRenderer(this, 0, 35);
        this.ll_collar.setRotationPoint(0.0F, 0.0F, 0.0F);
        this.ll_collar.addBox(-4.5F, -1.0F, -2.0F, 9, 3, 5, 0.0F);
        this.ll_hair = new ModelRenderer(this, 0, 53);
        this.ll_hair.setRotationPoint(0.0F, -9.0F, 0.0F);
        this.ll_hair.addBox(-0.5F, -1.0F, -0.5F, 1, 1, 5, 0.0F);
        this.ll_torso = new ModelRenderer(this, 14, 18);
        this.ll_torso.setRotationPoint(0.0F, 0.0F, 0.0F);
        this.ll_torso.addBox(-4.5F, 0.0F, -2.5F, 9, 12, 5, 0.0F);
        this.ll_helm = new ModelRenderer(this, 0, 0);
        this.ll_helm.setRotationPoint(0.0F, 0.0F, 0.0F);
        this.ll_helm.addBox(-4.5F, -9.0F, -4.5F, 9, 9, 9, 0.0F);
        this.ll_shoulder_l = new ModelRenderer(this, 36, 8);
        this.ll_shoulder_l.setRotationPoint(0.0F, 0.0F, 0.0F);
        this.ll_shoulder_l.addBox(-1.0F, -2.5F, -2.5F, 5, 5, 5, 0.0F);

        this.ll_leg_r = new ModelRenderer(this, 0, 0);
        this.ll_leg_r.setRotationPoint(0.0F, 0.0F, 0.0F);
        this.ll_leg_r.addBox(-3.0F, 0.0F, -2.5F, 5, 6, 5, 0.0F);
        this.ll_leg_l = new ModelRenderer(this, 0, 0);
        this.ll_leg_l.mirror = true;
        this.ll_leg_l.setRotationPoint(0.0F, 0.0F, 0.0F);
        this.ll_leg_l.addBox(-2.0F, 0.0F, -2.5F, 5, 6, 5, 0.0F);
        this.ll_foot_r = new ModelRenderer(this, 0, 43);
        this.ll_foot_r.setRotationPoint(0.0F, 7.0F, 0.0F);
        this.ll_foot_r.addBox(-3.0F, 0.0F, -2.5F, 5, 5, 5, 0.0F);
        this.ll_foot_l = new ModelRenderer(this, 0, 43);
        this.ll_foot_l.mirror = true;
        this.ll_foot_l.setRotationPoint(0.0F, 7.0F, 0.0F);
        this.ll_foot_l.addBox(-2.0F, 0.0F, -2.5F, 5, 5, 5, 0.0F);


        if (legs)


Then in my item file, I literally just return the armor model (returning null if the equipment slot is empty). I even tried giving the helmet its own separate texture and while everything else is fixed, another cube inside the head gets rendered as well: 



As you can see, the helmet itself renders fine, but inside it there's another cube that uses the helmet texture but messes it all up.

Link to comment
Share on other sites

I went and commented out the part where the player model parts are parented to my armor parts (so I expected the armor NOT to render), but this is the result:




These are the parts that are rendering underneath my armors in the pics above. So bizzarre, I can't figure out what to make of this.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.