• Recently Browsing

    No registered users viewing this page.

  • Posts

    • I have an eclipse gradle project with a Minecraft mod dealing with ore generation and I want to add the Advanced Xray Mod by Error_MiKeY for testing purposes. I'm not planning on distributing his mod with mine, I just want to be able to test my mod within my workspace without having to build a jar file and put both files into actual Minecraft and run it there every time I want to test something. What I've tried and what sometimes works with other mods is adding the mod's .jar file to the run\mods folder. However, when I put the Advanced Xray mod in there, I get "Advanced Xray has class loading errors" (crash report here). The mod calls a method called Minecraft.func_7140_x(), and it returns a NoSuchMethod error, even though both mods are on the same version 1.16.4. They both work when I build my mod and add it to the mod files in Minecraft and run it on the actual game, so why doesn't it work here? Is it because my workspace is set up incorrectly? I heard that it's because it's not deobfuscated, but I'm not sure how to deobfuscate it without a tool like BON2 to do it for me and I can only go up to 1.15 on that. I've researched it and I heard that you can also put a dependency on your build.gradle file and it will download it online. I don't really have an understanding of how it works so I got lost in this step. What URL do I put? The mod is on GitHub, so do I add a GitHub repository with the link to the GitHub and grab it from there? I'm not sure. I also heard another way to add a dependency is to add a libs folder on your project root directory and put it there. By that do they mean making a new libs folder on the outermost layer where the build, settings, and src folders are or are they talking about the libs folder in \build? If the former, I tried making a libs folder like this and then I added the .jar file to it but nothing happened. I clearly don't know what I'm doing so don't overestimate how many things I know lol.   I'd appreciate any help, thanks.
    • 1.12 is no longer supported on this forum. Please update to a modern version of Minecraft to receive support.
    • So I downloaded FTB revelation 3.2.0 server from curseforge site configured everything and turned it on. After me and my friends joined and tried to craft crafting station which is modded item we couldn't craft. then we tried and took copper through creative and when we clicked crafting table copper dissapeared.
    • 1.12 is no longer supported on this forum. Please update to a modern version of Minecraft to receive support.
    • Some zip managers like to take control of the .jar file extension away from Java. Make sure you have Java installed and try running Jarfix once, then try the installer again.
  • Topics

  • Who's Online (See full list)