Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Item name and texture not showing up VER 1.16.4


GiovanniStella
 Share

Recommended Posts

Hello, I started modding a few days ago and now I'm trying to add a new Item just for testing but for some reason the name on en_us.json, and my texture are not showing up in game. It only shows the java name of the item like (item.keanumod.card). I have tried multiple things but none of them worked. Tried :

1- Changing text the text file enconding. (to UFT-8)

2- Changing workspace in Eclipse

3- Downloaded IntelliJ, and the same thing happened

4- I did re-write the whole again, and it still did not work.

5- And tried to change the text format in .jsons to old ones like ""="" instead of "":"" in en_us.json

This is my en_us.json

{
    "item.keanumod.card":"Delayed Card"
}

=================================================================

card.json :

{
  "parent": "item/generated",
  "textures": {
    "layer0": "keanumod:items/card"
  }
}

==========================================================================

A print of my structure https://prnt.sc/vv7bmj

============================================================================

latest log:

https://pastebin.pl/view/8b79ffa8

==============================================================================

Just to clarify, the item shows up on my world but withou any texture and named "item.keanumod.card". 

Thanks to anyone who did read, I would love some help. 

 

Edited by GiovanniStella
forgot the latest log
Link to comment
Share on other sites

31 minutes ago, diesieben07 said:

It should be neither .class, nor .jar nor .txt files.

Please simply create a git repository in your project root (where your build.gradle is) and push. The MDK comes with a .gitignore file which will ignore any unneeded files.

Its my first time doing this, and i cannot believe i actually did it. Here it is : https://github.com/GigiTeddy/Test1

 

Link to comment
Share on other sites

26 minutes ago, GiovanniStella said:

Its my first time doing this, and i cannot believe i actually did it. Here it is : https://github.com/GigiTeddy/Test1

 

Code Style 5

Don't create an ItemBase class, when registering call new Item, and pass the properties to the constructor. If you want to save a few keystrokes you can write a utility method that simply return the default ItemProperties that you want.

Additionally, you should be using Data Generators to generate the ItemModel files, if you want to know more about them, this comment has a few useful links that explain how to use them: https://forums.minecraftforge.net/topic/94402-generated/?tab=comments#comment-432933

 

Link to comment
Share on other sites

2 minutes ago, diesieben07 said:

You set showAsResourcePack to true, which means your mod will be its own resource pack, which needs to be separately enabled. If you enable it, your model works.

Dude, you are a LEGEND. Thank you so much, it worked. I don't actually remember writing it down but anyways. Thanks to everyone that posted here!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.