• Recently Browsing

    No registered users viewing this page.

  • Posts

    • Here: "Config variable that will not update" is the variable that I'm trying to access. It simply reverts to the default value.   // Do something when certain thing is said in chat public static final Minecraft mc = Minecraft.getInstance(); boolean serverFound = false; @SubscribeEvent public void onChat (ClientChatReceivedEvent event) { // Logger LOGGER.info("serverFound is now " + serverFound); String message = event.getMessage().getString(); if (message.contains("CONFIG VARIABLE THAT WILL NOT UPDATE")) { serverFound = true; // Logger LOGGER.info("serverFound has been set to true"); } if ((message.contains("entered the world.") && serverFound) == true) { // Logger LOGGER.info("serverFound is now true"); Minecraft.getInstance().player.sendChatMessage("/teleport 0 150 0"); serverFound = false; // Logger LOGGER.info("serverFound has been set to false"); } } }  
    • I have registered blocks for both a Standing Sign, and Wall Sign and I have registered an item for the sign. I did reflection for registering a wood type, and am using this wood type in the signs I have the texture for the wood type under textures/entity/signs and I have created the blockstate and model files, copying the vanilla ones (where the blockstates point to a model file that only has a texture for particles)   However, the Sign still won't render, and the edit sign screen won't show up. Sometimes the game crashes when I place a sign, with a NPE, but it isn't consistent.   Sign block registration: EFFETE_SIGN = registerNoItem("effete_sign", () -> new StandingSignBlock( AbstractBlock.Properties.create(Material.NETHER_WOOD, MaterialColor.LIME) .doesNotBlockMovement().hardnessAndResistance(1.0F).sound(SoundType.WOOD), Main.EFFETE_WOOD_TYPE)); EFFETE_WALL_SIGN = registerNoItem("effete_wall_sign", () -> new WallSignBlock( AbstractBlock.Properties.create(Material.NETHER_WOOD, MaterialColor.LIME) .doesNotBlockMovement().hardnessAndResistance(1.0F).sound(SoundType.WOOD).lootFrom(EFFETE_SIGN.get()), Main.EFFETE_WOOD_TYPE));   Blockstate and model files: { "textures": { "particle": "effetewood:block/effete_planks" } } { "variants": { "": { "model": "effetewood:block/effete_sign" } } }   Wood Type registration and Reflection code: private void setup(final FMLCommonSetupEvent event) { reflectionSetup(); try { EFFETE_WOOD_TYPE = (WoodType) registerWoodTypeMethod.invoke(null, woodTypeConstructor.newInstance("effete")); } catch (Exception e) { LOGGER.error("Error registering wood type"); e.printStackTrace(); } } private void reflectionSetup() { if (woodTypeConstructor != null) woodTypeConstructor.setAccessible(true); if (registerWoodTypeMethod != null) registerWoodTypeMethod.setAccessible(true); } private static final Constructor<WoodType> woodTypeConstructor; private static final Method registerWoodTypeMethod; private static Constructor<WoodType> getWoodTypeConstructor() { try { return WoodType.class.getDeclaredConstructor(String.class); } catch (Exception e) { LOGGER.error("Exception in getWoodTypeConstructor: " + e.getMessage()); e.printStackTrace(); return null; } } private static Method getRegisterWoodTypeMethod(){ try { return WoodType.class.getDeclaredMethod("register", WoodType.class); } catch (Exception e) { LOGGER.error("Exception in getRegisterWoodTypeMethod: " + e.getMessage()); e.printStackTrace(); return null; } } static { woodTypeConstructor = getWoodTypeConstructor(); registerWoodTypeMethod = getRegisterWoodTypeMethod(); }  
    • First of all, which I assume you know, is that the computer must always be on from which the server is being hosted. Secondly what kind of computer is this? If it has a GUI (like windows or mac and some distributions of linux/ubuntu/debian) it will make things much easier for changing things to the correct setting. Third, I would like to know what the desired outcome is, and what mods you have installed, forge version, debug.log, ETC, the basics.   For Biomes O' Plenty, you have to make sure that the world type is set to a Biomes O' Plenty world type. So you'll have to reset your world.   And finally, I assume you know that most mods MUST be on both the client and server for it to function properly. So for example, if you want lucky blocks, that must be in the server mods folder, AND in your .minecraft mod folder.   For me to fully finish helping you I need the rest of the information that I stated above.   Cheers,        Foonicular
    • You probably won't receive any help from the official forge dev team, and I don't know how what's going on with that, so you may not get an answer for this. I could recommend using buttons around the sprint key (for commonly used slots) and using numbers for the rest.
    • So I downloaded Forge 1.8.9 and installed the SBA mod (SkyBlockAddons) I have my key binds set for pvp as “Button 5” for the first slot and “Button 4” for the second slot (might be the other way around. Not sure). These are mouse side buttons   So whilst I’m sprinting i try to switch my slots but it won’t let me it’ll just go to the slot number 2 for both my key binds (this is on Forge 1.8.9 still)   (Bare in mind, any other client. My keybinds work perfectly fine. No problem)   But when I stop sprinting, I can change it with that set keybind   I don’t know what’s going on. But if someone could help me that would be amazing!!
  • Topics

  • Who's Online (See full list)