Jump to content

Can't Load World | Error in Datapacks + Previous Buggy Behavior

Recommended Posts


When trying to load a world that was created with mods, I get the following error:


Errors in currently selected datapacks prevented the world from loading.
You can either try to load it with only the vanilla datapack ("safe mode", or go
back to the title screen and fix it manually.


I get to option buttons - Safe Mode and Back to the Title Screen

Clicking on Safe Mode doesn't work - when I hover it, there's a border around it, and when I click on it it stays for a few seconds, and then disappears, with nothing else happening.

Before I had this problem I had another problem - I'll describe what I had earlier, what I did to come to this state, and I attached logs to this post at its bottom.

I played the game for some time, v1.6.15, with Forge build 1.16.5-forge-36.0.54, build with 25 mods (Quark among them, in case it matters), and it worked, with one one exception, though, that I got every time, that it said that the world was using experimental settings or something like that, and gave me to options - either "I know what I'm doing" or "Create a Backup" - and I created a backup every single time, and it worked just fine.


I played aboveground mostly, lowest I've gone down was exploring in existing cave systems.

The only new thing I did in the game compared to the last time it worked before freezing was that I started mining deep underground - and it did seem a bit strange to me - there was bedrock at around y=0 instead of at lower (could have been due to mods), and on the minimap I was using (Xaero's minimap) - it showed deep-enough just black in some parts, between lava chambers - the exposed part of that darkness was just regular cobblestone/ores, and only when I mined those blocks it displayed them on the map (drew them over the blackness). I was told by someone in the Forge Discord server that those features don't exist in 1.16.5, so I assume that they came from mods. I do remember that Quark has some underground features, in particular new underground biomes.

Today, for whatever reason, when I tried launching the same world, it froze when I clicked on Create a Backup, and it kept doing that.
I reinstalled Forge (same build) and kept getting the same problem.
I reinstalled Minecraft and kept getting the problem.

I tried playing with no mods at all - kept getting the same problem.

Only when I removed Forge completely and played vanilla the world loaded succesfully - with the warning of the experimental settings again - but it works in vanilla just fine.


I then tried debugging the mods, and found out the Mods section in the client that some mod features were disabled due to not-up-to-date Java installation, so I pointed the Forge profile to a latest-version Java installation, and then those warnings/errors about those features being deactivated disappeared.

I tried starting the world again in the Forge profile, and it didn't work.

Today, as I was doing this, a new version of Forge was released, 1.16.5-forge-36.0.55 so I installed it. It didn't help and got me to my current problem about datapacks. I checked my save's folder's datapacks folder, but it's empty. I also checked in NBTExplorer in my save's data in level.dat > Data > DataPacks > Enabled, and there's only 1 entry, and that's vanillaThere are 0 datapacks disabled, in case it matters.

I tried in both this one and in  1.16.5-forge-36.0.54 to open the world and it didn't work.

I tried also recreating the world, opening the world in vanilla, modifying the world (destroyed a block, picked up a few blocks) and saving it, recreating the world, trying a new save file - none of them worked.

I suspect that the problem was due Quark or some mod/setting(s) corrupting the save file with some weird generation, but I don't know neither how to verify it nor how to debug it or fix it.


I attached the full logs (all the logs I have, didn't touch anything).

I'd highly appreciate help with this - out of the blue all of my progress and work is inaccessible for me.



Link to comment
Share on other sites

Hi, @diesieben07, thanks for the comment. :)

I installed build  
1.16.5-forge-36.0.46 but it doesn't work for me - I just downloaded the installer, installed it (client installation), launched the game's launcher - it created a new profile succesfully for this build, and I now I get the experimetal features error that freezes the game again.

Link to comment
Share on other sites

32 minutes ago, diesieben07 said:

This file is invalid. If you didn't change it, just delete it.

Why do you think it's invalid and what do you think is invalid about it?
Also, I deleted it and ran the game in 1.16.5-forge-36.0.46 and got the same error and it froze again.
I attached logs again (updated to the time of writing this).



Link to comment
Share on other sites

4 minutes ago, diesieben07 said:

Are you sure you deleted it? From the log it looks like it existed when you started the game.

What makes me think that it is invalid is that the log file says so.

I did delete it initially. I had serverconfig open while I was opening and running the game and refreshed it after every step (opening the launcher, finished loading, etc.) - it didn't get re-created at any point, however I noticed that either when the game froze or after it closed (I force-closed it), then it got re-created. Do you want me to remove the mod and the config file?

Also, which log file says so and what exactly does it say? Could you please point me to it?


Edited by GalGreenfield
Link to comment
Share on other sites

Just now, diesieben07 said:

The mod is still installed and the file still fails to load.

That's very weird. When I load the game it says that I have 24 mods installed (had 25 before I removed that one).
It's a part of a family of mods, I'll try to remove them all.
And couldn't it be that it's just a dependency of the save and isn't installed?

Link to comment
Share on other sites

I deleted that family of mods - still the same behavior - they can be restored at any point so it's okay.
I tried deleting logs but Windows (am using Windows) tells me that it's being used - I don't know where, since I clsoed Minecraft and all Java processes I'm aware of.
I was able to delete its contents, though. 
I ran the game again - same behavior. I attached 
debug.log below.


Link to comment
Share on other sites

Just now, diesieben07 said:

It is a different file now:


So that's progress. If you didn't modify any of the files in the serverconfig folder, delete the whole folder. Then start the game again.

Holy hell, thank you so much - it worked!!! :D

Would you mind verifying with me the reason for this corruption? So I can try to prevent it.

Link to comment
Share on other sites

Just now, diesieben07 said:

To be honest: We do not know.

Sometimes it happens that the config files become... unreadable. Unfortunately nobody in the Forge team has reproduced this on their machines so far, so the only solution we know is to just delete the invalid files so they get recreated correctly.

Hm, I understand. And the way you debug what files are invalid is with what kind of errors in the logs? Just so I know what to look for in the future.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.