Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

How can I expand upon a existing Mod?


Bloodheaven
 Share

Recommended Posts

Hey there,

 

[1.16.5-36.0.58] + [IntelliJ IDEA]

how can I interact with Mods in my own created Mod?

For example If I want to add a Crafting Recipe with a specific Item / Block from a different Mod that results in one of my custom made Items.

I tried to put the Different_Mod.jar in "Workspace\ModName\run\mods" but that doesnt seem to work it always ends up in a crash if I try to start the Project. (Is it normal that if you put mods in there it starts to crash when trying to launch?)

 

Anyone here that can help me out?

 

PS: Image below is just when I start to add the Different_Mod.jar in the mods folder within the Project, frequently happens to any mod I put in there.

weird.png

Edited by Bloodheaven
Link to comment
Share on other sites

13 hours ago, diesieben07 said:

You have to use fg.deobf in your gradle dependency, because mods get obfuscated when building and cannot work in a dev env anymore after that.

 

13 hours ago, diesieben07 said:

You have to use fg.deobf in your gradle dependency, because mods get obfuscated when building and cannot work in a dev env anymore after that.

I dont seem to find it, do you mean in this box in the picture? I am quite new in creating Mods.

dunno.png

Link to comment
Share on other sites

1 hour ago, diesieben07 said:

No, in your build.gradle.

How did you add the mod to your workspace?

I did not add the mod to the workspace because I dont know how to, I cant simply add a .jar file to a project or can I? Or do I have to put the .class files inside the .jar file into my project and if so how would I approach this?

 

PS: I just downloaded the MDK renamed it, opened IntelliJ open as Project it started downloading and then I went through some mod creation tutorials.

Edited by Bloodheaven
Additional Info
Link to comment
Share on other sites

It's worth noting that you'll need to find "Different Mod"'s gradle repository (in my case jitpack), and add it to your dependencies. (If you haven't removed them already, there will be a bunch of comments here with examples too.)

Here I am importing a (currently unreleased) mod of mine called LabKore on version 1.3.0-SNAPSHOT from GitHub.

repositories {
	maven { url 'https://jitpack.io' }
}

dependencies {
    minecraft 'net.minecraftforge:forge:1.16.5-36.0.54'
	
    implementation fg.deobf('com.github.ThatBlockyPenguin:LabKore:v1.3.0-SNAPSHOT')
}

 

I hope that helps!

Today (22/10/20) I reached 100 posts!

I'm probably more excited than I should be for something so realistically minor...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Here is my configuration: % java -version java version "18.0.2" 2022-07-19 Java(TM) SE Runtime Environment (build 18.0.2+9-61) Java HotSpot(TM) 64-Bit Server VM (build 18.0.2+9-61, mixed mode, sharing) forge-1.19-41.1.0-mdk on macOS Monterey 12.5 I ran the command: ./gradlew genEclipseRuns and was hoping it will generate the Eclipse project files for me. The run log is at https://gist.github.com/arun-gupta/06b983a6976b4c0a0f510d0dc225ddd3 and the generated directory structure is at https://gist.github.com/arun-gupta/3f5bfc70ec5d3d903b0f97d42840abda. In previous versions (1.12-ish), it used to generate an eclipse directory but 1.19 does not seem to have it. I tried opening the top-level forge directory but Eclipse does not recognize it as a project as well. How do I open this project in Eclipse now?  
    • I didn't put in credentials, I used it only for testing installing forge. But still the problem mentioned above.
    • I am trying to use Forge 1.18.2, I have checked my firewall, redownloaded Forge, deleted the fml.toml file (which keeps reappearing) and looked at countless help pages. I am just trying to download and use forge so that I can play with my friends and it will not download. It tells me there may be an issue with the Java runtime config and that the exit code is one, and I have copied the exit code.   
    • Okay, i think i understand but im getting issues, i create another packet to sync entity to another players like this package com.naim.belloto.networking.packet; import com.naim.belloto.networking.handler.ClientSyncHandler; import net.minecraft.client.Minecraft; import net.minecraft.network.FriendlyByteBuf; import net.minecraftforge.api.distmarker.Dist; import net.minecraftforge.fml.DistExecutor; import net.minecraftforge.network.NetworkEvent; import java.util.Objects; import java.util.function.Supplier; public class ClientSyncPacket { public ClientSyncPacket() { } public ClientSyncPacket(FriendlyByteBuf buf) { } public void toBytes(FriendlyByteBuf buf) { } public boolean handle(Supplier<NetworkEvent.Context> ctx) { NetworkEvent.Context context = ctx.get(); context.enqueueWork(() -> { assert Minecraft.getInstance().player != null; int idplayer = Minecraft.getInstance().player.getId(); DistExecutor.unsafeCallWhenOn(Dist.CLIENT,() -> () -> ClientSyncHandler.handlePacket(ctx, idplayer)); }); return true; } } And in the handler: public class ClientSyncHandler { public static boolean handlePacket(Supplier<NetworkEvent.Context> ctx, int idPlayer) { Minecraft.getInstance().level.getEntity(idPlayer); return true; } } But is not working :// 
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.