Jump to content

Providing the .zip as well as installer


Deathspell55555
 Share

Recommended Posts

Zips are jars so there's that.

And just magically being a zip doesn't make you compatible with things.

So no... we'll keep the format we have.Times change, this new system was developed along side Mojang to directly fix a lot of issues that the old system caused.

And in actually makes life a lot easier for majority of users.

 

it is rather simple for Base editing mods to move to Forge and our open source installing system.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Patreon: http://www.patreon.com/lexmanos
Paypal: http://paypal.me/LexManos

BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn

Link to comment
Share on other sites

Yes, just because you do things one way doesn't mean you're the majority.

And no we didn't make it didn't to help rare cases, it was actually a really common case because sadly most people don't know how to use archival tools.

As you're demonstrating now, by the fact that you don't know a jar IS a zip file. -.-

Your problem isn't a problem with Forge. You simply don't understand how the new system works.

Explain to me how having a '.zip' file helps you?

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Patreon: http://www.patreon.com/lexmanos
Paypal: http://paypal.me/LexManos

BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn

Link to comment
Share on other sites

Easy enough to fix: Rename the file so the extension is .zip instead of .jar...if you REALLY need a .zip file. But you don't.

 

Note that the OP said he is using Magic Launcher. Magic Launcher does not require mods to have a .zip extension, you can use .jar files. The important thing is that you have a clean minecraft.jar file (which you can specify), it's modloader to be first, then forge, then your mods.

 

To the OP: Honestly, take a few minutes to learn the new launcher, it will work well for what you need. The only problem is that it doesn't allow you to add mods graphically. With the Forge installer, modding Minecraft for Forge compatible/required mods is dead simple. DEAD. SIMPLE. You'll have your Forge profile which you can copy to create different flavors of Forge. There are instructions here in the Suggestions forum to help you get started.

 

To LexManos: To be honest, when I went to install Forge for 1.6.x, I grabbed the universal zip file like I always did. When I opened it to install Forge, I did not find the files I expected and spent a few minutes tracking down what happened. The new installer happened without fanfare (at least I didn't see anything posted about) so I was confused. I love the new installer, btw. Makes things wonderfully easy to work with now.

Link to comment
Share on other sites

- Use the official launcher to download and start once Minecraft 1.6.2.

- Use the Forge installer to install Forge

- Use the official launcher to start once Minecraft with the Forge profile.

- Start Magic Launcher

- Click "Setup"

- Select Environment "Forge9.10.X.Y"

- Click "Add" -> select the OptiFine ZIP file

- Click "Advanced"

- In the field "Parameters" add "-Dfml.ignorePatchDiscrepancies=true"

- Click "OK"

- Login and play

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.