Jump to content

[solved][1.16.5]How to make arrow faster but not incrase its damage?


Recommended Posts

Hello, I have made enchantment that accelerates arrow fired by crossbow, but not only this increases speed, this also increases damage, I want it to have the same damage as before, how can i make damage the same?
What i'm doing is when firing arrow, detect it using EntityJoinWorld event and changing its velocity

	double damage = abstractArrowEntity.getBaseDamage();
	Vector3d vector3d1 = shooter.getUpVector(1.0F); 
	Quaternion quaternion = new Quaternion(new Vector3f(vector3d1), 0, true);
	Vector3d vector3d = shooter.getViewVector(1.0F);
	Vector3f vector3f = new Vector3f(vector3d);
	Vector3d originalVector = abstractArrowEntity.getDeltaMovement();
	double length = originalVector.length() * 10;
	abstractArrowEntity.setDeltaMovement(vector3f.x()*length, vector3f.y()*length, vector3f.z()*length);
	abstractArrowEntity.hurtMarked = true;


Edit:I have solved it by saving length of original velocity and setting damage when it hit entity to its base damage multiplied by saved length

Edited by tmvkrpxl0
Link to comment
Share on other sites

28 minutes ago, tmvkrpxl0 said:

how can i make damage the same?

I think that's not possible because the damage from the arrow depends on the arrow velocity
that mean if you increase the speed of the arrow, the damage is also increased


Edit: check out the method onEntityHit in the AbstractArrowEntity class for more information

Edited by Luis_ST
Link to comment
Share on other sites

  • tmvkrpxl0 changed the title to [solved][1.16.5]How to make arrow faster but not incrase its damage?

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • I created a server with the Pixelmon mod, it's fine and everything but a person enters and the server closes, I don't know how to explain it very well but I attach the detailed file of the error that happens to me https://mclo.gs/eSemvtq This error had not happened to me until now, so I don't understand very well why this happens, could you help me solve it?
    • When I create the server and log in it lets me play, but a person ends up joining and it sends me an error and the server closes The report says Exception in server tick Loop I put here what the console tells me because I honestly don't know how to explain it: https://mclo.gs/eSemvtq I use Forge mods and this has not happened to me until now 
    • Sorry I wasn't on this site for a few days. But anyways, if you just simply want to install forge to play with mods, you need to click on the installer option, thqat way, forge will be automatically installed to your device at the version you chose. Then you could just open Minecraft launcher to play on that version.
    • I've been putting together a modpack for a few weeks, and it's worked just fine. Until today, I logged onto my survival world and went exploring. As soon as I entered my boat the game froze and crashed. Now when I try to start the world, nothing loads and the game crashes. I tried creating a new world and the same thing happened when I tried to use a boat. Here's the latest crash report from the original world: If anyone knows how to fix the issue, I'd really appreciate the help, thanks.
    • I am using Geckolib to create custom entities, but I want to be able to enable/disable certain parts based on criteria. For example, a saddle layer would only show if the entity `isSaddled()`. I'm just not sure how to access individual model parts using the geo.json files. For now, I have created two separate models and I swap them based on the `object.isSaddled() method`:   @Override public ResourceLocation getModelResource(MyModdedEntity object) { return MODELS[object.isSaddled() ? 1 : 0]; }
  • Topics

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.