Jump to content

I am a beginner and i need help, java.exe non-zero code exit value 1


FrediOtMahlata

Recommended Posts

So, I haven't changed a single line of code from the examples that i downloaded from the forge website.  I am using intelij.

I tried a lot of things: updating software, reinstalling it i tried editing files i tried literally everything, i read a lot of git hub and so bullsh and i can't fix it. These are the issues

Quote

Execution failed for task ':runClient'.
> Process 'command 'C:\Users\User\.jdks\bin\java.exe'' finished with non-zero exit value 1

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

When i try to run with --starcktrace or --debug it says
 

Quote

 

D:\untitled2>gradle --warning-mode=all

FAILURE: Build failed with an exception.

* Where:
Build file 'D:\untitled2\build.gradle' line: 11

* What went wrong:
A problem occurred evaluating root project 'untitled2'.
> Failed to apply plugin 'net.minecraftforge.gradle'.
   > Found Gradle version Gradle 6.8.3. Versions Gradle 6.0.0 and newer are not supported in FG3, FG4 however supports Versions 6.8.1 and newer. Consider upgrading.

 

I tried different versions of Gradle, nothing helped.Here is Build file 'D:\untitled2\build.gradle' line: 11-> apply plugin: 'net.minecraftforge.gradle'

P.s: I am not entirely what is going on, i have read the Forge docs, so i technically know, but i have zero practice, because i just started

P.s.ps: I am new to this forum so I`m sorry for any mistakes, and sorry if my English is ass, you could probably tell without me mentioning it, I`m not a native English speaker

 

Link to comment
Share on other sites

EDIT: After a shit ton of debugging i remembered that the only thing i didn't reinstall was my JDK, so i did that and it works now.

EDIT: i changed the  JDK and i ran it for the first time, no error.

After i changed the JDK i got the same error with a different name: error

Quote

Execution failed for task ':runClient'.
> Process 'command 'C:\Users\User\.jdks\corretto-1.8.0_282\bin\java.exe'' finished with non-zero exit value 1

 LAST EDIT: i found the fucking issue i am so sorry for spamming but i haven't slept since yesterday this modding shit is so consuming gn boys

Edited by FrediOtMahlata
issue fixed
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Wow this looks a lot simpler than I thought it would be. Especially compared to the setup I had to do for capabilities. I'll look at all this and update if I have any issues ty
    • Me and a group of friends were trying to get a modpack to work so we can play together. It works for everyone else, except me. At first when I tried to import the modpack, it said "invalid file" but it didn't with anyone else's. The owner of the modpack resent it several times and I still kept getting the same issue, so I opened the modlist and downloaded every single mod by hand. I thought that it would resolve the issue, but instead, it started saying "Forge Modloader Installation Failed" after I created a new installation, so I tried to use a pre-existing modpack, made sure it was the same version "1.20.1, forge version 47.3.0" and swap the mods there, but it still had the same issue, and now none of my modpacks are working at all. They all keep saying that the modloader installation failed. None of us have any idea what to do as we aren't the techiest people. Any help is appreciated. Thank you!
    • I don't think there's any documentation on them yet, I mainly just looked at the Vanilla code when implementing mine. You can see a fairly simple example here: Registration: https://github.com/Choonster-Minecraft-Mods/TestMod3/blob/f3bea10d5f455fa0904056caafd8c844b6fd13ae/src/main/java/choonster/testmod3/init/ModDataComponents.java#L50-L58 Item Registration: https://github.com/Choonster-Minecraft-Mods/TestMod3/blob/f3bea10d5f455fa0904056caafd8c844b6fd13ae/src/main/java/choonster/testmod3/init/ModItems.java#L264-L266 Usage: https://github.com/Choonster-Minecraft-Mods/TestMod3/blob/f3bea10d5f455fa0904056caafd8c844b6fd13ae/src/main/java/choonster/testmod3/world/item/EntityCheckerItem.java
    • Okay, I'm glad I made a backup then. I'm confused as to where there is any information on how to work with Data Components. I don't see anything about it on the Forge docs or any tutorials on this in general unless I'm missing it somehow. I can see the DataComponents decompiled class file but I'm not sure how to work with it. Maybe it's beyond my technical expertise?
    • The situation is the same in 1.20.6. Data Components were introduced in 1.20.5/1.20.6 and Item Capabilities haven't been re-implemented since then.
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.