Jump to content

My mod won't appear in src/main/java in Eclipse


Recommended Posts

what do you mean "won't appear"?

the forge mdk comes with a default examplemod under src/main/java, but it is not necessary, you can create your own package, following the maven package naming conventions, and put your mod there

  • Like 1
Link to comment
Share on other sites

3 minutes ago, DMD_ said:

sorry I'm new to modding and java completely, but what is the maven package naming convention.

if you're new to java, minecraft modding is a pretty tough first-project, if you already have experience with similar OOP languages,, like C#, learning Java as you go isn't that hard, but if not, I'd suggest taking some time to understand java by itself before diving into modding

the maven naming convention is just a convention on how to name your packages, it should usually be under a domain you own (like a website), but backwards, and then the project. and if you don't own a domain, you can use your github account: https://maven.apache.org/guides/mini/guide-naming-conventions.html, but don't worry too much about it

if you can't find a tutorial for a supported version, silentchaos512 has a pretty good and updated series over on youtube for 1.16 I can recommend

Link to comment
Share on other sites

  • Guest locked this topic
This topic is now closed to further replies.

  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • So, I try to make a katana, with katana and scabbard, is that possible to make 2 different models to be on player while he holding item? Katana in hands, and scabbard at belt. 
    • I created a server with the Pixelmon mod, it's fine and everything but a person enters and the server closes, I don't know how to explain it very well but I attach the detailed file of the error that happens to me https://mclo.gs/eSemvtq This error had not happened to me until now, so I don't understand very well why this happens, could you help me solve it?
    • When I create the server and log in it lets me play, but a person ends up joining and it sends me an error and the server closes The report says Exception in server tick Loop I put here what the console tells me because I honestly don't know how to explain it: https://mclo.gs/eSemvtq I use Forge mods and this has not happened to me until now 
    • Sorry I wasn't on this site for a few days. But anyways, if you just simply want to install forge to play with mods, you need to click on the installer option, thqat way, forge will be automatically installed to your device at the version you chose. Then you could just open Minecraft launcher to play on that version.
    • I've been putting together a modpack for a few weeks, and it's worked just fine. Until today, I logged onto my survival world and went exploring. As soon as I entered my boat the game froze and crashed. Now when I try to start the world, nothing loads and the game crashes. I tried creating a new world and the same thing happened when I tried to use a boat. Here's the latest crash report from the original world: If anyone knows how to fix the issue, I'd really appreciate the help, thanks.
  • Topics

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.