Jump to content

java.lang.IllegalStateException: No server set.


Recommended Posts

My Forge 1.16.5 server was working well for many months, that was until now.

I'm using a .bat file to run the server with 8G of memory and nothing seems out of the ordinary when the server is starting up. However, when the server's debug console appears I'm left with this:


[Server thread/ERROR] [minecraft/MinecraftServer]: java.lang.IllegalStateException: No server set.


Keep in mind that the server did not crash therefore there is no crash report. It gets close to running successfully however the Debug window is saying the tick speed is 0ms which isn't good.

Debug Log:

Server Debug Log 8/16/21 (github.com)

Link to comment
Share on other sites

Yeah still had the same issue even after messing with port settings. Interestingly enough, created a new server and copied the data from the old one and we're back in business. So... I'm not entirely sure what happened, like I said this was whole thing was very random and I technically didn't fix it.



I created a new server exactly how you would any other forge server. After you've gotten your new server to run without mods, make sure to copy and paste your "world" and "mods" folders into your new server. You could also copy "server.properties" if you actually care to mess with server properties.


So there ya go... Solved?

Link to comment
Share on other sites

  • 6 months later...

It's been a while since this was posted, but I'm gonna chip in the things I learned when I got the same error.

I had the same situation, where I had hosted a server daily for me and my friends, until one day when I ran the usual .bat file, I got the error.

Here's how I fixed the problem: If you've port forwarded your server, check your IPv4 address. For some reason mine had changed from .2 to .3 during the night, and after changing the porting for Minecraft and server to the new IPv4 address, the server launched like usual.

When you created the new server, it his highly possible why it started working again was because you used the new IP, so copying over the server.properties file would cause the same error to apear.

Hopefully this helps other people who get this error in the future.

Link to comment
Share on other sites

  • 4 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.