Jump to content

[1.17.1] Trying to draw a simple line overlay


Marshall7

Recommended Posts

Hi all. New to modding so this is probably a silly question but I've searched and searched but cannot find any guides or sample code that works for 1.17.1
I have successfully created a client-side only mod that displays the player's coordinates on the screen and am now trying to draw a simple line in the world. Unfortunately, everything I have tried results in nothing displaying or a crash.
My latest crash is

Cannot invoke "net.minecraft.client.renderer.ShaderInstance.setSampler(String, Object)" because "shaderinstance" is null

Here is the code I have so far
 

public class MyRenderType extends RenderType {
    public MyRenderType(String p_173178_, VertexFormat p_173179_, VertexFormat.Mode p_173180_, int p_173181_, boolean p_173182_, boolean p_173183_, Runnable p_173184_, Runnable p_173185_) {
        super(p_173178_, p_173179_, p_173180_, p_173181_, p_173182_, p_173183_, p_173184_, p_173185_);
    }

    private static final LineStateShard THICK_LINES = new LineStateShard(OptionalDouble.of(3.0));

    public static final RenderType OVERLAY_LINES = create("overlay_lines",
            DefaultVertexFormat.POSITION_COLOR,
            VertexFormat.Mode.LINES,
            256,
            true,
            true,
            CompositeState.builder()
                    .setLineState(THICK_LINES)
                    .setLayeringState(VIEW_OFFSET_Z_LAYERING)
                    .setTransparencyState(TRANSLUCENT_TRANSPARENCY)
                    .setTextureState(NO_TEXTURE)
                    .setDepthTestState(NO_DEPTH_TEST)
                    .setCullState(NO_CULL)
                    .setLightmapState(NO_LIGHTMAP)
                    .setWriteMaskState(COLOR_WRITE)
                    .createCompositeState(false)
    );
}

///////////////

@SubscribeEvent
public static void drawLast(RenderWorldLastEvent event) {
    MultiBufferSource.BufferSource buffer = MultiBufferSource.immediate(Tesselator.getInstance().getBuilder());
    VertexConsumer builder = buffer.getBuffer(MyRenderType.OVERLAY_LINES);
    PoseStack matrixStack = event.getMatrixStack();
    Vec3 pos = minecraft.player.position();
    matrixStack.pushPose();
    matrixStack.translate(-pos.x, -pos.y, -pos.z);

    Matrix4f matrix = matrixStack.last().pose();

    // There's also a version of the vertex method that doesn't take matrixStack, I tried that too but it made no difference.
    builder.vertex(matrixStack, (float)-5 + 0.5f, (float)0 + 0.5f, (float)5 + 0.5f)
        .color(1,0,0,1f)
        .endVertex();
    builder.vertex(matrixStack, (float)5 + 0.5f, (float)0 + 0.5f, (float)5 + 0.5f)
        .color(1, 0, 0, 1f)
        .endVertex();

    // I tried adding these lines but it made no difference.
    //RenderSystem.setShaderColor(1.0F, 1.0F, 1.0F, 1.0F);
    //RenderSystem.setShader(GameRenderer::getPositionColorShader);

    buffer.endBatch(); // crashes here
    matrixStack.popPose();
}

Any help is much appreciated

Edited by Marshall7
Link to comment
Share on other sites

  • Marshall7 changed the title to [1.17.1] Trying to draw a simple line overlay

I am trying to find the class you mentioned but StructureBlockEntityRenderer doesn't appear to exist in the vanilla code that I can see. I also cannot find any results on google for either class.
I can see LevelRenderer but so far haven't been able to figure out how to use it or what is wrong with my existing code.

Link to comment
Share on other sites

Thank you! I was able to make something appear using LevelRenderer and now I have determined the key thing that was wrong with my original code:
My custom render type needed to include

.setShaderState(RENDERTYPE_LINES_SHADER)

and for some reason I need one or both of
 

RenderSystem.disableDepthTest();
RenderSystem.disableCull();

...if I want to see the line through other blocks.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.