Jump to content

Unable to import basic things like net.minecraft.item.Item


Recommended Posts

Hi! I was following this tutorial on how to set up a Forge mod. The MDK that I downloaded and set up in Intellij compiled fine, so I wanted to try adding an item to the game to make sure it would work. I tried following the code here but my Intellij couldn't find a number of those symbols, like net.minecraft.item.Item, ItemGroup, and net.minecraftforge.fml.RegistryObject. So instead I tried using the code from within the same tutorial here, but I wasn't able to figure out how to import AbstractBlock.

I was thinking this had something to do with the mappings I was using, but I tried using the official Mojang mappings as well as the snapshot ones described in the Forge tutorial, and I was getting this problem regardless. Is there something I'm missing in terms of setup here?


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.