Jump to content

World edit won't start


JML0508

Recommended Posts

Hi, I installed World Edit with Forge app on my PC and it won't start. 

I checked that I have the right version, I can see it in my Mods folder, I can see it in the installed mods in the game as well but it won't allow me to do any of the world edit commands. I see in Forge that the file size is 0 MB while the file I downloaded was 5.25 MB. Can it be that?

Link to comment
Share on other sites

4 minutes ago, JML0508 said:

I can see it in the installed mods in the game as well but it won't allow me to do any of the world edit commands.

Please post debug.log from the logs folder.

4 minutes ago, JML0508 said:

I see in Forge that the file size is 0 MB while the file I downloaded was 5.25 MB. Can it be that?

What did you mean by "in Forge", Forge is not a File Explorer?

Link to comment
Share on other sites

I don't see a debug.log file in the logs folder.

About "in Forge", I mean in the app. I have 2 mods installed on this profile. For More player models I can see that it does 1.1 MB but for World Edit it says 0 MB.

I found this in the logs:

[10:39:08] [modloading-worker-0/INFO]: Forge mod loading, version 40.1.0, for MC 1.18.2 with MCP 20220404.173914
[10:39:08] [modloading-worker-0/INFO]: MinecraftForge v40.1.0 Initialized
[10:39:11] [Render thread/INFO]: Narrator library for x64 successfully loaded
[10:39:12] [Render thread/INFO]: Reloading ResourceManager: Default, Mod Resources
[10:39:12] [Forge Version Check/INFO]: [forge] Starting version check at https://files.minecraftforge.net/net/minecraftforge/forge/promotions_slim.json
[10:39:14] [Forge Version Check/INFO]: [forge] Found status: UP_TO_DATE Current: 40.1.0 Target: null
[10:39:14] [Worker-Main-22/INFO]: Got request to register class com.sk89q.worldedit.forge.ForgePlatform with WorldEdit [com.sk89q.worldedit.extension.platform.PlatformManager@2036ea6f]
[10:39:14] [Worker-Main-22/INFO]: WorldEdit for Forge (version 7.2.10+1742f98) is loaded
[10:39:40] [Render thread/INFO]: OpenAL initialized on device OpenAL Soft on Headphones (High Definition Audio Device)
[10:39:40] [Render thread/INFO]: Sound engine started
[10:39:40] [Render thread/INFO]: Created: 1024x512x4 minecraft:textures/atlas/blocks.png-atlas
[10:39:40] [Render thread/INFO]: Created: 256x128x4 minecraft:textures/atlas/signs.png-atlas
[10:39:40] [Render thread/INFO]: Created: 512x512x4 minecraft:textures/atlas/banner_patterns.png-atlas
[10:39:40] [Render thread/INFO]: Created: 512x512x4 minecraft:textures/atlas/shield_patterns.png-atlas
[10:39:40] [Render thread/INFO]: Created: 256x256x4 minecraft:textures/atlas/chest.png-atlas
[10:39:40] [Render thread/INFO]: Created: 512x256x4 minecraft:textures/atlas/beds.png-atlas
[10:39:40] [Render thread/INFO]: Created: 512x256x4 minecraft:textures/atlas/shulker_boxes.png-atlas
[10:39:43] [Render thread/INFO]: Created: 256x256x0 minecraft:textures/atlas/particles.png-atlas
[10:39:43] [Render thread/INFO]: Created: 256x256x0 minecraft:textures/atlas/paintings.png-atlas
[10:39:43] [Render thread/INFO]: Created: 128x128x0 minecraft:textures/atlas/mob_effects.png-atlas
[10:40:05] [Render thread/INFO]: Connecting to localhost, 25565
[10:40:06] [Netty Client IO #2/INFO]: Connected to a vanilla server. Catching up missing behaviour.
[10:40:07] [Render thread/INFO]: Environment: authHost='https://authserver.mojang.com', accountsHost='https://api.mojang.com', sessionHost='https://sessionserver.mojang.com', servicesHost='https://api.minecraftservices.com', name='PROD'
[10:40:08] [Render thread/INFO]: Loaded 353 advancements
[10:40:33] [Render thread/INFO]: [CHAT] Unknown or incomplete command, see below for error
[10:40:33] [Render thread/INFO]: [CHAT] /wand<--[HERE]
[10:40:45] [Render thread/INFO]: Stopping!

 

Link to comment
Share on other sites

7 minutes ago, JML0508 said:

I don't see a debug.log file in the logs folder.

If you using CurseForge you need to enable the debug.log in the settings.

8 minutes ago, JML0508 said:

For More player models I can see that it does 1.1 MB but for World Edit it says 0 MB.

I guess this is is a issue with CurseForge

Link to comment
Share on other sites

Your log shows world edit getting loaded.

[15Aug2022 12:27:15.695] [main/DEBUG] [net.minecraftforge.fml.loading.moddiscovery.ModFileInfo/LOADING]: Found valid mod file worldedit-mod-7.2.10 (3).jar with {worldedit} mods - versions {7.2.10+1742f98}

 

But, I don't understand why you are asking for help with WorldEdit here? You should ask the mod author.

My guess is you haven't read the FAQ?

https://www.curseforge.com/minecraft/mc-mods/worldedit

Quote

Do I need cheats on?
If you're playing on single player: Yes, cheats must be enabled for the world to use WorldEdit, but you can change this in the configuration. If you're running a server: Only opped users can use WorldEdit, though this can be changed too.

If that's not it, the mod authors are the ones with the relevant knowledge.

Boilerplate:

If you don't post your logs/debug.log we can't help you. For curseforge you need to enable the forge debug.log in its minecraft settings. You should also post your crash report if you have one.

If there is no error in the log file and you don't have a crash report then post the launcher_log.txt from the minecraft folder. Again for curseforge this will be in your curseforge/minecraft/Install

Large files should be posted to a file sharing site like https://gist.github.com  You should also read the support forum sticky post.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Hello. I'm using IntelliJ IDEA and making a mod for Forge 1.20.1 and I'm trying to make a GUI. I found that the Minecraft-related codes are all obfuscated and when setting up the workspace, Gradle did not execute Deobfuscation tasks like createMcpToSrg. Is this normal or a bug? Can anyone help me with this?
    • Hello! I'm trying to get a list of all entries registered in the infusion upgrade registry. Code can be found in github: https://github.com/ChamoisEST/MiningMadness/tree/1.20.1 Registry in common/registries/MMRegistries.java Event that calls the registry is in MiningMadness.java List of registered entries should be called in common/capabilities/infusion/InfusionCapabilityImplementation.java:getActiveInfusions() in the for loop. Is there any way to accomplish that? Thanks in advance!  
    • So, I am trying to create and add tags to my custom damage type, but looks like I made something wrong, since it crashing with error that "cannot register" damage type. Im trying to register it, and in datagen add tags, but it everytime crashing due to not register "grimtales:entropy". Full code there - https://github.com/undertakerJ/Grim-Tales-Forge ModDamageTypes class public class ModDamageTypes { public static final DeferredRegister<DamageType> DAMAGE_TYPES = DeferredRegister.create(Registries.DAMAGE_TYPE, GrimTales.MOD_ID); public static final ResourceKey<DamageType> ENTROPY_KEY = ResourceKey.create(Registries.DAMAGE_TYPE, new ResourceLocation(GrimTales.MOD_ID, "entropy")); public static final RegistryObject<DamageType> ENTROPY = DAMAGE_TYPES.register( "entropy", () -> new DamageType("entropy_effect", DamageScaling.ALWAYS, 1f, DamageEffects.HURT)); // // public static final DamageSource ENTROPY_SOURCE = new DamageSource(Holder.direct(ENTROPY.get())); public static void register(IEventBus eventBus) { DAMAGE_TYPES.register(eventBus); } } Datagen for damageTags public class ModDamageTagsProvider extends DamageTypeTagsProvider { public ModDamageTagsProvider( PackOutput p_270719_, CompletableFuture<HolderLookup.Provider> p_270256_, @Nullable ExistingFileHelper existingFileHelper) { super(p_270719_, p_270256_, GrimTales.MOD_ID, existingFileHelper); } @Override protected void addTags(HolderLookup.Provider pProvider) { this.tag(DamageTypeTags.BYPASSES_INVULNERABILITY).add(ModDamageTypes.ENTROPY_KEY); } } Datagen class it self   @Mod.EventBusSubscriber(modid = GrimTales.MOD_ID, bus = Mod.EventBusSubscriber.Bus.MOD) public class DataGenerators { @SubscribeEvent public static void gatherData(GatherDataEvent event){ DataGenerator generator = event.getGenerator(); PackOutput packOutput = generator.getPackOutput(); ExistingFileHelper helper = event.getExistingFileHelper(); CompletableFuture<HolderLookup.Provider> lookupProvider = event.getLookupProvider(); generator.addProvider(event.includeServer(), new ModDamageTagsProvider(packOutput, lookupProvider, helper)); } } And register class in main class public GrimTales() { IEventBus modEventBus = FMLJavaModLoadingContext.get().getModEventBus(); ModDamageTypes.register(modEventBus); modEventBus.addListener(this::commonSetup); MinecraftForge.EVENT_BUS.register(this); modEventBus.addListener(this::addCreative); }  
    • Looking for a semi-vanilla Minecraft server? Maybe one with keep inventory and land claims? I have one for you! Let me introduce you to Safe Survival! Come on and join us at mc.safesurvival.net. It is bedrock supported too!
    • Hi. I'm trying to play RLCraft with Optifine but my game keeps crashing on startup with Exit Code 1. The modpack was working fine yesterday, not sure what changed to make it not wanna work anymore. I was hoping someone here could help me figure out what's going wrong. If I remove Optifine, nothing changes, I still get the same errors. Thanks in advance. Crash Report (I only included the errors+fatal, I’m not sure if more is needed, please let me know): https://pastebin.ai/66ivknz0f4  
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.