Jump to content

Intellij not seeing Curios API classes


Recommended Posts

This would be something to ask curios itself; however, the answer is quite simple and related to gradle, not your IDE. Looking at their repo, they have you compile against the api and add the full mod for runtime. Most likely, the api jar to compile against only contains the classes in the api package. So, you wouldn't be able to use any other class the mod contains. If you are, you are probably using their API wrong.

Link to comment
Share on other sites


I looked at their example


There may be a problem in build.gradle

repositories {
    maven { url 'https://maven.theillusivec4.top/' }
dependencies {
    minecraft 'net.minecraftforge:forge:1.19-41.1.0'
    runtimeOnly fg.deobf("top.theillusivec4.curios:curios-forge:1.19.2-")
    compileOnly fg.deobf("top.theillusivec4.curios:curios-forge:1.19.2-")


Link to comment
Share on other sites

As was said above.

If you are using non-api classes at compile time you are doing it wrong.

The curios discord is the place to ask.

Edited by warjort


If you don't post your logs/debug.log we can't help you. For curseforge you need to enable the forge debug.log in its minecraft settings. You should also post your crash report if you have one.

If there is no error in the log file and you don't have a crash report then post the launcher_log.txt from the minecraft folder. Again for curseforge this will be in your curseforge/minecraft/Install

Large files should be posted to a file sharing site like https://gist.github.com  You should also read the support forum sticky post.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.