Jump to content

[resolved] Problem with liblwjgl.so in Eclipse


Recommended Posts

I posted this on someone else's thread http://www.minecraftforge.net/forum/index.php/topic,9148.0.html, but they've [resolved] theirs, I have not, so.....


Hello, I'm getting this same issue, yesterday it was working fine, today not so much, running Mint Linux 15 64 bit

In Eclipse I get:


Caused by: java.lang.UnsatisfiedLinkError: /media/scott/Stuff/Java Source code/forge/mcp/jars/versions/1.6.2/1.6.2-natives/liblwjgl.so: /media/scott/Stuff/Java Source code/forge/mcp/jars/versions/1.6.2/1.6.2-natives/liblwjgl.so: wrong ELF class: ELFCLASS32 (Possible cause: architecture word width mismatch)


Reinstalled Eclipse, deleted my forge installation and done a clean ./install.sh of it.


Downloaded lwjgl, the zip contains exactly the same files I already have in forge/mcp/jar/versions/1.6.2/1.6.2-natives


From the error, it looks like it's using the 32-bit liblwjgl.so instead of liblwjgl64.so (which is in this folder), so how would I tell it to load the 64 bit one?


Also, tried stepping through the code where it loads the library and...

String library_path = System.getProperty("org.lwjgl.librarypath");


is getting a NULL, is that the problem? and if so, how would I fix that.


My next step is re-install Linux. :-O I'd rather not do that.


Link to comment
Share on other sites

Interesting it should pick the one based off your architecture.

You can try deleting the 32-bit version and seeing if it detects the 64.

Either way that env varible shouldnt be null.

We have the launch configurations that set that value.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Consider supporting the team on Patreon

Link to comment
Share on other sites


Removing "liblwjgl.so" - says java.lang.UnsatisfiedLinkError: no lwjgl in java.library.path -

(liblwjgl64.so is definitely in there)


Renaming liblwjgl64.so to liblwjgl.so I get:

...liblwjgl.so: failed to map segment from shared object: Operation not permitted


I've switched back to my Windows pc for now, I'll take another look at this when I have time, thanks for your suggestions. One last thing, should I be using OracleJDK or OpenJDK...or do they both play well with Eclipse?...or is there some heated debate about which one is best?  :)

Link to comment
Share on other sites

I had a similar problem when trying to just run minecraft.


You have to export the location of the java library files so minecraft(forge) can find them.


Here is what I did and it work(s/ed).


Open a terminal (not root / sudo) and type:

export LD_LIBRARY_PATH="/opt/java/jre/lib/amd64"


or change to i386 for 32-bit. Assuming this is where you java is installed. I personally use Oracle Java on Linux.

“Most good programmers do programming not because they expect to get paid or get adulation by the public, but because it is fun to program.” - Linus Torvalds

Link to comment
Share on other sites

Thanks for that, but still no luck. I did see something like that while googling, looks like it does fix Minecraft starting up, but no effect inside Eclipse.


Going to re-install linux this weekend, as it used to work, I must have done something to upset it :-(


UPDATE: Re-installed Linux, all is well again. Just wish I knew what it was that I did to break it, so I don't do it again! :-)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.