Jump to content

Problem with adding 'wthit' as dependency [solved]


Recommended Posts

I'm in the process of updating my mod to newer minecraft versions. Part of the mod is interacting with the mod wthit (the newest fork of waila), so of cause I added the mod api as compileOnly dependency while the actual mod itself is a runtimeOnly dependency. (You can see the dependency part of my build.gradle file here and the properties file here). This set up did work fine up to minecraft version 1.17.1, but since the 1.18.2 and 1.19.3 version I run into exception when running the mod with eclipse.

Exception in thread "main" java.lang.module.ResolutionException: Modules wthit and wthit_api export package mcp.mobius.waila.api.__internal__ to module minecraft
	at java.base/java.lang.module.Resolver.resolveFail(Resolver.java:901)
	at java.base/java.lang.module.Resolver.failTwoSuppliers(Resolver.java:815)
	at java.base/java.lang.module.Resolver.checkExportSuppliers(Resolver.java:736)
	at java.base/java.lang.module.Resolver.finish(Resolver.java:380)
	at java.base/java.lang.module.Configuration.<init>(Configuration.java:140)
	at java.base/java.lang.module.Configuration.resolveAndBind(Configuration.java:494)
	at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.ModuleLayerHandler.buildLayer(ModuleLayerHandler.java:75)
	at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.TransformationServicesHandler.buildTransformingClassLoader(TransformationServicesHandler.java:60)
	at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.Launcher.run(Launcher.java:104)
	at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.Launcher.main(Launcher.java:77)
	at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.BootstrapLaunchConsumer.accept(BootstrapLaunchConsumer.java:26)
	at MC-BOOTSTRAP/[email protected]/cpw.mods.modlauncher.BootstrapLaunchConsumer.accept(BootstrapLaunchConsumer.java:23)
	at [email protected]/cpw.mods.bootstraplauncher.BootstrapLauncher.main(BootstrapLauncher.java:141)

I can build the mod jar just fine and test it by running it directly with forge launcher (aka adding it to custom modpack), but debugging like this is annoying af. 

So is my gradle set up incorrectly or is the wthit dependency faulty? Anyhow what can I do to fix it?

Edited by Tavi007
Link to comment
Share on other sites


I run into exception when running the mod with eclipse.

If you are running it inside eclipse, it doesn't use the gradle build directly.

You need to (re)generate the eclipse run configurations from the gradle build.


Also their wiki says you need to use the "badpackets" mod as well: https://docs.bai.lol/wthit/plugin/getting_started/


But, I suggest you contact the mod author about their mod. These are the forge support forums.


If you don't post your logs/debug.log we can't help you. For curseforge you need to enable the forge debug.log in its minecraft settings. You should also post your crash report if you have one.

If there is no error in the log file and you don't have a crash report then post the launcher_log.txt from the minecraft folder. Again for curseforge this will be in your curseforge/minecraft/Install

Large files should be posted to a file sharing site like https://gist.github.com  You should also read the support forum sticky post.

Link to comment
Share on other sites

I always run 'gradlew genEclipseRuns --refresh-dependencies' and 'gradlew eclipse' to create a working eclipse project. But you might be right, that I also need badpackets, since I can't find it in the Referenced Libraries.


But, I suggest you contact the mod author about their mod. These are the forge support forums.

Well i was not sure, what causes the error and this forum is the best place to get any advice. So thanks for the hint anyway :)

Link to comment
Share on other sites

  • 2 weeks later...

So after a lot of trial and error and using google i actually found a solution here:

Apparently it's a known problem and for now the best work around is to apply the plugin in a certain order:

  1. apply plugin: 'net.minecraftforge.gradle'
  2. apply plugin: 'org.spongepowered.mixin'
  3. apply plugin: 'eclipse'

At least that worked for me

Link to comment
Share on other sites

  • Tavi007 changed the title to Problem with adding 'wthit' as dependency [solved]

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.