Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Copying src over to new Dir


Recommended Posts

I am copying my mod over from another mcp directory built on forge 3.2.3 #108 and am putting it into a directory containing 4.0.0 #200. Only problem is i cant tell where to drop my src code. Will i drop it in src/net.minecraft.src or common/net.minecraft.src? A simple answer would be appreciated. Thank you.

Link to comment
Share on other sites

I dont follow. I wrote it like any other mod. I had a mod_ and than i had all the other files in a folder in teh same directory. I will be re-writting the mod_ accordingly but i'd like the mod to work in lan, client and server. I think that's how it should run normally anyway.

Link to comment
Share on other sites

no, wait: I wrote my mod in eclipse and its path is /MCP/src/common/MY MOD FOLDER/common/java-files


Well yeh i coded it in eclipse back in 1.1.0 and updated it to 1.2.5. So your saying you created your own folder inside common and than put your code in that?

Link to comment
Share on other sites

yes, right... or... I just made a little test-mod in 1.3.2 with the new forge to test it and made it with eclipse and this way was the only one which looks good for me... and it works... when i obfuscated my output in /reobf-folder is: minecraft/Test-Mod(the name of my test mod xDDD)/common and what i do is zipping the folder "Test-Mod" and put it in mods-folder and all works great... just to give u and idea how to do it

Link to comment
Share on other sites

Yeh im getting errors left right and centre when it comes to package and imports. I get some imports have change by ways of forge and so have some hooks but like i don't think what you said is right :/ Are ya sure that works and if so what will i set the package to?

Link to comment
Share on other sites

I really dont know what to do and I think the reason is that I dont understand ur problem but if u use eclipse u can import packages automatically ? CTRL+SHIFT+O


what I did exactly (im really not THAT pro) is: opened eclipse, select \mcp\eclipse as workspace, in project explorer extended "minecraft" -> "common" and then rightclicked "common" and made my own new package in there with name "testmod.common" then i rightclicked my package and clicked "new" -> "class" and finished that... then I made my small test-mod (just new recipes and smelting to test new forge ;) ) the output is like i defined above... I know that this wont help much but pls try to descrive ur problem more exactly... :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • Register your own IRecipeSerializer. It is registered like any other registry entry. However note that you should have as much as possible in the JSON. Don't just have a placeholder JSON file and then hardcode all the logic in code. That defeats the point of datapacks. You'll have to have your own repair recipe then (see above for how to make your own serializer) and override getRemainingItems. If the knife is your item, override hasContainerItem and getContainerItem in your Item class. If the knife is not your item, refer to the section about repairing. Use a GlobalLootModifier.
    • So, im kinda new to modding. Trying to make relatively complicated mod(as I see now, it breaks the api a little bit...), and faced into some problems, especially with crafting. I think I should tell a little bit about my mod, you actually can skip this part, but if you don't get something, i strongly suggest to read this part. The goal i'm chasing is to implement similar food mechanics to TFC classic(1.7.10) mechanics. In a nutshell, it's food with durrability, and when you eat, you consume as much as you need(like if you have a steak and 1 hunger, if you eat it, stake's potential wastes, in case of my mod, it shouldn't). That's it, that's already done(with little bugs thou, but done). Now I have to do crafting somehow, using that items and modify durability while crafting. And it doesn't seems to be easy.     And.. question 1 will be: is it possible to hardcode crafts in 1.16.5? I know.. it's kinda not beautifull, but I really hate the json system. I've made as much crafts as possible by using it, but now, when I need to implement some logic, it's such a headache.   2. This question is about repearing. I mean, placing two damaged items in recipe grid. If you add 2 8/10 items, you'll get just one 10/10 item, and nothing more. I'd like 6/10 item to apear in grid after crafting. 3. Also there should be a recipe for extracting seeds with knife(i don't like to loose knife and whole peace of crop after craft). 4. And the last one. Well, I should change drop of crops if it's broken by special tool. I know, it's possible to do it by adding harvest tools, but I can't modify vanilla crops(maybe only by reflection..). Seems like it's reasonable to use onBlockBroken event, or something like that, but I keep finding deprecated code examples in google, and it doesn't work for me. Maybe there is a better solution.   About crafts.. I tried to figure out how CraftSerializers works, and i think it might be a good solution for that crafting stuff. But don't understand how to bind the serializer to regular minecraft crafting. Tried to read ShapelessRecipe class, but don't understand what happens in mathes, so cant do any assumptions how should I modify it. 
    • IP: Play.EpicLandCraft.Com Version: Cualquiera
    • What Im trying to do is to implement a "dash" mechanic on a Shift button.   @SubscribeEvent public static void onEvent(InputEvent.KeyInputEvent event){ KeyBinding runBinding = Minecraft.getInstance().gameSettings.keyBindSprint; int key = event.getKey(); int runKey = runBinding.getKey().getKeyCode(); ClientPlayerEntity player = Minecraft.getInstance().player; if (key == runKey){ //some checks, and then: float yaw = player.rotationYaw; float x = -MathHelper.sin(yaw * 0.017453292F); float z = MathHelper.cos(yaw * 0.017453292F); double groundMotion = 5, airMotion = 2; if (player.isOnGround()) player.setMotion(new Vector3d(x * groundMotion, 0, z * groundMotion)); else player.setMotion(new Vector3d(x * airMotion, 0, z * airMotion)); } } And this code works. The problem is, it causes a lot of lag when the setMotion() is called - my fps drops from 60 to 50-40 and the dash movement looks discrete. I wonder why is it so and how it can be improved...
  • Topics

  • Who's Online (See full list)

  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.