Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[Linux] Forge Server file not working


NeonPhoenix
 Share

Recommended Posts

Hey guys i was wondering if anyone can help me with my problem

 

I have recently been trying to update my server to 1.6.4 however I install the relevant files etc.

and nothing works. I HAVE used the installer and using the LATEST Forge.

But nothing happens, I have tried running from terminal and it throws this error.

 

We appear to be missing one or more essential library files.

You will need to add them to your server before FML and Forge will run successfully.java.lang.ClassNotFoundException: net.minecraft.launchwrapper.Launch

at java.net.URLClassLoader$1.run(URLClassLoader.java:202)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.findClass(URLClassLoader.java:190)

at java.lang.ClassLoader.loadClass(ClassLoader.java:306)

at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)

at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

at java.lang.Class.forName0(Native Method)

at java.lang.Class.forName(Class.java:249)

at cpw.mods.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:25)

at cpw.mods.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:12)

 

Link to comment
Share on other sites

Did you touch the libraries folder in the server folder somehow?

 

Either that or use the recommended build.

Read the EAQ before posting! OR ELSE!

 

This isn't building better software, its trying to grab a place in the commit list of a highly visible github project.

 

www.forgeessentials.com

 

Don't PM me, I don't check this account unless I have to.

Link to comment
Share on other sites

Use the recomended build, or manually build the classpath, there was a slight bug with the gradle switch, post-gradle 1.6.4 builds are not advised to be used.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Patreon: http://www.patreon.com/lexmanos
Paypal: http://paypal.me/LexManos

BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Hello, I am trying to replace every rendered mob's model (not the mob itself) with the model of a custom entity, under certain conditions. This is how it would work: @SubscribeEvent public static void replaceMobModel(RenderLivingEvent.Pre<LivingEntity, EntityModel<LivingEntity>> event) { if (condition A is reached) { // replace every rendered mob's model with the model of a custom entity } else { // every rendered mob's model reverts back to normal (e.g. villagers start looking like villagers again) } } I was looking at this forum (https://forums.minecraftforge.net/topic/75986-114-how-to-change-rendered-entity/) and found out that I need to use EntityRenderManager::renderEntity. But since that is from a previous version, I assume it would be EntityRenderDispatcher::render. Here's what I tried to do so far: @SubscribeEvent public static void replaceMobModel(RenderLivingEvent.Pre<LivingEntity, EntityModel<LivingEntity>> event) { LocalPlayer localPlayer = Minecraft.getInstance().player; if (localPlayer != null && event.getEntity() instanceof Mob mob) { // I'll set up the conditions later once I get this working event.setCanceled(true); CustomEntity customEntity = ModEntities.CUSTOM_ENTITY.get().create(localPlayer.clientLevel); if (customEntity != null) { customEntity.setXRot(mob.getXRot()); customEntity.setYRot(mob.getYRot()); Minecraft.getInstance().getEntityRenderDispatcher().render( customEntity, mob.getX(), mob.getY(), mob.getZ(), mob.getViewYRot(event.getPartialTick()), event.getPartialTick(), event.getPoseStack(), event.getMultiBufferSource(), event.getPackedLight() ); } } } This results in a stack overflow (EntityRenderDispatcher::render seems to cause RenderLivingEvent to fire, causing an infinite recursion). Is this even the right thing to do? Or do I have to go to my CustomEntity renderer class and override render()? If that's the case, I don't know what I should put in that method.
    • Above is the output I got when I tried to run run.bat
    • C:\Users\user\Desktop\ModdedPlay>REM Forge requires a configured set of both JVM and program arguments. C:\Users\user\Desktop\ModdedPlay>REM Add custom JVM arguments to the user_jvm_args.txt C:\Users\user\Desktop\ModdedPlay>REM Add custom program arguments {such as nogui} to this file in the next line before the  or C:\Users\user\Desktop\ModdedPlay>REM  pass them to this script directly C:\Users\user\Desktop\ModdedPlay>java @user_jvm_args.txt @libraries/net/minecraftforge/forge/1.18.2-40.1.21/win_args.txt Error: Could not find or load main class @user_jvm_args.txt C:\Users\user\Desktop\ModdedPlay>pause Press any key to continue . . .  
    • I want to make the item decrease its durability when it is used. I mean, "hurt" the item when the player tries to use it seems like the better option. I've tried to call it when inside the elytraFlightTick method and cancel the flight later, the item durability reduces, but the player keep starting the boring flight animation.  Sorry if i wrote a little weird, i'm not very good at english.
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.