Jump to content

[1.6.4] No vanilla sounds with latest recommended forge version


NRASean

Recommended Posts

Hi.

 

I'm making a modpack and have put together forge (9.11.1.953) and a bunch of mods.

 

When I'm playing I'm not getting any vanilla sounds played at all (no menu clicks, block breaking sounds etc.) but the custom sounds work (for mekanism machines for example).

 

Also when I play minecraft vanilla 1.6.4 the sounds work fine.

 

I tried searching the forums but no-one seems to have the same issues as me, or the suggested fixes just haven't worked. I noticed in the forge changelog there's a "Delay sound system backend initalization to speed up startup and prevent race condition on some computers." but that hasn't helped in my case.

 

I have tried this with mods and without mods and both times i've had no sound. My friend has tried the modpack as well though and says his sound works fine, so I can only assume it's an issue with my computer and/or forge.

 

It may also be worth noting that I use avast antivirus.

 

Things ive tried:

+ updated sound drivers (RealTek rtkvhd64)

+ updated java (I'm running Version 7 Update 45 (64bit) (build 1.7.0_45-b18) on Windows 7 x64)

+ removed mods

+ copied vanilla assets folder into /modpack_folder/bin/assets/ and /modpack_folder/assets/

+ removed "slick-util.jar" from mods folder

+ tried other "1.6.4" modpacks on the technic launcher website and i don't get any sounds on those either (sound worked fine on previous 1.5.2 versions)

+ tried an older version of 1.6.4 forge, but it told me to go download the recommended (9.11.1.953) one again :(

 

My forge log is here: https://gist.github.com/anonymous/7996812

 

Any help would be greatly appreciated. If I try anything else I will try to update this post with more information.

 

Thanks!

 

Link to comment
Share on other sites

Yeah thanks for that..

 

If I thought it was technic launcher that was the problem I would have done.

 

It appears to be forge that is causing the problems. I will try launching it without technic launcher and report back if anything has changed.

 

If you're using the technic launcher go bitch at technic.

Link to comment
Share on other sites

2013-12-16 23:12:59 [iNFO] [sTDOUT] Completely ignored arguments: [--icon, C:\Users\Sean\AppData\Roaming\.technic\assets/packs/bec-multipack/icon.png, --title, BEC Multipack]
2013-12-16 23:12:59 [iNFO] [Minecraft-Client] LWJGL Version: 2.9.0
2013-12-16 23:12:59 [iNFO] [sTDERR] javax.imageio.IIOException: Can't read input file!

It's the launcher not updated to the asset system change, not us.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Consider supporting the team on Patreon

Link to comment
Share on other sites

I don't know if this is related but I had problems with sounds with older versions of MagicLauncher. The solution was that I had to copy the contents from "<minecraft>/assets/virtual/legacy" into "<minecraft>/assets".  The "<minecraft>" being your appropriate minecraft support folder like ".minecraft".

 

You didn't mention MagicLauncher so this might not be related.

Link to comment
Share on other sites

The launcher is supposed to mount .minecraft/assets/virtual/legacy as the assets folder. I'm sticking to my guns and saying your launcher needs an update.

Read the EAQ before posting! OR ELSE!

 

This isn't building better software, its trying to grab a place in the commit list of a highly visible github project.

 

www.forgeessentials.com

 

Don't PM me, I don't check this account unless I have to.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • i have the decocraft mod and i can see all of them. i can click right click and place the items but as soon as i put it down it disappears. im so sad it doesnt work and i dont know how to fix it. i used cursed forge to launch minecraft as well.
    • Me and my friend wanted to make a custom mod pack hosted on aternos. I downloaded the same mods as the server then started the server and my minecraft and I joined the server without issues. Then I sent the mods to my friend compressed in a zip folder (i don’t know if that has anything to do with the issue). He unpacked it put it in his mod folder and started it but couldn't join the server and got this issue:   internal exception: java.lang.runtimeexception: server not initialized yet! call IMDLib.entityHandler (modid)   Also we are using curseforge launcher to manage the mods on client side. But as I said it works on my side but not with my friend, that’s why it doesn’t make sense   Mod list:   xplosives-1.2.0.jar whisperwoods-1.18.2-2.1.0-forge.jar waystones-forge-1.18.2-10.2.2.jar voicechat-forge-1.18.2-2.4.32.jar trashslot-forge-1.18.2-11.0.3.jar towns_and_towers_forge-1.10.0.1+1.18.2.jar torchmaster-18.2.1.jar ToolBelt-1.18.2-1.18.9.jar toms_storage-1.18.2-1.4.4.jar swingthroughgrass-1.18.2-1.9.1.jar strictly_origins_v5.1_1.18.2.jar starlight-1.0.2+forge.546ae87.jar SpartanWeaponry-1.18.2-3.0.4.jar SimpleQuarry-1.18.2-18.2.5.jar simpleplanes-1.18.2-5.2.2.jar secretrooms-1.18.2-1.1.5.jar right-click-harvest-3.2.0+1.18.2-forge.jar REIPluginCompatibilities-forge-8.0.89.jar RoughlyEnough|tems-8.3.681-forge.jar RegionsUnexploredForge-0.4.1_1+1.18.2.jar TerraBlender-forge-1.18.2-1.2.0.126.jar Recall_Potion_v1.0.3-1.18.2.jar Quark-3.2-358.jar PickleTweaks-1.18.2-6.1.2.jar Pehkui-3.7.11+1.18.2-forge.jar Origins-1.18.2-1.4.1.4-unified.jar naturalist-forge-1.1.1-1.18.2.jar mysticaloaktree-1.18.2-1.2.jar selene-1.18.2-1.17.14.jar MysticalAgradditions-1.18.2-5.1.4.jar MysticalAgriculture-1.18.2-5.1.5.jar MultiMine-1.18.7.jar moyai-1.18.2-1.1.4.jar ModernDynamicSurroundings-5.0.0.4.jar lootbeams-1.18.1-release-july1722.jar journeymap-1.18.2-5.9.7-forge.jar ironfurnaces-1.18.2-3.3.3.jar ironchest-1.18.2-13.2.11.jar industrial-foregoing-1.18.2-3.3.1.6-10.jar titanium-1.18.2-3.5.11-45.jar immersive_armors-1.5.6+1.18.2-forge.jar hardcorerevival-forge-1.18.2-8.0.1.jar HammerLib-1.18.2-18.2.16. jar gravestone-1.18.2-1.0.1.jar geckolib-forge-1.18-3.0.57.jar findme-3.0.6-forge.jar faithfulbackrooms3.0.0.7.jar elevatorid-1.18.2-1.8.4.jar EasyMagic-v3.3.0-1.18.2-Forge.jar PuzzlesLib-v3.5.9-1.18.2-Forge.jar easy_villagers-1.18.2-1.0.11.jar easy_mob_farm_1.18.2-7.1.0.jar DynamicTrees-1.18.2-1.0.4.jar dragonseeker-1.1.1-1.18.2.jar iceandfire-2.1.12-1.18.2.jar Cucumber-1.18.2-5.1.5 jar cloth-config-6.5.116-forge.jar citadel-1.11.3-1.18.2.jar chunkloaders-1.2.8a-forge-mc1.18.jar supermartijn642configlib-1.1.8-forge-mc1.18.jar supermartijn642corelib-1.1.17-forge-mc1.18.jar cave_dweller-1.18.2-1.6.4.jar carryon-1.18.2-1.17.1.12.jar caelus-forge-1.18.1-3.0.0.2.jar BotanyTrees-Forge-1.18.2-4.0.13.jar BotanyPots-Forge-1.18.2-8.1.29.jar Bookshelf-Forge-1.18.2-13.3.56.jar balm-3.2.6.jar AutoRegLib-1.7-53.jar ars_nouveau-1.18.2-2.9.0.jar curios-forge-1.18.2-5.0.9.2.jar Patchouli-1.18.2-71.1.jar architectury-4.12.94-forge.jar almostunified-forge-1.18.2-0.3.10.jar [1.18.2] SecurityCraft v1.9.8.jar
    • Thank you for trying, I really appreciate it
    • It worked! Now I can run my modpack without crashes, thanks!
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.