Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.7.2 #1019] unresolved dependency - forgeBin 1.7.2-10.12.0.1019


dand0
 Share

Recommended Posts

Hi. I have got an error, which says: "Project 'Minecraft' is missing required library: 'C:\Users\admin\Desktop\Minecraft\MCP\forge 1.7\unresolved dependency -  forgeBin 1.7.2-10.12.0.1019". It is all the time. I tried

gradlew.bat setupDecompWorkspace eclipse

and

gradlew.bat setupDevWorkspace eclipse

and them both

gradlew.bat setupDevWorkspace setupDecompWorkspace

and simple "eclipse"

gradlew.bat eclipse

But this problem is. I know that I need forge binarny file, but I don't know how this file must be inside. Should I download userdev or universal? Or it is a special file? And if it is so, where can I download this special file and where should I put it (in what directory) ? Thank's

Link to comment
Share on other sites

Delete old .classpath file in forge folder

gradlew.bat setupDevWorkspace setupDecompWorkspace eclipse

Open .classpath with a text editor.

Search for "forgeSrc" .

File name "forgeSrc" in path attribute should be changed to "forgeBin".

File name "forgeSrc" in sourcepath attribute should remain unchanged.

Link to comment
Share on other sites

There is one way to fix this problem. And that is to run the setup and IDE tasks in seperate commands.

for example..

gradlew setupDevWorkspace eclipse

should instead be done as...

gradlew setupDevWorkspace

gradlew eclipse

 

this will serv as a workarround until I can permanently fix this issue.

Link to comment
Share on other sites

Still doesn't work. "forgeSrc-1.7.2-10.12.0.1019.jar" shows up in the project folder now, but I still get:

Archive for required library: 'C:/Users/einsteinsci/.gradle/caches/minecraft/net/minecraftforge/forge/1.7.2-10.12.0.1019/forgeSrc-1.7.2-10.12.0.1019.jar' in project '1019 v2' cannot be read or is not a valid ZIP file

in Markers.

 

When I try and run it anyway, the FMLTweaker class isn't found.

Link to comment
Share on other sites

  • 2 weeks later...

When your settting up your Workspace

 

use these commands

 

first command -

gradlew.bat setupDecompWorkspace --refresh-dependencies

 

Second Command -

gradlew.bat eclipse

Check Out My Modding Tutorials For Minecraft Forge!

 

http://www.youtube.com/user/XxxXEclipse7XxxX

 

 

Check Out My Forums -

http://www.theaustralianmodder.com

Link to comment
Share on other sites

Here's how I get mine to work:

 

gradlew.bat setupDecompWorkspace eclipse

gradlew.bat --refresh-dependencies

gradlew.bat setupDecompWorkspace --debug

gradlew.bat eclipse --debug

 

This series of commands fixes all build path errors. I got these from LexManos himself when I had the same problem. Use all of them every time you update as well.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.