Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Server Problem?: Quickly crashes after installing Forge


TheWingedOne
 Share

Recommended Posts

Alright... so I've been trying to set up a modded server for a long time now, but I've always had problems and never asked for help. I have done a LOT of looking around, but I could never find anything like my problem. I can only hope someone knows what's going on.

 

I start by making a regular vanilla server. I download minecraft_server.jar and stick it into its own folder. Then I make a Wordpad document and put this inside:

 

java -Xms512M -Xmx1G -jar minecraft_server.jar

 

That's from this wiki page. Since I'm using Windows and the 64x Java package, I also followed step 3 of the "REQUIRED: Verify and install the latest version of Java" section (changing the path).

 

Then I save it as "startserver.bat". When I open it, and the server sets itself up with ease. I can enter it with no trouble. I've also tried this AFTER installing Forge to the minecraft_server.jar, but after I add Forge the problem happens.

 

I'm trying to install Forge because I want to play Twilight Forest. On the minecraftforum page, it says to follow this link and download the latest recommended build, which has a star next to it. I downloaded 4.1.4.298 universal. Then I opened that and stuck it into my clean client jar, deleted META-INF, started Minecraft, and it prepared itself. (I have tried this before and after I first use startserver.bat, and neither worked.)

 

Then I opened the minecraft_server.jar and put Forge inside. Then I use startserver.bat. (I have tried this before and after the first time I use startserver.bat, and neither worked.)

 

Every time, the cmd window pops up for half a second and then immediately closes down. This window closes down too quickly for me to properly read or copy. HOWEVER, I managed to take a screenshot of it so I went and typed down everything I saw.

 

 

Here is the image: http://i286.photobucket.com/albums/ll83/_-Snow-_/MinecraftForgeProblemScreenshot1-2.png

 

C:\Users\setiram\Desktop\Minecraft Servers\Minecraft Modded 1.3.2>java -Xms512M -Xmx1G -jar minecraft_server.jar

Exception in thread "main" java.lang.ImcompatibleClassChangeError: Implementing class

at java.lang.ClassLoader.defineClass1(Native Method)

at java.lang.ClassLoader.defineClass(Unknown Source)

at java.security.SecureClassLoader.defineClass(Unknown Source)

at java.net.URLClassLoader.defineClass(Unknown Source)

at java.net.URLClassLoader.access$100(Unknown Source)

at java.net.URLClassLoader$1.run(Unknown Source)

at java.net.URLClassLoader$1.run(Unknown Source)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.FindClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at sun.launcher.LauncherHelper.checkAndLoadMain(Unknown Source)

 

 

If there's trouble seeing it, I can try for a better picture...

 

So... anyone have an idea on what's going on?

 

PS. I have also tried this with a previous build of Forge, and the same problem occurred. This is all for a Minecraft 1.3.2 server.

Link to comment
Share on other sites

I'm sorry, I'm a bit confused... what do you mean by that? I basically have tried:

 

1) Starting the server, allowing the vanilla server files to be created, then putting Forge into minecraft_server.jar and starting it again

2) Putting Forge in the jar first then starting the server

3) Putting Forge in the client jar, starting Minecraft itself, then doing 1 or 2

 

If by tools you mean MCPatcher or some external program like that, I'm not using any.

 

And I think I forgot to mention that I never deleted META-INF in the server jar.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • I am running forge-1.16.1-32.0.108-mdk and all my code SEEMs to be legit but when I run, the loading screen pops up and gets through the Mojang intro but immediately closes  Java 8 minecraft 1.16.1    ---- Minecraft Crash Report ---- // I feel sad now :( Time: 10/19/21 10:50 AM Description: Rendering overlay net.minecraft.util.ResourceLocationException: Non [a-z0-9_.-] character in namespace of location: .DS_Store:sounds.json at net.minecraft.util.ResourceLocation.<init>(SourceFile:38) ~[?:?] {re:classloading} at net.minecraft.util.ResourceLocation.<init>(SourceFile:50) ~[?:?] {re:classloading} at net.minecraft.client.audio.SoundHandler.prepare(SoundHandler.java:56) ~[?:?] {re:classloading,pl:runtimedistcleaner:A} at net.minecraft.client.audio.SoundHandler.prepare(SoundHandler.java:34) ~[?:?] {re:classloading,pl:runtimedistcleaner:A} at net.minecraft.client.resources.ReloadListener.func_215270_b(SourceFile:11) ~[?:?] {re:classloading} at java.util.concurrent.CompletableFuture$AsyncSupply.run(CompletableFuture.java:1590) ~[?:1.8.0_111] {} at java.util.concurrent.CompletableFuture$AsyncSupply.exec(CompletableFuture.java:1582) ~[?:1.8.0_111] {} at java.util.concurrent.ForkJoinTask.doExec(ForkJoinTask.java:289) ~[?:1.8.0_111] {} at java.util.concurrent.ForkJoinPool$WorkQueue.runTask(ForkJoinPool.java:1056) ~[?:1.8.0_111] {} at java.util.concurrent.ForkJoinPool.runWorker(ForkJoinPool.java:1692) ~[?:1.8.0_111] {} at java.util.concurrent.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:157) ~[?:1.8.0_111] {} A detailed walkthrough of the error, its code path and all known details is as follows: --------------------------------------------------------------------------------------- -- Head -- Thread: Render thread Stacktrace: at net.minecraft.client.renderer.GameRenderer.updateCameraAndRender(GameRenderer.java:473) -- Overlay render details -- Details: Overlay name: net.minecraft.client.gui.ResourceLoadProgressGui Stacktrace: at net.minecraft.client.renderer.GameRenderer.updateCameraAndRender(GameRenderer.java:473) at net.minecraft.client.Minecraft.runGameLoop(Minecraft.java:951) at net.minecraft.client.Minecraft.run(Minecraft.java:582) at net.minecraft.client.main.Main.main(Main.java:184) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:498) at net.minecraftforge.userdev.FMLUserdevClientLaunchProvider.lambda$launchService$0(FMLUserdevClientLaunchProvider.java:55) at cpw.mods.modlauncher.LaunchServiceHandlerDecorator.launch(LaunchServiceHandlerDecorator.java:37) at cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:54) at cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:72) at cpw.mods.modlauncher.Launcher.run(Launcher.java:81) at cpw.mods.modlauncher.Launcher.main(Launcher.java:65) at net.minecraftforge.userdev.LaunchTesting.main(LaunchTesting.java:105) -- System Details -- Details: Minecraft Version: 1.16.1 Minecraft Version ID: 1.16.1 Operating System: Mac OS X (x86_64) version 10.16 Java Version: 1.8.0_111, Oracle Corporation Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation Memory: 469098616 bytes (447 MB) / 948961280 bytes (905 MB) up to 1908932608 bytes (1820 MB) CPUs: 4 JVM Flags: 1 total; -Xss1M ModLauncher: 6.1.3+75+master.851120a ModLauncher launch target: fmluserdevclient ModLauncher naming: mcp ModLauncher services: /mixin-0.8.jar mixin PLUGINSERVICE /eventbus-3.0.3-service.jar eventbus PLUGINSERVICE /forge-1.16.1-32.0.108_mapped_snapshot_20200514-1.16-launcher.jar object_holder_definalize PLUGINSERVICE /forge-1.16.1-32.0.108_mapped_snapshot_20200514-1.16-launcher.jar runtime_enum_extender PLUGINSERVICE /accesstransformers-2.2.0-shadowed.jar accesstransformer PLUGINSERVICE /forge-1.16.1-32.0.108_mapped_snapshot_20200514-1.16-launcher.jar capability_inject_definalize PLUGINSERVICE /forge-1.16.1-32.0.108_mapped_snapshot_20200514-1.16-launcher.jar runtimedistcleaner PLUGINSERVICE /mixin-0.8.jar mixin TRANSFORMATIONSERVICE /forge-1.16.1-32.0.108_mapped_snapshot_20200514-1.16-launcher.jar fml TRANSFORMATIONSERVICE FML: 32.0 Forge: net.minecraftforge:32.0.108 FML Language Providers: javafml@32.0 minecraft@1 Mod List: client-extra.jar Minecraft {minecraft@1.16.1 NONE} forge-1.16.1-32.0.108_mapped_snapshot_20200514-1.16.jar Forge {forge@32.0.108 NONE} resources Example Mod {examplemod@NONE NONE} Launched Version: MOD_DEV Backend library: LWJGL version 3.2.1 build 12 Backend API: Intel(R) Iris(TM) Plus Graphics OpenGL Engine (1x6x8 (fused) LP GL version 2.1 INTEL-16.5.2, Intel Inc. GL Caps: Using framebuffer using ARB_framebuffer_object extension Using VBOs: Yes Is Modded: Definitely; Client brand changed to 'forge' Type: Client (map_client.txt) Resource Packs: Current Language: English (US) CPU: 4x Intel(R) Core(TM) i3-1000NG4 CPU @ 1.10GHz  
    • Currently, I have a init package with my ModBlocks, ModItems, ModEntityTypes, etc. abstract classes that initialize the registry objects as class fields. Does it suffice to use @ObjectHolder("modid") above the class name in each class? My runClient has worked so far without these annotations... are these necessary for build, then? All of my registry objects are currently public static. Should I use final on all objects? Also, regarding the original topic, I updated my last post with the inheritance issue I am running into.
    • Guys HELP!! I get an error message when i launch minecraft Forge 1.17.1 . it only happens with this version and this problem never happened to me in any other versions. I tried to update this version till last one 37.0.97. Can anyone help me?? i would be so glad.
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.