Jump to content

Build Artifacts with Intellij 14 and MC 1.7.10


cad435

Recommended Posts

Well, i just wanted to export my mod, with Build -> Build Artifacts, but its greyed out

(mod works well in IDE!)

 

 

i searched and found this Wiki-Site: http://www.minecraftforge.net/wiki/Forge_Development_in_IntelliJ_IDEA

 

but as i use MC 1.7.10 i klick the redirect on top and come to: http://www.minecraftforge.net/forum/index.php/topic,21354.0.html

I setup my intellij as diesieben07 told in this topic, except im not installing in inside Itellij, but with cmd and "gradlew SetupDecompWorkspace" and " gradlew idea"

 

i tried to create the artifacts as the wiki (first link) states, but it won't let me select any Main-Classesand without a selected main-class i can't continue...

 

 

any suggestions?

 

PS if it matters: the intellij 14.0 Runfix from diesieben07 is installed

 

Link to comment
Share on other sites

Thanks, i'll update the runfix and will try to import the buid.gradle....

 

Edit: http://www.minecraftforge.net/forum/index.php/topic,21354.0.html

 

hmm i can't find the runfix...

still this topic? http://www.minecraftforge.net/forum/index.php/topic,21354.0.html

 

Edit#2: ok i think i got it, the line "sourceSets { main { output.resourcesDir = output.classesDir } }" pasted on top of the gradle skript replaces the runfix.class that was stated before?

 

And i just saw a build.gradle allready were imported, now i created a build configuration(is marked as a groovy config, not gradle config?!)...

running that it said: "Error running build: forge-1.7.10...src i not backed by gradle"

 

any parameters to add to the "buld"-Runconfiguration?

 

€#3

As i just screw up my IDEA (trial and error to get the export running) i have now completely deleted the working-dir and try to import from gradle - it works well but only without the line "sourceSets { main { output.resourcesDir = output.classesDir } }" so i imported it without that and falled back to the old Idea14 Fix

 

 

problem remains: how can i export my mods to a .jar file?

Link to comment
Share on other sites

ah, i added the Line on TOP of the skript... and Intellij then don't know what variable ist "sourceSets"...

 

(maybe you could clarify it in your Tut, don't know if anyone else is as stupid as i am^^)

 

let me try that...

 

 

Edit: it worked... This Forum has damn good people!

Link to comment
Share on other sites

Edit: it worked... This Forum has damn good people!

 

No, it has diesieben07 ;)

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.