Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

gradlew setupDecompWorkspace issue


Azurephyre
 Share

Recommended Posts

Hi there! For the past couple of days I've been attempting to set up Forge-Gradle so that I can have a go at some modding, however whenever I run "gradlew setupDecompWorkspace" the download seems to 'get stuck' and ends up hanging indefinitely at various points; sometimes it manages to download several files, and at other times it'll only download a handful of kbs before giving up.

 

C:\Users\Kelsey\Desktop\Mod Attempt>gradlew setupDecompWorkspace
Download http://files.minecraftforge.net/maven/org/eclipse/jdt/org.eclipse.jdt.c
ore/3.10.0.v20131029-1755/org.eclipse.jdt.core-3.10.0.v20131029-1755.jar
> Configuring > 0/1 projects > root project > 321 KB/4.63 MB downloaded

 

I've followed several tutorials on how to set this up, and so far each one has brought me to this point. I've also gone through several forum and google pages looking for a solution, and just about everyone I've found discussing this issue has gone unanswered. I've also tried:

- Running the command with firewall off

- Leaving it to do its thing for extended periods of time (6+ hours and still stuck)

- Downgrading to Java 7 and running the command

- Deleting the .gradle folder and starting from scratch

- Setting up a system-wide proxy and running (as suggested here http://www.minecraftforge.net/forum/index.php?topic=24935.0)

- Contacted ISP

 

If anyone has any ideas as to how to get past this issue (or even if there's a place where I can download the required files manually), I would be most grateful, and if there's anymore info that I need to share to fix this just let me know and I'll get it up as soon as possible. Thanks!

Link to comment
Share on other sites

  • 5 weeks later...

Download servers are NOT broken.

 

I just did a clean decompilation of both the 1.7.10 line and the 1.8 line on a Mac. Downloads all worked just fine.

 

@Azurephyre

Not sure what your problem is since I don't have access to my PC right now. If you haven't gotten this working in the next couple of days, I'll see if I can do this on my PC.

 

I don't use the local gradle or gradlew myself because I have a global installation of gradle on my System (via Homebrew).

 

Have you tried running it from a folder that doesn't have a space in it? Maybe gradlw has a problem with that? Not sure.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.