Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.7.10] Allow a container to have a stacksize in excess of the item's stacksize


BinaryCrafter
 Share

Recommended Posts

I'm developing what will hopefully be a simple mod, which is a simple item storage based mod, that I'm calling DeepStorageChest. It's essentially intended to be a mash up of a chest and a DeepStorageUnit from the mod MineFactory Reloaded. As I'm sure you know, DeepStorageUnit allows for lots of storage of one particular item type, whereas, I want to allow lots of storage of multiple item types. Essentially, I'm creating a chest with 27 / 54 slots, but slots aren't limited by the item's maximum stack size. e.g. Cobblestone has a MaxStackSize of 64, EnderPearls 16, etc, but I want my storage to exceed this limit.

 

I've created my own TileEntity and Container classes for the storage block, and overriden methods such that I am able to shift click items to my storage block and exceed the normal MaxStackSize limit.

 

The problem I'm finding, is that the only way I can allow a slot to contain more than MaxStackSize items per slot is by shift clicking items in to the inventory, if I click drag to move them or use a hopper to place items into my container, then the MaxStackSize for the item is honoured, which is not what I want.

 

Can anybody explain how I might be able to accomplish this, as I can't find any methods I can override might allow me to be able to do this?

 

I'm building the mod for Forge 1.7.10, if that's relevant, source code so far is on GitHub (https://github.com/WalterWeight/DeepStorageChest)

Link to comment
Share on other sites

MaxStackSize will always be honoured. It is set inside Item instance and you can't do much to just change it (only for custom items).

If you set stackSize of itemStack to above MaxStackSize it will be auto-corrected and lowered to max.

 

I've been doing similar thing some time ago, I didn't really used stackSize. What I did was create arrays in TE - one list of ItemStacks (stackSize = 1), other sizeOfStack, and 3rd is a ItemStackBackup. Then I've overriden every method that uses ItemStack (merge, drop, everything) to use sizeOfStack for given slot instead of normal stackSize. Worked pretty well. You'd have to ofc add custom renderer to client Gui (which is easy - read size and render string)

 

There might be some new methods to archieve this since i was coding it before 1.6 :P

 

Edit: If you haven't gotten the idea - that also solves problem of drag-and-drop with mouse / anything else. Since it is TE you can always restore previous state of ItemStack (using ItemStackBackup) when you drag ItemStack it will be set to null in normal ItemStack array, but you always have backup array and size of stack saved separately, you can re-set it in onUpdate().

1.7.10 is no longer supported by forge, you are on your own.

Link to comment
Share on other sites

You'd have to fake it. Keep a stack at the maximum allowed as the "display" stack, then keep an internal counter storing the true value.

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Hello There! In the 73rd episode of Bed Wars we get into a lobby with a guy who had a cool name and for some reason Ben is very impressed with the name and thus the title!  
    • I have been trying to install forge, but I can't even get the installer to run. I'm really not sure what the issue is, first let me make sure I am even using the installer right, I downloaded the forge installer matching my minecraft version (1.19.2), if I double click the .jar from the download then I see a flash of a black window that immediately disappears. If I use a command prompt, I receive the following output: C:\Users\austi> java -jar forge-1.19.2-43.0.19-installer.jar Error: Unable to access jarfile forge-1.19.2-43.0.19-installer.jar   I feel like this is more likely a java issue than a forge issue but I was hoping that people here might be able to help. I've tried a couple versions of java, at first I was using 8 I believe because all of the install guides for forge were a bit older so they linked to the java website rather than oracle. I tried version 18 from the oracle site and received the same result from command prompt. It is also entirely possible that I am doing something else wrong that is blatantly obvious to everyone else.
    • Here is my configuration: % java -version java version "18.0.2" 2022-07-19 Java(TM) SE Runtime Environment (build 18.0.2+9-61) Java HotSpot(TM) 64-Bit Server VM (build 18.0.2+9-61, mixed mode, sharing) forge-1.19-41.1.0-mdk on macOS Monterey 12.5 I ran the command: ./gradlew genEclipseRuns and was hoping it will generate the Eclipse project files for me. The run log is at https://gist.github.com/arun-gupta/06b983a6976b4c0a0f510d0dc225ddd3 and the generated directory structure is at https://gist.github.com/arun-gupta/3f5bfc70ec5d3d903b0f97d42840abda. In previous versions (1.12-ish), it used to generate an eclipse directory but 1.19 does not seem to have it. I tried opening the top-level forge directory but Eclipse does not recognize it as a project as well. How do I open this project in Eclipse now?  
    • I didn't put in credentials, I used it only for testing installing forge. But still the problem mentioned above.
    • I am trying to use Forge 1.18.2, I have checked my firewall, redownloaded Forge, deleted the fml.toml file (which keeps reappearing) and looked at countless help pages. I am just trying to download and use forge so that I can play with my friends and it will not download. It tells me there may be an issue with the Java runtime config and that the exit code is one, and I have copied the exit code.   
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.