Jump to content

Forge 6.01.337 Source Installation Error


Recommended Posts

If this is a case that I'm jumping the gun before this is complete for 1.4.2 then I apologize up front.


So I decided to see about working with 1.4.2 and forge. Here are the steps I did:


1) I downloaded the latest MCP version 719.

2) I downloaded the recommended build for forge 6.01.337.

3) I completely wiped out my .minecraft folder in Roaming to ensure I started pristine and downloaded the latest Minecraft.exe and ran it to get the files.

4) I downloaded the minecraft server jar.

5) I extracted MCP 719.

6) I copied the bin and resources directories from .minecraft to the jars folder under MCP.

7) I copied the minecraft server jar into the jars directory under MCP.

8) I extracted forge under the MCP directory.

9) I tried to install from the forge directory.


Two things I noticed. Despite it being utterly clean in terms of both client and server, forge was saying they had been modified when it started the install. I don't think I can get any cleaner than wiping out the entire minecraft installation and starting from scratch but maybe someone can point me to something I missed in those regards. As I have put no mod nor patched... I don't want other mods involved in mine as of yet for debugging purposes so I keep things vanilla as possible. So I didn't even drop my own mod files in as of yet.


So the real problem is that it fails at the MCPMerger portion (see the attached screenshot). The error is somewhat varied at times this one shows an indexoutofboundsexception... another one at one point complained of duplicate entries.


Now I tried this about 10 times ... I rechecked tutorials and the instructions on the forge wiki to see if I was missing anything. I had no issues with my 1.3.2 setup which I still have in a separate repository. Just for sanity I checked that I was up to date with my JDK, which it is, I even reinstalled it to be sure.


If I jumped the gun on this before it is ready for 1.4.2 sorry :) But if not any help would be appreciated.


EDIT: Just tried 339 as well and got the duplicate entry error. See second screenshot. Again everybody is clean I keep on starting from scratch each time.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.