Jump to content

I'm Completely Dumb. Please help me figure out what I'm doing wrong to load mods


Recommended Posts



I promise I've spent a considerable amount of time trying to figure this out. I think I'm doing everything right, but I can't seem to get some mods to load. Maybe because I'm a stupid dad trying to figure this out for my kids? LOL


See the following pic:




How come any mods we download which are .jar will load, but not any that are in .zip?


I've tried unzipping those files and placing in the mods folder too, but still doesn't work.


Surely there is one very small thing I'm doing wrong?



Link to comment
Share on other sites

Hey, sorry, but I posted a question at this thread :http://www.minecraftforge.net/forum/index.php/topic,31016.0.html


but it got locked so I could not ask any follow up questions.


The response was "We do not support 1.5.2, if you want to play that old of a version you're on your own."


But, they are using Minecraft 1.8.7; NOT 1.5.2


As well as the latest Forge currently up for download (forge-1.8-



Link to comment
Share on other sites

They may be but the mods they are trying to use are 1.5.2 mods.

They have not follow the rules and posted logs.

They are not following the install instructions for their mods.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Consider supporting the team on Patreon

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.