Jump to content

[SOLVED]1.7.10 crash on player specific login (with logs!)


UberAffe

Recommended Posts

I have a custom modpack that a few people have started playing on.

One of the players got kicked with an internal server error while going down a ladder and a villager walked beneath them.

 

Things I tried:

having them restart their client,

restarting both server and client,

editing that players .dat file to put them to known safe coordinates

 

This is what happens on the server when they try to log in:

 

[19:42:49] [server thread/ERROR] [FML/]: Index: 12 Listeners:
[19:42:49] [server thread/ERROR] [FML/]: 0: NORMAL
[19:42:49] [server thread/ERROR] [FML/]: 1: ASM: com.darkona.adventurebackpack.handlers.PlayerEventHandler@34877aaf tickPlayer(Lcpw/mods/fml/common/gameevent/TickEvent$PlayerTickEvent;)V
[19:42:49] [server thread/ERROR] [FML/]: 2: ASM: tconstruct.armor.ArmorAbilities@53dbd223 playerTick(Lcpw/mods/fml/common/gameevent/TickEvent$PlayerTickEvent;)V
[19:42:49] [server thread/ERROR] [FML/]: 3: ASM: crazypants.enderio.item.MagnetController@59ed79de onPlayerTick(Lcpw/mods/fml/common/gameevent/TickEvent$PlayerTickEvent;)V
[19:42:49] [server thread/ERROR] [FML/]: 4: ASM: crazypants.enderio.item.darksteel.DarkSteelController@55f92efa onPlayerTick(Lcpw/mods/fml/common/gameevent/TickEvent$PlayerTickEvent;)V
[19:42:49] [server thread/ERROR] [FML/]: 5: ASM: com.rwtema.extrautils.crafting.LawSwordCraftHandler@3ad13c37 event(Lcpw/mods/fml/common/gameevent/TickEvent$PlayerTickEvent;)V
[19:42:49] [server thread/ERROR] [FML/]: 6: ASM: chylex.hee.mechanics.compendium.events.CompendiumEvents@7f68b22b onPlayerTick(Lcpw/mods/fml/common/gameevent/TickEvent$PlayerTickEvent;)V
[19:42:49] [server thread/ERROR] [FML/]: 7: ASM: com.emoniph.witchery.common.ServerTickEvents@7820040e onPlayerTick(Lcpw/mods/fml/common/gameevent/TickEvent$PlayerTickEvent;)V
[19:42:49] [server thread/ERROR] [FML/]: 8: ASM: codechicken.nei.ServerHandler@7b461ac6 tickEvent(Lcpw/mods/fml/common/gameevent/TickEvent$PlayerTickEvent;)V
[19:42:49] [server thread/ERROR] [FML/]: 9: ASM: extracells.util.ExtraCellsEventHandler@25312228 onPlayerTick(Lcpw/mods/fml/common/gameevent/TickEvent$PlayerTickEvent;)V
[19:42:49] [server thread/ERROR] [FML/]: 10: ASM: openblocks.common.ServerTickHandler@2a3a628d onPlayerTick(Lcpw/mods/fml/common/gameevent/TickEvent$PlayerTickEvent;)V
[19:42:49] [server thread/ERROR] [FML/]: 11: ASM: tombenpotter.sanguimancy.util.EventHandler@2920e376 onPlayerTick(Lcpw/mods/fml/common/gameevent/TickEvent$PlayerTickEvent;)V
[19:42:49] [server thread/ERROR] [FML/]: 12: ASM: code.elix_x.mods.teleplates.events.OnPlayerTickEvent@421c5861 tick(Lcpw/mods/fml/common/gameevent/TickEvent$PlayerTickEvent;)V
[19:42:49] [server thread/ERROR] [FML/]: 13: ASM: thaumic.tinkerer.common.potion.PotionEffectHandler@26cf3ef onPlayerTick(Lcpw/mods/fml/common/gameevent/TickEvent$PlayerTickEvent;)V
[19:42:49] [server thread/ERROR] [FML/]: 14: ASM: com.rwtema.extrautils.worldgen.Underdark.DarknessTickHandler@248d3463 tickStart(Lcpw/mods/fml/common/gameevent/TickEvent$PlayerTickEvent;)V
[19:42:49] [server thread/ERROR] [FML/]: 15: ASM: vazkii.botania.common.block.BlockPistonRelay@b60ed88 tickEnd(Lcpw/mods/fml/common/gameevent/TickEvent;)V
[19:42:49] [server thread/ERROR] [FML/]: 16: ASM: lumien.randomthings.Handler.RTTickHandler@287ff2de tick(Lcpw/mods/fml/common/gameevent/TickEvent;)V
[19:42:49] [server thread/ERROR] [FML/]: 17: ASM: appeng.hooks.TickHandler@5ad2b17b onTick(Lcpw/mods/fml/common/gameevent/TickEvent;)V
[19:42:49] [server thread/ERROR] [FML/]: 18: LOWEST
[19:42:49] [server thread/ERROR] [FML/]: 19: ASM: vazkii.botania.common.item.ItemRegenIvy@2ccadab9 onTick(Lcpw/mods/fml/common/gameevent/TickEvent$PlayerTickEvent;)V
[19:42:49] [server thread/DEBUG] [NotEnoughItems/]: Unloading Player: EmeraldOtter

 

 

the last line is what happens when I shut down the server, not when they get kicked.

 

Their client doesn't actually crash but this is their fml latest log:

 

[18:32:06] [Netty Client IO #0/INFO] [FML/]: Attempting connection with missing mods [inventorytweaks] at SERVER
[18:32:10] [Netty Client IO #1/DEBUG] [FML/]: Server FML protocol version 2, 4 byte dimension received 0
[18:32:10] [Netty Client IO #1/TRACE] [FML/]: $ServerHello->FMLHandshakeClientState$2:HELLO
[18:32:10] [Netty Client IO #1/INFO] [FML/]: Server protocol version 2
[18:32:10] [Netty Client IO #1/DEBUG] [FML/]: Received override dimension 0
[18:32:10] [Netty Client IO #1/TRACE] [FML/]: $ModList:101 mods->FMLHandshakeClientState$3:WAITINGSERVERDATA
[18:32:10] [Netty Client IO #1/INFO] [FML/]: Attempting connection with missing mods [inventorytweaks] at SERVER
[18:32:10] [Netty Client IO #1/TRACE] [FML/]: $ModIdData:4371 mappings->FMLHandshakeClientState$4:WAITINGSERVERCOMPLETE
[18:32:10] [Netty Client IO #1/INFO] [FML/]: Injecting existing block and item data into this client instance
[18:32:10] [Netty Client IO #1/DEBUG] [FML/]: Registry consistency check successful
[18:32:10] [Netty Client IO #1/DEBUG] [FML/]: Fixed block id mismatch witchery:embermoss: 1394 (init) -> 1393 (map).
... fixing id's
[18:32:10] [Netty Client IO #1/DEBUG] [FML/]: Fixed item id mismatch witchery:stairswoodrowan: 1406 (init) -> 1405 (map).
[18:32:10] [Netty Client IO #1/DEBUG] [FML/]: Registry consistency check successful
[18:32:10] [Netty Client IO #1/TRACE] [mcp/mcp]: Sending event FMLModIdMappingEvent to mod mcp
...sending events
[18:32:10] [Netty Client IO #1/TRACE] [aobd/aobd]: Sent event FMLModIdMappingEvent to mod aobd
[18:32:10] [Netty Client IO #1/DEBUG] [FML/]: Bar Step: ModIdMapping - Another One Bites The Dust took 0.000s
[18:32:10] [Netty Client IO #1/DEBUG] [FML/]: Bar Finished: ModIdMapping took 0.027s
[18:32:10] [Netty Client IO #1/INFO] [FML/]: Applying holder lookups
[18:32:10] [Netty Client IO #1/INFO] [FML/]: Holder lookups applied
[18:32:10] [Netty Client IO #1/TRACE] [FML/]: $HandshakeAck:{2}->FMLHandshakeClientState$5:PENDINGCOMPLETE
[18:32:10] [Netty Client IO #1/TRACE] [FML/]: $HandshakeAck:{3}->FMLHandshakeClientState$6:COMPLETE
[18:32:10] [Client thread/DEBUG] [FML/]: The fluid thaumicenergistics:gaseouscognitioessentia has been selected as the default fluid for gaseouscognitioessentia
... default fluids
[18:32:10] [Client thread/DEBUG] [FML/]: The fluid thaumicenergistics:gaseouscorpusessentia has been selected as the default fluid for gaseouscorpusessentia
[18:32:10] [Client thread/DEBUG] [OpenMods/]: openmods.network.IdSyncManager.decodeIds(IdSyncManager.java:113): Received data store for key rpc_methods, packet size = 337
[18:32:10] [Client thread/DEBUG] [OpenMods/]: openmods.network.IdSyncManager.decodeIds(IdSyncManager.java:113): Received data store for key events, packet size = 167
[18:32:10] [Client thread/DEBUG] [OpenMods/]: openmods.network.IdSyncManager.decodeIds(IdSyncManager.java:113): Received data store for key rpc_targets, packet size = 107
[18:32:10] [Client thread/INFO] [FML/]: [Client thread] Client side modded connection established
[18:32:10] [Client thread/INFO] [NEIAddons/]: Connected to new server, resetting commands
[18:32:10] [Client thread/DEBUG] [FML/]: Overriding dimension: using 0
[18:32:11] [Client thread/INFO] [journeymap/]: Requesting World ID
[18:32:12] [Client thread/INFO] [ThermalExpansion/]: Receiving Server Configuration...
[18:32:12] [Client thread/INFO] [THAUMCRAFT/]: Client received server config settings.
[18:32:12] [Client thread/INFO] [THAUMCRAFT/]: CHEAT_SHEET[false], WARDED_STONE[true], MIRRORS[true], HARD_NODES[true], WUSS_MODE[false], RESEARCH_DIFFICULTY[0], ASPECT_TOTAL_CAP[100
[18:32:12] [Client thread/INFO] [malisiscore/]: Found hooks for net.minecraft.network.NetHandlerPlayServer (nh)
[18:32:12] [Netty Client IO #1/INFO] [Armory/]: Started loading custom ArmorMaterial Values from Config.
[18:32:12] [Client thread/DEBUG] [NotEnoughItems/]: Loading Remote World
[18:32:12] [Netty Client IO #1/INFO] [Armory/]: Loading of the custom ArmorMaterial Values has succesfully been performed!
[18:32:12] [Netty Client IO #1/INFO] [THAUMCRAFT/]: Restoring client configs.
[18:32:12] [Netty Client IO #1/DEBUG] [OpenMods/]: openmods.network.IdSyncManager.onDisconnect(IdSyncManager.java:124): Disconnected, restoring local data
[18:32:12] [Client thread/ERROR] [NotEnoughItems/]: Failed to find identifier for: com.kentington.thaumichorizons.common.items.ItemGolemBellTH@b019f7b
[18:32:13] [Client thread/DEBUG] [CCL ASM/]: Inserted super call into [bfo.e()V]
[18:32:13] [Client thread/DEBUG] [CCL ASM/]: Injecting before method [bfl.a(Labt;II)Z]
[18:32:13] [Client thread/DEBUG] [CCL ASM/]: Injecting before method [bfl.b(Labt;II)Z]
[18:32:13] [Client thread/DEBUG] [FML/]: Found a minecraft related file at C:\Users\compName\Documents\Curse\Minecraft\Install\libraries\net\minecraftforge\forge\1.7.10-10.13.4.1492-1.7.10\forge-1.7.10-10.13.4.1492-1.7.10.jar, examining for codechicken classes
... found related files
[18:32:15] [Client thread/DEBUG] [FML/]: Found a minecraft related file at C:\Users\compName\Documents\Curse\Minecraft\Install\versions\forge-10.13.4.1492\forge-10.13.4.1492.jar, examining for codechicken classes
[18:32:15] [Client thread/ERROR] [CodeChickenCore/]: Failed to scan C:\Users\compName\Documents\Curse\Minecraft\Install\versions\forge-10.13.4.1492\forge-10.13.4.1492.jar, the zip file is invalid
java.util.zip.ZipException: invalid entry size (expected 67324752 but got 2231 bytes)
at java.util.zip.ZipInputStream.readEnd(ZipInputStream.java:384) ~[?:1.8.0_25]
at java.util.zip.ZipInputStream.read(ZipInputStream.java:196) ~[?:1.8.0_25]
at java.util.zip.ZipInputStream.closeEntry(ZipInputStream.java:140) ~[?:1.8.0_25]
at java.util.zip.ZipInputStream.getNextEntry(ZipInputStream.java:118) ~[?:1.8.0_25]
at codechicken.core.ClassDiscoverer.readFromZipFile(ClassDiscoverer.java:116) ~[ClassDiscoverer.class:?]
at codechicken.core.ClassDiscoverer.findClasspathMods(ClassDiscoverer.java:100) [ClassDiscoverer.class:?]
at codechicken.core.ClassDiscoverer.findClasses(ClassDiscoverer.java:51) [ClassDiscoverer.class:?]
at codechicken.nei.NEIClientConfig.bootNEI(NEIClientConfig.java:273) [NEIClientConfig.class:?]
at codechicken.nei.NEIClientConfig.loadWorld(NEIClientConfig.java:208) [NEIClientConfig.class:?]
at codechicken.nei.NEICPH.handleSMPCheck(NEICPH.java:109) [NEICPH.class:?]
at codechicken.nei.NEICPH.handlePacket(NEICPH.java:23) [NEICPH.class:?]
at codechicken.lib.packet.PacketCustom$ClientInboundHandler.handle(PacketCustom.java:100) [PacketCustom$ClientInboundHandler.class:?]
at codechicken.lib.packet.PacketCustom$CustomInboundHandler.channelRead0(PacketCustom.java:77) [PacketCustom$CustomInboundHandler.class:?]
at codechicken.lib.packet.PacketCustom$CustomInboundHandler.channelRead0(PacketCustom.java:64) [PacketCustom$CustomInboundHandler.class:?]
at io.netty.channel.SimpleChannelInboundHandler.channelRead(SimpleChannelInboundHandler.java:98) [simpleChannelInboundHandler.class:?]
at io.netty.channel.DefaultChannelHandlerContext.invokeChannelRead(DefaultChannelHandlerContext.java:337) [DefaultChannelHandlerContext.class:?]
at io.netty.channel.DefaultChannelHandlerContext.fireChannelRead(DefaultChannelHandlerContext.java:323) [DefaultChannelHandlerContext.class:?]
at io.netty.channel.DefaultChannelPipeline.fireChannelRead(DefaultChannelPipeline.java:785) [DefaultChannelPipeline.class:?]
at io.netty.channel.embedded.EmbeddedChannel.writeInbound(EmbeddedChannel.java:169) [EmbeddedChannel.class:?]
at cpw.mods.fml.common.network.internal.FMLProxyPacket.func_148833_a(FMLProxyPacket.java:77) [FMLProxyPacket.class:?]
at net.minecraft.network.NetworkManager.func_74428_b(NetworkManager.java:212) [ej.class:?]
at net.minecraft.client.multiplayer.GuiConnecting.func_73876_c(SourceFile:78) [bcx.class:?]
at net.minecraft.client.Minecraft.func_71407_l(Minecraft.java:1661) [bao.class:?]
at net.minecraft.client.Minecraft.func_71411_J(Minecraft.java:973) [bao.class:?]
at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:898) [bao.class:?]
at net.minecraft.client.main.Main.main(SourceFile:148) [Main.class:?]
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_25]
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_25]
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_25]
at java.lang.reflect.Method.invoke(Method.java:483) ~[?:1.8.0_25]
at net.minecraft.launchwrapper.Launch.launch(Launch.java:135) [launchwrapper-1.12.jar:?]
at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.12.jar:?]
[18:32:15] [Client thread/DEBUG] [FML/]: Found a minecraft related file at C:\Users\compName\Documents\Curse\Minecraft\Instances\Moar fun\mods\1.7.10 Technomancy  - 0.11.2 - 1.7.10.jar, examining for codechicken classes
... found related files
[18:32:18] [Client thread/DEBUG] [FML/]: Found a minecraft related file at C:\Users\compName\Documents\Curse\Minecraft\Instances\Moar fun\mods\witchery-1.7.10-0.24.1.jar, examining for codechicken classes
[18:32:19] [Client thread/DEBUG] [FML/]: Found a minecraft related file at C:\Users\compName\Documents\Curse\Minecraft\Instances\Moar fun\mods\AOBD-2.8.1.jar, examining for codechicken classes
[18:32:19] [Client thread/DEBUG] [NotEnoughItems/]: Loaded cofh.plugins.nei.NEICoFHConfig
...loaded
[18:32:19] [Client thread/DEBUG] [NotEnoughItems/]: Loaded com.emoniph.witchery.integration.NEIWitcheryConfig
[18:32:19] [Client thread/INFO] [Waila/]: Received server authentication msg. Remote sync will be activated
[18:32:19] [Client thread/INFO] [NEIAddons/]: Received handshake from server
[18:32:19] [Client thread/INFO] [NEIAddons/]: Available server commands: SetAE2FakeSlot
[18:32:19] [Client thread/INFO] [FML/]: Ars Magica 2 >> Received player login packet.
[18:32:19] [Client thread/INFO] [FML/]: Secondary tree cap: 99
[18:32:19] [Client thread/INFO] [FML/]: Disabled skills: 0
[18:32:19] [Client thread/INFO] [FML/]: Mana cap: 0.00
[18:32:19] [Client thread/WARN] [FML/]: =============================================================
[18:32:19] [Client thread/WARN] [FML/]: MOD HAS DIRECT REFERENCE System.exit() THIS IS NOT ALLOWED REROUTING TO FML!
[18:32:19] [Client thread/WARN] [FML/]: Offendor: truetyper/TrueTypeFont.loadImage(Ljava/awt/image/BufferedImage;)I
[18:32:19] [Client thread/WARN] [FML/]: Use FMLCommonHandler.exitJava instead
[18:32:19] [Client thread/WARN] [FML/]: =============================================================
[18:32:20] [Client thread/INFO] [sTDOUT/]: [truetyper.TrueTypeFont:<init>:94]: TrueTypeFont loaded: java.awt.Font[family=Arial,name=Arial,style=plain,size=12] - AntiAlias = true
[18:32:20] [Client thread/INFO] [FML/]: Ars Magica 2 >> Compendium unlock state not found to load.  Assuming it hasn't been created yet.
[18:32:20] [Client thread/DEBUG] [FML/]: Reverting to frozen data state.
[18:32:20] [Client thread/INFO] [FML/]: Applying holder lookups
[18:32:20] [Client thread/INFO] [FML/]: Holder lookups applied

 

All the parts that I omitted don't list any errors and they can load in single player fine I expect that it is just the last few lines that will be important.

 

Edit: let the confusion continue ...

I removed the players uuid.dat file along with all the other player specific files in that folder

and they still get the same issue when trying to connect.

 

Other players can connect and play just fine, we have no items that are linked to players either.

 

Edit2:

Began happening to another player when they tried opening a vanilla furnace gui, didn't happen with crafting table gui though.

Current Project: Armerger 

Planned mods: Light Drafter  | Ore Swords

Looking for help getting a mod off the ground? Coding  | Textures

Link to comment
Share on other sites

Post the actual full log file from the server.

We dont care about the client if it says Internal Server Error.

And the log you posted doesn't have any useful information.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Consider supporting the team on Patreon

Link to comment
Share on other sites

I got a fresh log

server started player,

player tried to connect

server stopped

 

Full fml-server-latest:

https://raw.githubusercontent.com/UberAffe/excessivly-large-files/master/technexx-full-fml-log.log

 

10,500 lines is way to much for this, a surprisingly simple number.

Current Project: Armerger 

Planned mods: Light Drafter  | Ore Swords

Looking for help getting a mod off the ground? Coding  | Textures

Link to comment
Share on other sites

Found it, sort of.

Removing Teleplates and its dependency xcore fixed the problem, it is a new mod and seems to be causing a problem with its player tick event.

 

Reporting this to mod author.

 

Thanks for taking a look at this anyways LexManos!

Current Project: Armerger 

Planned mods: Light Drafter  | Ore Swords

Looking for help getting a mod off the ground? Coding  | Textures

Link to comment
Share on other sites

This should not happen at all... Or mappings are different or what?

This is line that gives NoSuchMethodError:

if(player.rotationPitch == 90 && ((block == TeleplatesBase.teleplate && EnergyManager.canTeleportFromTeleplate(player)) || (player.getItemInUse() != null && player.getItemInUse().getItem() == TeleplatesBase.portableTeleplate && EnergyManager.canTeleportFromPortableTeleplate(player)))){

As you can see, nothing wrong here and

EntityPlayer.func_71011_bu()Lnet/minecraft/item/ItemStack;

method can only be

player.getItemInUse()

.

So i'm confused. It seems that something else caused this error. Compiler? Different forge versions? MCP mappings? 3rd party coremod? What?

 

EDIT: if somebody is interested, this issue on modder support page with some more detailed description: http://www.minecraftforge.net/forum/index.php/topic,33194

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Pretty much, although all the recipes im planning to make on it are shapeless. The idea is that the chamber uses energy to "fuse" the items in each of the center slots together, in this case an ingot. The two slots at the sides are fuel. (A special kind of wood in this case). Here is an image of the interface just for reference (The center slot is the output)   As for the code- Can you elaborate a little bit on it? Seeing three different record classes has confused me a lot. (Elaborate as in why make them in three different records. I understand the code itself more or less)
    • Hello im trying to make a mod and the past few days GSON has almost killed me, when i export the mod and then launch it through minecraft launcher i get java.lang.NoSuchMethodError: com.google.gson.JsonParser.parseString(Ljava/lang/String;)Lcom/google/gson/JsonElement; i have literally tried everything here is my build config   dependencies { minecraft("com.mojang:minecraft:1.8.9") mappings("de.oceanlabs.mcp:mcp_stable:22-1.8.9") forge("net.minecraftforge:forge:1.8.9-11.15.1.2318-1.8.9") compileOnly("cc.polyfrost:oneconfig-1.8.9-forge:0.2.2-alpha+") shadowImpl("cc.polyfrost:oneconfig-wrapper-launchwrapper:1.0.0-beta+") { isTransitive = false exclude(module = "gson") } shadowImpl("org.spongepowered:mixin:0.7.11-SNAPSHOT") { isTransitive = false exclude(module = "gson") } annotationProcessor("org.spongepowered:mixin:0.8.5-SNAPSHOT") shadowImpl("org.javassist:javassist:3.15.0-GA") { isTransitive = false exclude(module = "gson") } shadowImpl("com.neovisionaries:nv-i18n:1.28") { isTransitive = false exclude(module = "gson") } shadowImpl("org.apache.commons:commons-lang3:3.4") { isTransitive = false exclude(module = "gson") } shadowImpl("org.apache.httpcomponents:httpcore:4.4.5") { isTransitive = false exclude(module = "gson") } compileOnly("com.google.code.gson:gson:2.8.6") { isTransitive = false } configurations.all { resolutionStrategy { force("com.google.code.gson:gson:2.8.6") } } shadowImpl(fileTree( mapOf( "dir" to "libs", "include" to listOf("*.jar"), "exclude" to listOf( "asm", "asm-commons", "asm-tree", "gson", "unspecified", "nv-i18n" ) ) )) }  
    • @chxr Looks like you're making some sort of a crafting table / furnace hybrid? Are the inputs needing arranging like a shaped recipe, or is it shapeless? I'll assume it's shapeless since that just adds a lot more complexity. In that case I'd probably do something like this { "type": "relativedimensions:particle_rebound", "inputs": [ { "ingredient": { "item": "relativedimensions:aberrant_shard" }, "count": 8 } ], "fuel": { "tag": "relativedimensions:block/aberrant_fuel" }, "output": { "Count": 1, "id": "relativedimensions:aberrant_ingot" } } inputs: A list of ingredients and how many are needed. The count among each input adds up to 8. Since there's only 1 ingredient, the count is set to 8. fuel: Same thing as before but remove the list and just make it an object with a tag. output: Kept the same.   In this case the Codec I would make is public record ParticleReboundIngredient(Ingredient ingredient, int count) { public static final Codec<ParticleReboundIngredient> CODEC = RecordCodecBuilder.create( builder -> builder.group( Ingredient.CODEC.fieldOf("ingredient").forGetter((i) -> i.ingredient), Codec.INT.fieldOf("count").forGetter(i -> i.count) ).apply(builder, ParticleReboundIngredient::new) ); } public record ParticleReboundFuel(String tag) { public static final Codec<ParticleReboundFuel> CODEC = RecordCodecBuilder.create( builder -> builder.group(Codec.STRING.fieldOf("tag").forGetter(f -> f.tag)).apply(builder, ParticleReboundFuel::new) ); public boolean isFuel(ItemStack stack) { // TODO: Check if fuel item matches the tag } } public record ParticleReboundRecipe(List<ParticleReboundIngredient> inputs, ParticleReboundFuel fuel, ItemStack output) { public static final Codec<ParticleReboundRecipe> CODEC = RecordCodecBuilder.create( builder -> builder.group( ParticleReboundIngredient.CODEC.listOf().fieldOf("inputs").forGetter(r -> r.inputs), ParticleReboundFuel.CODEC.fieldOf("fuel").forGetter(r -> r.fuel), ItemStack.CODEC.fieldOf("output").forGetter(r -> r.output) ).apply(builder, ParticleReboundRecipe::new) ); }   There might be a more proper Codec for the fuel and the tag that's built into minecraft / forge, but I didn't look
    • Tested with 5900X, 64GB 3200 MHz, 3070 Ti, driver 551.86 GPU clock range: 200 - 1950 MHz, usually 210 MHz with 10-30% utilisation on desktop idle use Render settings: Vsync ON, Framerate unlimited, Render distance 32, Fullscreen ON (60hz monitor, so 60 fps with vsync) Vanilla minecraft: Main menu: 210mhz idle clock always, ingame clock around 400 - 1000 mhz with ~30% utilisation and after alt+tab stays at same. Modded install with curseforge app, only said forge added: Main menu: 210 mhz idle clock always, ingame clock around 400 - 1000 mhz with ~30% utilisation, but after alt+tab gpu clock shoots up to 1950 mhz and utilisation is at 50-60% After disabling all render and chunk related stuff in config, after alt+tab it goes up to 1500 mhz. So game turns gpu into space heater when its not even seen. GPU usage returns to expected when game comes back on top. If instead of unlimited fps, fps is set to ~60, then during alt+tab gpu stays at same range as vanilla, but minecraft has horrible limit logic and framerate limit causes lot of tearing, so its not an option. So it seems that when alt+tabbing, for some reason logic no longer takes vsync toggle into account. So expected behaviour would be for it to work like vanilla does. keep rendering in same manner, no matter if its seen and use same amount of resources. Essentially noticed this behaviour while playing Supersymmetry and after elimination testing, result was that only Forge was enough to cause it. And also confirmed it by doing fresh pack with only Forge added, so no other mods even in disabled state. Also happened with both singleplayer and remote multiplayer. Other offender was "Universal Tweaks" which introduced same effect to main menu with its # Removes the hardcoded 30 FPS limit in screens like the main menu B:"Uncap FPS"=true setting, meaning when game was on top, it still worked in limits of vsync cap, but after alt+tabbing even in main menu gpu usage shot up to max.
    • Add crash-reports with sites like https://paste.ee/ and paste the link to it here Make a test without the mod auditory
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.