Jump to content

[1.8] Fluid not being rendered


RafaMv

Recommended Posts

Hello guys, so I have never done a fluid before, but I think I got it right, except the rendering.

 

I have the fluid block (BlockFluidClassic), I can place it and it can normally flow; However, it is invisible (with default RenderType = -1) or untextured blocks (with RenderType = 3).

 

Does anyone know how to properly register a fluid in 1.8?

Link to comment
Share on other sites

You need to use Forge's fluid model. Use the default render type of 3 (model specified by blockstates file). -1 stops the block being rendered at all (used by vanilla

TESR

blocks).

 

Forge has an example here (blockstates file) and I have an example here (blockstates file).

Please don't PM me to ask for help. Asking your question in a public thread preserves it for people who are having the same problem in the future.

Link to comment
Share on other sites

I see... for some reason my forge Fluid class is different from those, it doesn't have the ResourceLocation. What version are you using?

 

Edit: I was using the recommended version 11.14.3.1450. I changed to version 11.14.3.1502 and it worked beautifully!

 

Thanks Choonster! :)

Link to comment
Share on other sites

Fluid Renderer wasn't added until build 1464, 1502 is just the last build before forge gradle 2.0

 

This is correct. I've just been updating to the latest Forge version occasionally, since it's just a test mod I don't worry about compatibility with older versions of Java or Forge.

Please don't PM me to ask for help. Asking your question in a public thread preserves it for people who are having the same problem in the future.

Link to comment
Share on other sites

  • 1 month later...

Thanks so much for the post, it has really helped me with fluids in 1.8.  However, I am having an issue with getting the texture hooked up correctly.  I am currently getting a texture error saying that I am missing 2 textures (the flow and still) in DOMAIN minecraft, however I have it of course with my mod's assets.  It seems like it is looking for it in the Minecraft asset structure.

 

log below

 

[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]: +=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]: The following texture errors were found.
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]: ==================================================
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]:   DOMAIN minecraft
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]: --------------------------------------------------
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]:   domain minecraft is missing 2 textures
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]:     domain minecraft has 3 locations:
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]:       unknown resourcepack type net.minecraft.client.resources.DefaultResourcePack : Default
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]:       mod FML resources at C:\Users\Jerrbear\.gradle\caches\minecraft\net\minecraftforge\forge\1.8-11.14.3.1502\snapshot\20141130\forgeSrc-1.8-11.14.3.1502.jar
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]:       mod Forge resources at C:\Users\Jerrbear\.gradle\caches\minecraft\net\minecraftforge\forge\1.8-11.14.3.1502\snapshot\20141130\forgeSrc-1.8-11.14.3.1502.jar
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]: -------------------------
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]:     The missing resources for domain minecraft are:
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]:       textures/blocks/lifestream_flow.png
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]:       textures/blocks/lifestream_still.png
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]: -------------------------
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]:     No other errors exist for domain minecraft
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]: ==================================================
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]: ==================================================
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]:   DOMAIN makomod
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]: --------------------------------------------------
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]:   domain makomod is missing 1 texture
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]:     domain makomod has 1 location:
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]:       mod makomod resources at C:\Users\Jerrbear\Desktop\Minecraft\makomod\build\libs\makomod-1.0.jar
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]: -------------------------
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]:     The missing resources for domain makomod are:
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]:       textures/blocks/makoReactor.png
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]: -------------------------
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]:     No other errors exist for domain makomod
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]: ==================================================
[16:07:28] [Client thread/ERROR] [TEXTURE ERRORS]: +=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=

 

 

NOTE: I have textures working for other items and blocks, I just haven't gotten around to making a texture for the reactor, so ignore that one please.

 

EDIT: I shouldn't blindly use source code :P  for anyone else that might encounter this problem, make sure to include "modid:path/to/texture" in your constructor for your fluid, instead of just "path/to/texture"

example:

public FluidLifestream() {
        super(NAME, new ResourceLocation("makomod:blocks/lifestream_still"), new ResourceLocation("makomod:blocks/lifestream_flow"));
}

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • LINK DAFTAR : KLIK DISINI LINK DAFTAR : KLIK DISINI   Slot deposit bank bsi merupakan salah satu situs slot gacor deposit bank bsi 24 jam mudah maxwin tanpa batas. hari ini slot deposit bank bsi menawarkan bonus terbesar untuk player yang sudah bergabung di situs slot bank bsi ini, dengan ada nya slot bank bsi sanget mempermudah player untuk melakukan transaksi deposit dengan bank bsi. Sebagai Situs Slot Deposit Bank Bsi meyediakan banyak permainan seperti slot online, live casino, sabung ayam, tembak ikan, sportbook semua game tersebuat sangat aman dan terpercaya. Beramin slot bank bsi sangat mudah hanya dengan niminal deposit 5000 ribu saja anda sudah bisa bermain di semua game yang sudah di sediakan oleh situs slot bank bsi. Slot bank bsi adalah saranan untuk Pemain yang mencari pengalaman bermain slot gacor sekarang dapat menemukan metode pembayaran beragam di berbagai situs slot gacor yang tersebar luas di seluruh negeri. Munculnya situs Slot Bank BSI, kini para pemain dapat menikmati kemudahan dan kenyamanan dalam melakukan transaksi pembayaran. Bahkan memungkinkan pemain untuk fokus sepenuhnya pada permainan yang mereka nikmati sepanjang waktu. Ini adalah langkah penting dalam memperluas aksesibilitas judi slot online di Indonesia dan memberikan pengalaman bermain yang lebih baik kepada para pecinta slot gacor.    
    • Sometimes love could be the worst experience. you get to love and trust your partner only to feel regret over it. i have been married for 7 years now and i found some sudden change in my partner attitude, i tried talking about it but he complains i'm nagging a lot . i tried to ignore his attitude but it became unbearable so i was advised to hire a hacker to help me gain access to his phone so i had know if he is cheating or not so i was introduced to [ Remote spy hacker @ g m ail . c o m ] and this expert helped me gain access to his phone without his notice. i got to see his messages, photos, call recordings and many more . Now i can see his cheating and that's the reason for the attitude all along.
    • hola thanks for answering  i set some system outs to test and see whats going on      @Override     protected void saveAdditional( CompoundTag nbt ){                  nbt.put("itemhandler", itemhandler.serializeNBT() );         nbt.putInt("progress", this.progress );         System.out.println("saveAdditional(nbt)");                 System.out.println(NbtUtils.prettyPrint(nbt)); //<-- this is whats getting saved         super.saveAdditional( nbt );     }     @Override     public void load( CompoundTag nbt ){         itemhandler.deserializeNBT( nbt.getCompound("itemhandler") );         this.progress = nbt.getInt("progress" );         System.out.println(NbtUtils.prettyPrint(nbt)); //<-- this is whats minecraft is giving back to the entity          System.out.println("load(nbt)");         super.load( nbt );     }   This dead adventurer body  has two parts a block and a block Item  both has their own item-handlers and their own menus all of that seems fine  Testing remarks : *when i change some element inside the gui  it triggers the saveAdditional(nbt) system out and shows a pretty print of the data being saved  *when the world map loads it triggers the load(nbt) system out and shows a pretty print of the data minecraft is giving to this Block Entity For the testing i gonna set mi BlockEntityBodyBlock, save something in it, close minecraft, fireup the game again and check if the items remain      ################ first try set the block entity (dead adventurer body like shaped) and left only a weath seed  in the slot 10 the console says its all right    close minecraft, launch it again i see the system out whit the data returned to the entity and its look good theres is only a weed seed  ################ Second try, now i gonna change the seed for two arrows  the console says its all right the two arrows are being saved    ######### Now close and run again bam Error  minecraft returns the original data whit only a wheat seed the two arrows has been loss   ########## try again now i gonna put 3 wheat seeds Console system out says it gets it and is saving the data   ############## but after close fire again  wheat seed,  data losed once more time  and it just throw the original   ####################################################################################### sorry for the long post and the crappy video  this is the reason why i say its saving the Block Entity data only when it feels like  coze its saves data when it feels like  ¿ its something wrong whit mi BlockEntity.saveAdditional()  if  i keep trying eventually it updates and the data chages      i alredy try to  level.removeBlockEntity(pos); level.setBlockEntity(pos, bebb);     BlockEntityBodyBlock.class   BlockEntityInit.class     body_blockitem.class                  
    • Yesterday I buy a minecraft server to play with my friends you know... One of my friends send me the list of mods to add and then i start to dowload them, when i add them to the server it start crashing but i don't know about this things because it's my first time buying a minecraft server This is the error: https://paste.ee/p/sJf7B
    • Discovering that a trusted colleague had accessed my Bitcoin account and transferred $30,000 worth of bitcoins was a devastating blow. It shattered the trust I had placed in them and left me feeling vulnerable and betrayed. However, in the face of adversity, I turned to MUYERN TRUST HACKER for assistance in reclaiming control over my finances and holding the perpetrators accountable for their actions. One of the standout features of MUYERN TRUST HACKER was its ability to provide real-time alerts and notifications, keeping me informed every step of the way. With the support of MUYERN TRUST HACKER, I was able to gather irrefutable evidence of the perpetrator's actions and hold them accountable for their crimes. Armed with the information provided by the platform, I pursued legal recourse and ensured that justice was served. The perpetrator faced severe consequences for their actions, including legal penalties and financial restitution. Beyond its role in facilitating the recovery process, MUYERN TRUST HACKER provided me with a sense of empowerment and resilience in the face of adversity. While the experience was undoubtedly challenging, it ultimately served as a testament to the importance of vigilance and the power of technology in safeguarding our digital assets. Thanks to MUYERN TRUST HACKER, I emerged stronger and more resilient, ready to face whatever challenges the future may hold. Mail; muyerntrusted[At] mail-me .c o m
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.