Jump to content

Forge Problems?


Recommended Posts

I'm using the latest version of Forge, MC 1.4.4, and Magic Launcher.


Its a Forge error because I removed Forge from the internal mods list, and it worked fine, well except my mods.


*** MagicMinecraftLauncher 1.0.0 ***
java.lang.IncompatibleClassChangeError: Implementing class
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(Unknown Source)
    at java.security.SecureClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.access$100(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at magic.launcher.Launcher.main(Unknown Source)


I also have a clean Minecraft jar, and have tried redownloading Magic Launcher (on different versions also).

Link to comment
Share on other sites

Its the same thing. I've went to both main download, and the Forge 6.3.0 for MC 1.4.4 topic. It downloads the same file (hence the name being minecraftforge-universal- (1).zip) and still doesn't work. What else am I to download?


EDIT: I meant latest forge as in the main download topic on the releases forum.

Link to comment
Share on other sites

Now I get a new error, I get as far as the Mojang logo.


2012-11-17 22:47:09 [iNFO] [sTDERR] Exception in thread "Minecraft main thread" java.lang.VerifyError: (class: Config, method: getWorldServer signature: ()Lie;) Incompatible type for getting or setting field
2012-11-17 22:47:09 [iNFO] [sTDERR] 	at java.lang.Class.getDeclaredFields0(Native Method)
2012-11-17 22:47:09 [iNFO] [sTDERR] 	at java.lang.Class.privateGetDeclaredFields(Unknown Source)
2012-11-17 22:47:09 [iNFO] [sTDERR] 	at java.lang.Class.getField0(Unknown Source)
2012-11-17 22:47:09 [iNFO] [sTDERR] 	at java.lang.Class.getField(Unknown Source)
2012-11-17 22:47:09 [iNFO] [sTDERR] 	at cpw.mods.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:138)
2012-11-17 22:47:09 [iNFO] [sTDERR] 	at net.minecraft.client.Minecraft.a(Minecraft.java:424)
2012-11-17 22:47:09 [iNFO] [sTDERR] 	at net.minecraft.client.Minecraft.run(Minecraft.java:756)
2012-11-17 22:47:09 [iNFO] [sTDERR] 	at java.lang.Thread.run(Unknown Source)

Link to comment
Share on other sites

Install Optifine AFTER Forge. And make sure you've installed both correctly.


If that doesn't work then...you'll have to wait for Optifine to update. :-\

There's an EAQ for a reason. Read it!

"Note that failure to read this will make you look idiotic. You don't want that do you?" -- luacs1998


First rule of bug reports: More information is always better.

Oh, and logs OR IT DIDN'T HAPPEN!!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.