Jump to content

Remove java version nag (forge1.9-12.16.1.1887)


trefmanic

Recommended Posts

I've searched this forum and the only mention about it is in the release changelog, quoting

LexManos:

Add a java version detection and nag system for users on Java 7 or below.

Added detection of mods that rely on Java 8 and a graceful error screen.

The nag screen will be shown once a day. It can be disabled by editing the forge.cfg.

However it is HIGHLY recomended that user update to Java 8.

 

The problem is, I do not use Oracle Java at all and using openjdk 7 currently and newer versions are not available yet for my Linux distributions. So, my question is: how to disable nag screen and splashes?

 

I've checked forge.cfg and found this:

client {
...
    D:java8Reminder=1465767439359

 

It looks like it's a date in a Unix epoch format, so I've tried to change it to a date in the future (1490767439359), but it did not get rid of the splash text.

 

Link to comment
Share on other sites

Well, I'm using openjdk literally only for running Minecraft/Forge, so it's unlikely that I'm going to upgrade my entire OS just to get rid of this splash, nor I'm going to compile openjdk 8 from sources. Looks like it'll be my default splash message for some time now :) Thanks for replying anyway.

Link to comment
Share on other sites

Settings the number to something really high as described in the config will not show the nag.

As for the other stuff associated with it, there is no way to turn it off.

Update your java.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Consider supporting the team on Patreon

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Exception in thread "main" java.lang.IllegalStateException: Current Java is 1.8.0_271 but we require at least 17         at net.minecraftforge.bootstrap.shim.Main.main(Main.java:32) Never have successfully gotten a minecraft server up and running so I thought i'd try again. Instant unfixable issue.  
    • What MC version? What's the IP? Are any mods needed to be able to join?
    • Thank you for your answer ! Unfortunatly i have the same problem when i use setPos() public static int movingfunction(CommandContext<CommandSourceStack> context){ CommandSourceStack source = context.getSource(); if (!(source.getEntity() instanceof ServerPlayer)) { return 0; } ServerPlayer player = (ServerPlayer ) source.getEntity(); double moveSpeed = 0.5; for (int i =0; i<10000;i++) { LOGGER.info("running for the {} time", i); double x = player.getX() + player.getViewVector(1.0f).x * moveSpeed; double y = player.getY(); double z = player.getZ() + player.getViewVector(1.0f).z * moveSpeed ; Vec3 movementVec = new Vec3(x, y, z); LOGGER.info("x ={} y ={} z ={}", x, y, z); player.setPos( movementVec); } return 1; } With the logs i can see that x and z are increasing but once again my player is not moving. is there a function to use to sync the server and the client ? I also tried to use LocalPlayer instead of ServerPlayer but my code would stop when i got the object. Also i will change a bit the main topic but is there a way to similate key press ? i found KeyBinding.setKeyBindState on others post but it look like there is no more KeyBinding in 1.20   I found this code : KeyMapping.click(Minecraft.getInstance().options.keyUp.getKey()); But it doesn't seems to work   And i found this one : Minecraft.getInstance().options.keyUp.setDown(true); wich works but doesn't exactly do what i want , it doesn't release the key so for exemple i can't make him run. Minecraft.getInstance().options.keyUp.setDown(true); Minecraft.getInstance().options.keyUp.setDown(false); Minecraft.getInstance().options.keyUp.setDown(true); doesn't make him run
    • Add crash-reports with sites like https://paste.ee/ Maybe an issue with blur, essentials or cumulus_menus
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.