Jump to content

If anyone is having problems running a server with forge on Ubuntu, read this.


Recommended Posts

Just thought I'd pop in and let anyone who may be dealing with this irritating problem know how to get through it.


I google'd this issue earlier this evening and was met with a couple posts on the subject, both of which had our esteemed coder, LexManos, reacting in a rather douchey manner instead of actually working the situation out or trying to help.  No disrespect intended, but here;


"The issue is that you are failing at install ALL the files that forge ships, this isn't a forge issue, you just need to be better at copy/pasting files -.-

There is no help we can give you beyond, do it properly."


It appears that all of the .class files don't like being copied with Ubuntu (10.04, although I believe the issue is the same with 12) and it's default archiving software.  All you have to do is go through the folders and identify the ones that the class files don't properly copy into, then simply re-copy the missing class files, but not the folders, for some reason they won't copy if you attempt this, and your problem is solved.


Just finished setting up my personal server on my old slave machine now, works like a dream.


TL;DR  Double check all the .class files, like LexManos said, although don't think it's your fault.  It's not, it's just the os being wonky.



Link to comment
Share on other sites

If you're running the server there isn't a need to merge the files.

Just run java -jar yourforgezip.zip .

Read the EAQ before posting! OR ELSE!


This isn't building better software, its trying to grab a place in the commit list of a highly visible github project.




Don't PM me, I don't check this account unless I have to.

Link to comment
Share on other sites

I run my server using the method that luacs1998 posted. However before that method was available I used archive manager to install the forge files to the server jar. Never had any problems.


open both the forge universal file and the minecraft server file in two instances of archive manager. Then CTRL+A in the forge archive manager and drag it to the minecraft_server.jar archive manager. done.



Link to comment
Share on other sites

I run a variation of ubuntu on both my desktop and multiple servers.

The issue is that you are probably using the included zip manager with gnome, Archive something or so, it is a piece of crap.

Although you 'can' install things with it properly, it does not always if you do it the way you think you should.

I have used both Ark and the command line successfully and that is how I always do it.

So in essence, use a better zip program.

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.