Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

error with the CJB MOD


l12436
 Share

Recommended Posts

2013-03-16 19:47:44 [資訊] [sTDERR] java.lang.IllegalAccessError: tried to access method net.minecraft.entity.Entity.func_70022_Q()Ljava/lang/String; from class mod_cjb_moreinfo

2013-03-16 19:47:44 [資訊] [sTDERR]    at mod_cjb_moreinfo.renderMod(mod_cjb_moreinfo.java:177)

2013-03-16 19:47:44 [資訊] [sTDERR]    at mod_cjb_moreinfo.onTickInGame(mod_cjb_moreinfo.java:76)

2013-03-16 19:47:44 [資訊] [sTDERR]    at net.minecraft.src.BaseMod.doTickInGame(BaseMod.java:55)

2013-03-16 19:47:44 [資訊] [sTDERR]    at cpw.mods.fml.common.modloader.BaseModTicker.sendTick(BaseModTicker.java:102)

2013-03-16 19:47:44 [資訊] [sTDERR]    at cpw.mods.fml.common.modloader.BaseModTicker.tickBaseMod(BaseModTicker.java:82)

2013-03-16 19:47:44 [資訊] [sTDERR]    at cpw.mods.fml.common.modloader.BaseModTicker.tickEnd(BaseModTicker.java:56)

2013-03-16 19:47:44 [資訊] [sTDERR]    at cpw.mods.fml.common.SingleIntervalHandler.tickEnd(SingleIntervalHandler.java:34)

2013-03-16 19:47:44 [資訊] [sTDERR]    at cpw.mods.fml.common.FMLCommonHandler.tickEnd(FMLCommonHandler.java:140)

2013-03-16 19:47:44 [資訊] [sTDERR]    at cpw.mods.fml.common.FMLCommonHandler.onRenderTickEnd(FMLCommonHandler.java:379)

2013-03-16 19:47:44 [資訊] [sTDERR]    at net.minecraft.client.Minecraft.func_71411_J(Minecraft.java:868)

2013-03-16 19:47:44 [資訊] [sTDERR]    at net.minecraft.client.Minecraft.run(Minecraft.java:755)

2013-03-16 19:47:44 [資訊] [sTDERR]    at java.lang.Thread.run(Thread.java:722)

 

i do not known that why this will happened.

Link to comment
Share on other sites

This is an error caused by a new feature introduced with FML for 1.5.

 

For cpw: The runtime deobf feature causes an error with ModLoader mods:

These mods normally end up having all their files in the default package (after reobfuscation). With the runtime deobf these mods end up in net.minecraft.src. If they now access a protected function in Entity it works fine without deobf (both in default package) but with runtime deobf the mod class is in net.minecraft.src and Entity is in net.minecraft.entity, which causes the IllegalAccessError. I hope that made sense, but I guess you are not stupid :P

Link to comment
Share on other sites

so i need to change the protected to the public or create a class inside the package.

the second will make a large work in develop

 

and by the way.

the CJB MOD now is develop by me and i use the forge.

although some of code is still use the modloader.

Link to comment
Share on other sites

https://github.com/MinecraftForge/FML/commit/c5d5f4e5164111c5ae63e8de7ce97cc583d73e6e

It was a small bug, it has been fixed, update your forge.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Patreon: http://www.patreon.com/lexmanos
Paypal: http://paypal.me/LexManos

BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Here is my configuration: % java -version java version "18.0.2" 2022-07-19 Java(TM) SE Runtime Environment (build 18.0.2+9-61) Java HotSpot(TM) 64-Bit Server VM (build 18.0.2+9-61, mixed mode, sharing) forge-1.19-41.1.0-mdk on macOS Monterey 12.5 I ran the command: ./gradlew genEclipseRuns and was hoping it will generate the Eclipse project files for me. The run log is at https://gist.github.com/arun-gupta/06b983a6976b4c0a0f510d0dc225ddd3 and the generated directory structure is at https://gist.github.com/arun-gupta/3f5bfc70ec5d3d903b0f97d42840abda. In previous versions (1.12-ish), it used to generate an eclipse directory but 1.19 does not seem to have it. I tried opening the top-level forge directory but Eclipse does not recognize it as a project as well. How do I open this project in Eclipse now?  
    • I didn't put in credentials, I used it only for testing installing forge. But still the problem mentioned above.
    • I am trying to use Forge 1.18.2, I have checked my firewall, redownloaded Forge, deleted the fml.toml file (which keeps reappearing) and looked at countless help pages. I am just trying to download and use forge so that I can play with my friends and it will not download. It tells me there may be an issue with the Java runtime config and that the exit code is one, and I have copied the exit code.   
    • Okay, i think i understand but im getting issues, i create another packet to sync entity to another players like this package com.naim.belloto.networking.packet; import com.naim.belloto.networking.handler.ClientSyncHandler; import net.minecraft.client.Minecraft; import net.minecraft.network.FriendlyByteBuf; import net.minecraftforge.api.distmarker.Dist; import net.minecraftforge.fml.DistExecutor; import net.minecraftforge.network.NetworkEvent; import java.util.Objects; import java.util.function.Supplier; public class ClientSyncPacket { public ClientSyncPacket() { } public ClientSyncPacket(FriendlyByteBuf buf) { } public void toBytes(FriendlyByteBuf buf) { } public boolean handle(Supplier<NetworkEvent.Context> ctx) { NetworkEvent.Context context = ctx.get(); context.enqueueWork(() -> { assert Minecraft.getInstance().player != null; int idplayer = Minecraft.getInstance().player.getId(); DistExecutor.unsafeCallWhenOn(Dist.CLIENT,() -> () -> ClientSyncHandler.handlePacket(ctx, idplayer)); }); return true; } } And in the handler: public class ClientSyncHandler { public static boolean handlePacket(Supplier<NetworkEvent.Context> ctx, int idPlayer) { Minecraft.getInstance().level.getEntity(idPlayer); return true; } } But is not working :// 
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.