Jump to content

Having trouble setting up a dev environment with a forked GitHub repository


ThePwnd

Recommended Posts

Greetings all,

 

Couple of first notes - 1) I'm pretty new to this, so if something I say or did seems ignorant, please don't judge too hard, and 2) I'm working in Minecraft 1.7.10 on Windows 7 for this project.

 

Recently I created a fork of Terra Firma Craft's source code with the ultimate intention of making a more modular version so that it will be more compatible with other world gen mods.  I downloaded the official GitHub Desktop Client and used it to clone the repository I created into a workspace folder on my computer.  However, after doing this, I've run into some problems trying to create a project in Eclipse.

 

I'm pretty sure the first thing I need to do is open a command prompt in my workspace folder and run 

gradlew setupDecompWorkspace

which seems to run without any errors:

image.png.62da038b7915b8368c914333f842de49.png

 

followed by

gradlew eclipse

Here's the output:

image.png.fede4343cfbe5d4e5b24cd7a9e77da9b.png

 

Those commands seem to run without any errors, but no "eclipse" folder gets created.  I took a look at the build.gradle file, and it appears that instead of an "eclipse" folder, the "run" folder is created instead to serve the same purpose.  So I open Eclipse and try to set my project workspace to the "run" folder, but when I do that, Eclipse doesn't seem to think that any project actually exists.

image.thumb.png.39bcb52ad46176739bfc685870f5c5f9.png

 

Interestingly, I just noticed that the Git perspective does show the repository, but it doesn't seem to be what I need in order to edit the project.  So, the next thing I tried was to create a new forge dev environment (the default one, with the example mod), then copy over the source folders, add them to the build path, and add the extra libraries that TFC needed after reading the build.gradle file.  However, and this is where it gets really weird, now the TFC source code is still full of errors.  There are a couple visibility issues and a whole bunch of "cannot be assigned" errors.

image.thumb.png.05f42c875e53ec8a6db745747e00374f.png

 

I'm definitely using the master branch, so it seems like there must be a step that I'm missing on my end.  It can't be that TFC's source code on their master branch is broken, and this badly, can it?

 

This has had me scratching my head all week.  I posted about it over on Minecraft Forum but I haven't gotten any response back about it.  If anyone can spot what the problem is, I'd really appreciate it.

Link to comment
Share on other sites

2 hours ago, diesieben07 said:

*shudders*. Use Git from the command line.

 

If you're planning a career in software, yes you need to get intimate understanding of how git command line works. In fact it is common interview question. However, it is also 2018 and all the concepts of revision control lend themselves very well to a graphical representation. In fact pretty much every tutorial for using git ends up drawing all sorts of diagrams to show the head and commits, and such. For most hobbyists a git GUI (I recommend SourceTree) works very well. In any case, I'd rather have everyone using source control rather than not, and a GUI makes it a lot more accessible to beginners.

Edited by jabelar

Check out my tutorials here: http://jabelarminecraft.blogspot.com/

Link to comment
Share on other sites

Alright, it's decided then, I'm downloading SourceTree.

 

4 hours ago, diesieben07 said:

Seems like TF might be using some access transformers.

In eclipse you need to do File > Import > General > Existing Projects into Workspace and then select the project root (where your build.gradle is). However looking at TF's repository, they are not following any kind of standard, so I doubt this will work easily.

 

Interestingly, that worked this time.  I tried that before and I kept getting a no valid project found error.  There are no errors, and all the required libraries are being referenced, but I'm getting 549 java *warnings,* almost all of which are "raw type" errors.  I'm thinking that this is something the devs did, and not another mistake I've made on my end in trying to get the project setup... >.>

Link to comment
Share on other sites

48 minutes ago, diesieben07 said:

Yes, that is bad Java code.

It's TerraFirmaCraft, the Minecraft mod that gives no fucks about being compatible with anyone or anything.

 

And also:

 

7 hours ago, ThePwnd said:

Minecraft 1.7.10

 

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Ok yeah I think this might be where the problem starts. For starters, I think you can get rid of your RecipeType impl and make it a static constant instead. I'm not 100% sure this will fix it but it's posssible. RuneInscribingRecipe public class RuneInscribingRecipe implements Recipe<SimpleContainer> { public static final RecipeType<RuneInscribingRecipe> RECIPE_TYPE = new RecipeType<>(){}; // .... @Override public RecipeType<?> getType() { return RECIPE_TYPE; } // .... } RuneInscriberMenu private Optional<RecipeHolder<RuneInscribingRecipe>> getCurrentRecipe() { SimpleContainer inventory = new SimpleContainer(2); inventory.setItem(BASE_INPUT_SLOT, this.inventory.getStackInSlot(BASE_INPUT_SLOT)); inventory.setItem(TEMPLATE_INPUT_SLOT, this.inventory.getStackInSlot(TEMPLATE_INPUT_SLOT)); List<RecipeHolder<RuneInscribingRecipe>> list = this.blockEntity.getLevel().getRecipeManager().getRecipesFor(RuneInscribingRecipe.RECIPE_TYPE, inventory, this.blockEntity.getLevel()); if (list.isEmpty()) { return Optional.empty(); } return Optional.of(list.get(0)); }   Also, this here is a little suspicious where you're getting the `this.inventory.getStackInSlot` calls. I'd try and make sure those are what you expect they are with either a Debug line in IDE or print statement SimpleContainer inventory = new SimpleContainer(2); inventory.setItem(BASE_INPUT_SLOT, this.inventory.getStackInSlot(BASE_INPUT_SLOT)); System.out.printf("CHECKING BASE INPUT OF RECIPE: %s\n", this.inventory.getStackInSlot(BASE_INPUT_SLOT)); inventory.setItem(TEMPLATE_INPUT_SLOT, this.inventory.getStackInSlot(TEMPLATE_INPUT_SLOT)); System.out.printf("CHECKING TEMPLATE INPUT OF RECIPE: %s\n", this.inventory.getStackInSlot(TEMPLATE_INPUT_SLOT)); ^ See what the result of those print statements are, make sure they're right
    • Upon testing again after adding them, the game still doesn't crash however the resource packs are still unfortunately broken.
    • Hi! Can someone please point me to the correct FAQ or place? I'm not able do DuckDuckGo myself out of this one. As you can hopefully see, chunks are not rendered. I run a forge server, fresh install on a linux VM. Curseforge on the Win11 client with Embeddium, Oculus and Unbound shader. No mods. Forge 47.2.23 on server & client.  No errors, no crashes, no apparent CPU or RAM issues with the VM. This screenshot was captured while creative, but the same happens when flying in survival. Waiting (floating) for a few minutes sooner or (often) later, lets the missing chunks appear. Usually takes 5-10 minutes.  When on a local game, the chunks appear slowly, but they do appear without pause.   This must be something simple, obvious, but I can't find the correct "search words" to find my way out. "Chunks not loading / rendering" didn't help. Browsing several forums neither. 
    • This is the Forge forums. We only support Forge here. Read the FAQ
    • 1.The game doesn't crash, everything seems normal, but when i insert the designated items into the block entity, the result item does not show up. 2.Yes, I'm using a custom menu, here's the source code:  
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.