Jump to content

[1.8.9] Forge Install failed OS X 10.13.6


Recommended Posts

Hey! First of all, I don't know if I'm allowed to do this according to the E.A.Q., but I haven't seen a fix for this issue, and I want to play. (reasoning 100) I have previously installed a multitude of FML versions, from 1.8.9, 1.10.2, 1.11.0, 1.11.2., and 1.12.2. I installed all of these before moving to OS X High Sierra, and I believe I was on OS X Mountian Lion. (apple make these names shorter) I wanted to play a simplified version of my 1.8.9 mods, so I went through my mods folder and removed about half of the ones that I don't need. I then search "forge 1.8.9", first link, universal, while downloading launch vanilla 1.8.9, download done, drag file to the desktop, double click. I got the stupid "uhh hey man this file is from an unknown developer. if you wan open the 100% virus malware file, go to system preferences > security and privacy, and open it from there". So I do that, double click on the icon again, and I get this error. 

The Java JAR file "forge-1.8.9-" could not be launched. Check the console for possible error messages.

Okay. (cmon man i just want to play minecraft) I check the console, and I think this is the error messages, but I could be completely wrong. I am not versed in the code lingo.

Mar  8 21:26:14 Gregory-Kastens-Mac-mini launcher[3148]: Claimed it found a path: /Applications/Minecraft.app/Contents/MacOS/launcher (/Applications/Minecraft.app/Contents/MacOS/launcher) 4096
Mar  8 21:26:14 Gregory-Kastens-Mac-mini com.apple.xpc.launchd[1] (com.apple.preference.displays.MirrorDisplays): Service only ran for 0 seconds. Pushing respawn out by 10 seconds.
Mar  8 21:26:14 Gregory-Kastens-Mac-mini systemstats[63]: assertion failed: 17G65: systemstats + 914800 [D1E75C38-62CE-3D77-9ED3-5F6D38EF0676]: 0x40
Mar  8 21:26:16 Gregory-Kastens-Mac-mini launcher[3148]: [0308/212616:ERROR:LocalVersionProvider.cpp(145)] Found an unexpected file .DS_Store
Mar  8 21:26:16 Gregory-Kastens-Mac-mini launcher[3148]: [0308/212616:ERROR:LocalVersionProvider.cpp(140)] Version OptiFine_1.3.1_HD_U_A1 doesn't have a json file.
Mar  8 21:26:16 Gregory-Kastens-Mac-mini launcher[3148]: [0308/212616:ERROR:LocalVersionProvider.cpp(140)] Version  doesn't have a json file.
Mar  8 21:26:24 Gregory-Kastens-Mac-mini com.apple.xpc.launchd[1] (com.apple.preference.displays.MirrorDisplays): Service only ran for 0 seconds. Pushing respawn out by 10 seconds.

I did do a little bit of research beforehand, and I found a guide that should help you geniuses out.

Last login: Fri Mar  8 20:56:46 on ttys001
Gregory-Kastens-Mac-mini:~ Greg$ java -version
java version "1.8.0_131"
Java(TM) SE Runtime Environment (build 1.8.0_131-b11)
Java HotSpot(TM) 64-Bit Server VM (build 25.131-b11, mixed mode)
Gregory-Kastens-Mac-mini:~ Greg$ java -jar /Users/Greg/Desktop/forge-1.8.9- 
We appear to be missing one or more essential library files.
You will need to add them to your server before FML and Forge will run successfully.java.lang.ClassNotFoundException: net.minecraft.launchwrapper.Launch
	at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:335)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	at java.lang.Class.forName0(Native Method)
	at java.lang.Class.forName(Class.java:348)
	at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:25)
	at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:12)

 This is all of the information I can give you right now, and any help would be much appreciated. Thanks for reading, and have a good day!

Edited by Tethys
small oopsie in title
Link to comment
Share on other sites

I tried that. Multiple times. I run the installer .jar file, and I get the same error

The Java JAR file "forge-1.8.9-" could not be launched. Check the console for possible error messages.

If you know of anything else, the help would be appreciated.

Link to comment
Share on other sites

That's not the installer, that's the actual server file...

This is my Forum Signature, I am currently attempting to transform it into a small guide for fixing easier issues using spoiler blocks to keep things tidy.


As the most common issue I feel I should put this outside the main bulk:

The only official source for Forge is https://files.minecraftforge.net, and the only site I trust for getting mods is CurseForge.

If you use any site other than these, please take a look at the StopModReposts project and install their browser extension, I would also advise running a virus scan.


For players asking for assistance with Forge please expand the spoiler below and read the appropriate section(s) in its/their entirety.


Logs (Most issues require logs to diagnose):


Please post logs using one of the following sites (Thank you Lumber Wizard for the list):

https://gist.github.com/100MB Requires member (Free)

https://pastebin.com/: 512KB as guest, 10MB as Pro ($$$)

https://hastebin.com/: 400KB

Do NOT use sites like Mediafire, Dropbox, OneDrive, Google Drive, or a site that has a countdown before offering downloads.


What to provide:

...for Crashes and Runtime issues:

Minecraft 1.14.4 and newer:

Post debug.log

Older versions:

Please update...


...for Installer Issues:

Post your installer log, found in the same place you ran the installer

This log will be called either installer.log or named the same as the installer but with .log on the end

Note for Windows users:

Windows hides file extensions by default so the installer may appear without the .jar extension then when the .log is added the log will appear with the .jar extension


Where to get it:

Mojang Launcher: When using the Mojang launcher debug.log is found in .minecraft\logs.


Curse/Overwolf: If you are using the Curse Launcher, their configurations break Forge's log settings, fortunately there is an easier workaround than I originally thought, this works even with Curse's installation of the Minecraft launcher as long as it is not launched THROUGH Twitch:

  1. Make sure you have the correct version of Forge installed (some packs are heavily dependent on one specific build of Forge)
  2. Make a launcher profile targeting this version of Forge.
  3. Set the launcher profile's GameDir property to the pack's instance folder (not the instances folder, the folder that has the pack's name on it).
  4. Now launch the pack through that profile and follow the "Mojang Launcher" instructions above.






or alternately, 


Fallback ("No logs are generated"):

If you don't see logs generated in the usual place, provide the launcher_log.txt from .minecraft


Server Not Starting:


If your server does not start or a command window appears and immediately goes away, run the jar manually and provide the output.


Reporting Illegal/Inappropriate Adfocus Ads:


Get a screenshot of the URL bar or copy/paste the whole URL into a thread on the General Discussion board with a description of the Ad.

Lex will need the Ad ID contained in that URL to report it to Adfocus' support team.


Posting your mod as a GitHub Repo:


When you have an issue with your mod the most helpful thing you can do when asking for help is to provide your code to those helping you. The most convenient way to do this is via GitHub or another source control hub.

When setting up a GitHub Repo it might seem easy to just upload everything, however this method has the potential for mistakes that could lead to trouble later on, it is recommended to use a Git client or to get comfortable with the Git command line. The following instructions will use the Git Command Line and as such they assume you already have it installed and that you have created a repository.


  1. Open a command prompt (CMD, Powershell, Terminal, etc).
  2. Navigate to the folder you extracted Forge’s MDK to (the one that had all the licenses in).
  3. Run the following commands:
    1. git init
    2. git remote add origin [Your Repository's URL]
      • In the case of GitHub it should look like: https://GitHub.com/[Your Username]/[Repo Name].git
    3. git fetch
    4. git checkout --track origin/master
    5. git stage *
    6. git commit -m "[Your commit message]"
    7. git push
  4. Navigate to GitHub and you should now see most of the files.
    • note that it is intentional that some are not synced with GitHub and this is done with the (hidden) .gitignore file that Forge’s MDK has provided (hence the strictness on which folder git init is run from)
  5. Now you can share your GitHub link with those who you are asking for help.

[Workaround line, please ignore]


Link to comment
Share on other sites

  • 9 months later...
  • Guest locked this topic
This topic is now closed to further replies.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.