Jump to content

[SOLVED] Block Texture not showing, also no error log


Recommended Posts



I have the following:




        "parent": "block/cube_all",

        "textures": {

            "all": "comtech:blocks/ore_aluminium







    "forge_marker": 1,

    "defaults": {

        "model": "comtech:ore_aluminium"


    "variants": {

        "normal": [{}],

        "inventory: [{}]




and my texture file is in the following place:


When I load up the game, initially, I had a whole heap of errors which unfortunately I do not remember. What I do remember however, is that it said it couldn't find something for my block. This disappeared however, once I had added an entry into my .lang file and it runs as "normal". However, when I go into the inventory, the texture in there is the default no texture found icon.


Any ideas what might be happening? I've tried the solutions on the internet but they don't seem to be working in my case.


It seems to just be the inventory icon that I'm having an issue with, when I place the block in the world, the sides of the block are textured appropriately.

Edited by JamieEdwards
It got solved.
Link to comment
Share on other sites

16 minutes ago, JamieEdwards said:

It seems to just be the inventory icon that I'm having an issue with

Do you have a model file for your block? If you are using 1.12.2 you also need to register the model for the ItemBlock.


I will be posting 1.15.2 modding tutorials on this channel. If you want to be notified of it do the normal YouTube stuff like subscribing, ect.

Forge and vanilla BlockState generator.

Link to comment
Share on other sites

Please post your code, preferably as a GitHub repo.

Some tips:


Modder Support:


1. Do not follow tutorials on YouTube, especially TechnoVision (previously called Loremaster) and HarryTalks, due to their promotion of bad practice and usage of outdated code.

2. Always post your code.

3. Never copy and paste code. You won't learn anything from doing that.



Programming via Eclipse's hotfixes will get you nowhere

5. Learn to use your IDE, especially the debugger.



The "picture that's worth 1000 words" only works if there's an obvious problem or a freehand red circle around it.

Support & Bug Reports:


1. Read the EAQ before asking for help. Remember to provide the appropriate log(s).

2. Versions below 1.11 are no longer supported due to their age. Update to a modern version of Minecraft to receive support.



Link to comment
Share on other sites

I feel like an idiot.... I figured out what the problem was.


I was doing everything right EXCEPT, I didn't set the customModelResourceLocation for the inventory icon. It's fixed now and works absolutely fine.


I also get why I wasn't getting any errors too, given that the game didn't even know that the icons existed in the first place.


Sorry guys for wasting time!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.