Jump to content

Disappearing Shrubs when using Highlight tooltip from NEI or TukMC


Recommended Posts

Hi, I'm not sure if this is a Forge bug or Minecraft itself, but anyway, here's what happens.


There some selected shrubs (plants - what do you call them technically again?) that disappear when my cursor is focused on them while the Highlight Tooltip or Display Block ID is enabled. What will happen is that the ID will appear in a blink then the shrub disappears. This is both from using NEI's highlight tooltip and TukMC's Display block ID.


Tests done so far:


Minecraft Forge



Wild Caves 3


Result: Bomb flower, glowing Mushroom disappears when focused while using Highlight tooltip or Display Block ID.


Minecraft Forge


Wild Caves 3


Result: The same


Even tried using just one of the 2 mods affected and the result was still the same. Also tried removing TuKMC and resulted to using NEI for the Display Block ID and it was also the same.


Shrubs that are affected:

Bomb Flower - NMcCoy-LegendGear-1.5.2

Glowing Mushrooms - Wild Caves 3


There was another shrub that disappears from a different mod, I'm not sure which, but anyway, the bug happens so far on those 2 things as far as I noticed.


The shrub disappears/turns invisible from my screen, the highlight box (wireframe) when you focus your cursor to the shrub disappears as well but the thing is, the shrub is still there. When I relog, it show back up but when I focus my mouse on the specified shrubs, they disappear again. They will abruptly display their block ID then disappear along with a noticeable lag during the transition.


This doesn't happen when I disable the Highlight Tooltip or Display Block ID though.


Anyhow, I hope this is sufficient. Thanks.

Link to comment
Share on other sites

Hey, thanks for the heads up. Well, the reason why I didn't went ahead talking to NEI guys is that the TukMC Mod (specifically a GUI mod that displays some very helpful info) has the same Display Block ID function option, although the display onscreen is quite different than the NEI's Highlight tooltip.


I went and test it out to narrow down the possibilities, I tried loading the game with only NEI and one of the affected mods (Legend Gear, Wildcaves) to re-create the issue, the same with loading the game with only TukMC + one of the affected mods. Both instances were giving the same results over the given shrubs.


With that, given that both instances were giving the same result, I thought it could be from Forge itself. Well, thanks again, I'll try and see if NEI can do something.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.