• Recently Browsing

    No registered users viewing this page.

  • Posts

    • @diesieben07 Alright so I have the following, and the base model seems to be functioning just fine. However the GUI perspective just shows up as blank. No "missing model/texture" purple and black icon, just blank. Any idea why that might be?   I put some log messages in the code and found that it is detecting the GUI item model, and is loading it. It's just not doing it correctly for some reason.   { "loader": "mymodid:separate-perspective", "base": { "textures": { "0": "mymodid:item/flintlock", "particle": "mymodid:item/flintlock" }, "elements": [ { "from": [7, 6.75, -3], "to": [9, 8.75, 6], "rotation": {"angle": 0, "axis": "y", "origin": [8, 7.00105, 7.80305]}, "faces": { "north": {"uv": [9.5, 2.5, 11.5, 0.5], "texture": "#0"}, "east": {"uv": [0, 2, 9, 0], "rotation": 180, "texture": "#0"}, "south": {"uv": [9.5, 2.5, 11.5, 0.5], "texture": "#0"}, "west": {"uv": [0, 0, 9, 2], "texture": "#0"}, "up": {"uv": [0, 2, 9, 0], "rotation": 90, "texture": "#0"}, "down": {"uv": [0, 0, 9, 2], "rotation": 270, "texture": "#0"} } }, { "from": [8, 8.75, -3], "to": [8, 9.75, -1], "rotation": {"angle": 0, "axis": "y", "origin": [8, 7.00105, 7.80305]}, "faces": { "north": {"uv": [0, 0, 2, 1], "texture": "#0"}, "east": {"uv": [6, 15, 4, 16], "texture": "#0"}, "south": {"uv": [0, 0, 2, 1], "texture": "#0"}, "west": {"uv": [4, 15, 6, 16], "texture": "#0"}, "up": {"uv": [0, 0, 2, 1], "texture": "#0"}, "down": {"uv": [0, 0, 2, 1], "texture": "#0"} } }, { "from": [6.5, 7.75, 6], "to": [9.5, 8.75, 13], "rotation": {"angle": 0, "axis": "y", "origin": [8, 7.00105, 7.80305]}, "faces": { "north": {"uv": [6, 10, 3, 11], "texture": "#0"}, "east": {"uv": [7, 3, 14, 4], "texture": "#0"}, "south": {"uv": [13, 0, 12, 3], "rotation": 90, "texture": "#0"}, "west": {"uv": [14, 3, 7, 4], "texture": "#0"}, "up": {"uv": [9, 9, 6, 16], "texture": "#0"}, "down": {"uv": [7, 0, 0, 1], "texture": "#0"} } }, { "from": [6.5, 4.75, 2], "to": [9.5, 7.75, 13], "rotation": {"angle": 0, "axis": "y", "origin": [8, 7.00105, 7.80305]}, "faces": { "north": {"uv": [6, 11, 3, 14], "texture": "#0"}, "east": {"uv": [14, 4, 3, 7], "texture": "#0"}, "south": {"uv": [16, 0, 13, 3], "rotation": 270, "texture": "#0"}, "west": {"uv": [3, 4, 14, 7], "texture": "#0"}, "up": {"uv": [3, 3, 0, 14], "rotation": 180, "texture": "#0"}, "down": {"uv": [3, 3, 0, 14], "texture": "#0"} } }, { "from": [8, 2.75, 10], "to": [8, 4.75, 14], "rotation": {"angle": 0, "axis": "y", "origin": [8, 7.00105, 7.80305]}, "faces": { "north": {"uv": [0, 0, 4, 2], "texture": "#0"}, "east": {"uv": [4, 14, 0, 16], "texture": "#0"}, "south": {"uv": [0, 0, 4, 2], "texture": "#0"}, "west": {"uv": [0, 14, 4, 16], "texture": "#0"}, "up": {"uv": [0, 0, 4, 2], "texture": "#0"}, "down": {"uv": [0, 0, 4, 2], "texture": "#0"} } }, { "from": [8, 8.75, 10], "to": [8, 9.75, 12], "rotation": {"angle": 0, "axis": "y", "origin": [8, 7.00105, 7.80305]}, "faces": { "north": {"uv": [0, 0, 2, 1], "texture": "#0"}, "east": {"uv": [6, 15, 4, 16], "texture": "#0"}, "south": {"uv": [0, 0, 2, 1], "texture": "#0"}, "west": {"uv": [4, 15, 6, 16], "texture": "#0"}, "up": {"uv": [0, 0, 2, 1], "texture": "#0"}, "down": {"uv": [0, 0, 2, 1], "texture": "#0"} } }, { "from": [7, -4.43706, 9.71454], "to": [9, 4.56294, 12.71454], "rotation": {"angle": -45, "axis": "x", "origin": [8, 7.00105, 7.80305]}, "faces": { "north": {"uv": [9, 7, 11, 16], "texture": "#0"}, "east": {"uv": [13, 7, 16, 16], "texture": "#0"}, "south": {"uv": [11, 7, 13, 16], "texture": "#0"}, "west": {"uv": [16, 7, 13, 16], "texture": "#0"}, "up": {"uv": [0, 0, 3, 9], "texture": "#0"}, "down": {"uv": [14, 4, 16, 7], "texture": "#0"} } } ], "display": { "thirdperson_righthand": { "rotation": [60, 0, 0], "translation": [0, 4, 1], "scale": [0.55, 0.55, 0.55] }, "thirdperson_lefthand": { "rotation": [60, 0, 0], "translation": [0, 4, 1], "scale": [0.55, 0.55, 0.55] }, "firstperson_righthand": { "translation": [1, 3, 1], "scale": [0.68, 0.68, 0.68] }, "firstperson_lefthand": { "translation": [1, 3, 1], "scale": [0.68, 0.68, 0.68] }, "ground": { "translation": [0, 2, 0], "scale": [0.5, 0.5, 0.5] }, "gui": { "rotation": [30, 45, 0], "scale": [0.625, 0.625, 0.625] }, "head": { "rotation": [0, 180, 0], "translation": [0, 13, 7] }, "fixed": { "rotation": [90, 60, -90], "translation": [1, 2, 0] } }, "groups": [ { "name": "pistol Breech", "origin": [8, 7.00105, 7.80305], "children": [0, 1] }, { "name": "pistol", "origin": [8, 7.00105, 7.80305], "children": [2, 3, 4, 5, 6] } ] }, "perspectives": { "gui": { "parent": "item/generated", "textures": { "layer0": "mymodid:item/flintlock_icon" } } } }  
    • Well, it might help if you enable the lightmap associated with the block. Also, why not render a block using BlockRendererDispatcher? Finally, why do you even need to render a custom version of a block?
    • Also, make sure every single mod on the server and client are the same version as well as the forge version. Although they are both 1.16.4 they might not be the same forge version.
    • after trying to launch my server in forge 1.16.4, this happened. my the jar file for the server is 1.16.4, and my client is forge 1.16.4. I dont understand as they are running the same version
  • Topics

  • Who's Online (See full list)