Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

java.lang.ExeptionInInitializerError: null


Recommended Posts

I am making a mod right? Im using IntellijIdea but its not an issue with Intellij I dont think... I keep on getting an error when i try to run the client (the pastebin is down below). A little something you should know - This is 1.16.5, it was working earlier until i added blocks, and i am a complete noob.

 

https://pastebin.com/Ynj862CG

 

 

any help is GREATLY appreciated

Link to post
Share on other sites
Posted (edited)

Like, they work when i place them down but not when i am holding them in my inventory.... do i have to add the item into the lang file?

 

 

 

I updated the git hub BTW

Edited by We Random
Link to post
Share on other sites

The lang file has nothing to do with textures and models..the problem here is that your block have different registry name from their respective block items. Here:

https://github.com/WeRandom/My-Butiful-Test-Mod/blob/main/Test Mod - Copy/src/main/java/com/_shadow_/test/setup/ModBlocks.java

Check out the port of the BetterEnd fabric mod (WIP): https://www.curseforge.com/minecraft/mc-mods/betterend-forge-port

Link to post
Share on other sites
4 hours ago, We Random said:

ooooooooooooooooooooooooooooh ok thank you sooooooooo so much!!!!!!!!

 

i didnt know that capitals were invalid

I mean...that's literally what the error says.

Quote

Non [a-z0-9/._-] character in path of location: tbmem:Silver_Ore_Block

a-z, not a-Z.

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • Hello. I am trying to use a gradle librarie in my mod. But when I use "gradlew build" it doesn't compile my librarie and in-game it shows me an error (classnotfoundexception). How can I do that? Thanks
    • Hello @ChampionAsh5357, thank you for your reply! I do not use the newer version of netty directly. It's a transitive dependency of Discord4j: +--- com.discord4j:discord4j-core:3.1.3 | +--- io.projectreactor:reactor-bom:Dysprosium-SR15 | | ... | +--- com.discord4j:discord-json:1.5.6 | | ... | +--- com.discord4j:discord4j-rest:3.1.3 | | ... | | \--- com.discord4j:discord4j-common:3.1.3 | | +--- io.projectreactor:reactor-bom:Dysprosium-SR15 (*) | | +--- com.discord4j:discord-json:1.5.6 (*) | | +--- io.projectreactor.netty:reactor-netty:0.9.15.RELEASE | | | +--- io.netty:netty-codec-http:4.1.54.Final (BTW, Minecraft is using io.netty:netty-all:4.1.25.Final)   I thought those line will extend "compile" by "shadow" configuration, making "compile" inherit dependencies from "shaodw": https://github.com/tony84727/xp-tweak/blob/7f24df8f46f78840d145605db1d2cfdd988ef66b/build.gradle#L114-L117 But anyway, I tried. I added netty dependency to the buildscript and found out that ./gradlew runServer is working!🎉 (the PR) However, for intellij runs, still no luck. (I've run ./gradlew genIntellijRuns again after updating the buildscript). Starting server by IDE runs will still throw java.lang.NoSuchMethodError, indicating those runs are still using old version of netty.   I still wish I can launch server by IDE runs so I can use IDE's debug utilities.
    • now I don't know how to help you you may want to create a new topic asking for help with that   the only thing that comes to mind isthat if you're on intelliJ, check if those are actaully subdirectories and not a single directory with dots in the name (as that is a very common problem that happens when people are modding with intelliJ)
    • Yes! thank you, it works great now. One more thing though, I followed default minecraft code for the armor, but even though I have all my layers in assets/gemstones/textures/models/armor it still shows up on my character as the 'no-texture' texture.
    • Exception message: java.lang.IllegalArgumentException: Duplicate registration jade you're registering "jade" twice, I think that should be the only thing wrong oh also, your enum constants should be all uppercased (it won't cause any errors of course, but it's the standard)  
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.