Jump to content

Error while making spawn egg of a skeleton


Recommended Posts

I tried this code but I got an error while making custom spawn egg for a skeleton(this skeleton is a vanilla minecraft entity) I think I know why this error is coming, but I don't know how to solve it, can you please help, I am sharing the code - 

package com.anirudh.forgemod.init;

import com.anirudh.forgemod.ForgeMod;
import com.anirudh.forgemod.items.ItemBase;
import com.anirudh.forgemod.items.ModSpawnEggItem;
import com.anirudh.forgemod.items.StrongestApple;
import com.anirudh.forgemod.util.enums.ModArmorMaterial;
import net.minecraft.world.entity.EntityType;
import net.minecraft.world.entity.EquipmentSlot;
import net.minecraft.world.item.ArmorItem;
import net.minecraft.world.item.CreativeModeTab;
import net.minecraft.world.item.Item;
import net.minecraftforge.fmllegacy.RegistryObject;
import net.minecraftforge.registries.DeferredRegister;
import net.minecraftforge.registries.ForgeRegistries;

public class ModItems {

    public static DeferredRegister<Item> ITEMS = DeferredRegister.create(ForgeRegistries.ITEMS, ForgeMod.MOD_ID);

    public static final RegistryObject<Item> RUBY = ITEMS.register("ruby", ItemBase::new);
    public static final RegistryObject<StrongestApple> POISON_APPLE = ITEMS.register("strongest_apple", StrongestApple::new);

    public static final RegistryObject<ModSpawnEggItem> SKELETON_SPAWN_EGG = ITEMS.register("skeleton_spawn_egg",
            () -> new ModSpawnEggItem(EntityType.SKELETON, 0x00FFA8, 0x326D59, new Item.Properties().tab(CreativeModeTab.TAB_MATERIALS)));

    public static final RegistryObject<ArmorItem> RUBY_HELMET = ITEMS.register("ruby_helmet", () ->
            new ArmorItem(ModArmorMaterial.RUBY, EquipmentSlot.HEAD, new Item.Properties().tab(CreativeModeTab.TAB_COMBAT)));

    public static final RegistryObject<ArmorItem> RUBY_CHESTPLATE = ITEMS.register("ruby_chestplate", () ->
            new ArmorItem(ModArmorMaterial.RUBY, EquipmentSlot.CHEST, new Item.Properties().tab(CreativeModeTab.TAB_COMBAT)));

    public static final RegistryObject<ArmorItem> RUBY_LEGGINGS = ITEMS.register("ruby_leggings", () ->
            new ArmorItem(ModArmorMaterial.RUBY, EquipmentSlot.LEGS, new Item.Properties().tab(CreativeModeTab.TAB_COMBAT)));

    public static final RegistryObject<ArmorItem> RUBY_BOOTS = ITEMS.register("ruby_boots", () ->
            new ArmorItem(ModArmorMaterial.RUBY, EquipmentSlot.FEET, new Item.Properties().tab(CreativeModeTab.TAB_COMBAT)));


Link to comment
Share on other sites

I think the error comes from this java class even though it dosen't show any error - 

package com.mahidhoni123.forgemod.items;

import net.minecraft.core.BlockSource;
import net.minecraft.core.Direction;
import net.minecraft.core.dispenser.DefaultDispenseItemBehavior;
import net.minecraft.nbt.CompoundTag;
import net.minecraft.world.entity.EntityType;
import net.minecraft.world.entity.MobSpawnType;
import net.minecraft.world.item.ItemStack;
import net.minecraft.world.item.SpawnEggItem;
import net.minecraft.world.level.block.DispenserBlock;
import net.minecraftforge.common.util.Lazy;
import net.minecraftforge.fml.util.ObfuscationReflectionHelper;
import net.minecraftforge.fmllegacy.RegistryObject;

import java.util.ArrayList;
import java.util.List;
import java.util.Map;

public class ModSpawnEggItem extends SpawnEggItem {

    protected static final List<ModSpawnEggItem> UNADDED_EGGS = new ArrayList<>();
    private final Lazy<? extends EntityType<?>> entityTypeSupplier;

    public ModSpawnEggItem(final RegistryObject<? extends EntityType<?>> entityTypeSupplier, int p_43208_, int p_43209_, Properties p_43210_) {
        super(null, p_43208_, p_43209_, p_43210_);
        this.entityTypeSupplier = Lazy.of(entityTypeSupplier::get);

    public static void initSpawnEggs(){
        final Map<EntityType<?>, SpawnEggItem> EGGS = ObfuscationReflectionHelper.getPrivateValue(SpawnEggItem.class, null, "field_195987_b");
        DefaultDispenseItemBehavior dispenseBehavior = new DefaultDispenseItemBehavior() {

            protected ItemStack execute(BlockSource p_123385_, ItemStack p_123386_) {
                Direction direction = p_123385_ .getBlockState().getValue(DispenserBlock.FACING);
                EntityType<?> type = ((SpawnEggItem) p_123386_.getItem()).getType(p_123386_.getTag());
                type.spawn(p_123385_.getLevel(), p_123386_, null, p_123385_.getPos(),
                        MobSpawnType.DISPENSER, direction != Direction.UP, false);
                    return p_123386_;

        for (final SpawnEggItem spawnEgg : UNADDED_EGGS) {
            EGGS.put(spawnEgg.getType(null ), spawnEgg);
            DispenserBlock.registerBehavior(spawnEgg, dispenseBehavior);

    public EntityType<?> getType(CompoundTag nbt) {
        return this.entityTypeSupplier.get();


Link to comment
Share on other sites

1 hour ago, mahidhoni123 said:

I typed ForgeSpawnEggItem.fromEntityType(EntityType.SKELETON) but now I saw a complimation error - 

Required Registry Object extends<? net.minecraft.entity.EntityType

Provided SpawnEggItem

Luis_ST Can you please show me an example I am trying to create a ForgeSpawnEggItem in my ModSpawnEgg class, but it keeps on saying the same error as shown above 

Link to comment
Share on other sites

Does this work?

    public static final RegistryObject<ForgeSpawnEggItem> SKELETON_SPAWN_EGG = ITEMS.register("skeleton_spawn_egg",
            () -> new ForgeSpawnEggItem(new Supplier<EntityType<? extends Mob>>() {
                public EntityType<? extends Mob> get() {
                    return EntityType.SKELETON;
            }, 0x00FFA8, 0x326D59, new Item.Properties().tab(CreativeModeTab.TAB_MATERIALS)));


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.