Jump to content

So basically when i download the 1.16.5 server it doesnt give me the .json file


__Catt__

Recommended Posts

What .json file were you expecting?

Did you edit the eula.txt to say you accept it? It should have told you to do that when you ran run.bat

Boilerplate:

If you don't post your logs/debug.log we can't help you. For curseforge you need to enable the forge debug.log in its minecraft settings. You should also post your crash report if you have one.

If there is no error in the log file and you don't have a crash report then post the launcher_log.txt from the minecraft folder. Again for curseforge this will be in your curseforge/minecraft/Install

Large files should be posted to a file sharing site like https://gist.github.com  You should also read the support forum sticky post.

Link to comment
Share on other sites

18 hours ago, warjort said:

What .json file were you expecting?

Did you edit the eula.txt to say you accept it? It should have told you to do that when you ran run.bat

well i did and nothing happened, when they run it alot more stuff happens and they get alot more folders like mods, because when i do it i only get logs and eula and also server properties

thats it

Edited by __Catt__
Link to comment
Share on other sites

Just now, Luis_ST said:

is there a logs folder with a debug.log please post it,

if not run the server from the command line and post full output

yes ill do so rn
[06Jul2022 16:37:52.044] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 36.2.34, --fml.mcpVersion, 20210115.111550, --fml.mcVersion, 1.16.5, --fml.forgeGroup, net.minecraftforge, nogui]
[06Jul2022 16:37:52.051] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 8.1.3+8.1.3+main-8.1.x.c94d18ec starting: java version 18.0.1.1 by Oracle Corporation
[06Jul2022 16:37:52.061] [main/DEBUG] [cpw.mods.modlauncher.LaunchServiceHandler/MODLAUNCHER]: Found launch services [minecraft,testharness,fmlclient,fmlserver]

Link to comment
Share on other sites

1 minute ago, __Catt__ said:

uninstalled java 18

you do not need to uninstall java 18, you can just use the full path of the java executable instead of the java keyword in the .bat/.sh file

3 minutes ago, __Catt__ said:

it says no java found, even though in control panel its there

try with the full path, explained above

Link to comment
Share on other sites

1 minute ago, Luis_ST said:

you do not need to uninstall java 18, you can just use the full path of the java executable instead of the java keyword in the .bat/.sh file

try with the full path, explained above

uhhhh i dont understand what you mean by uhh full path

 

Link to comment
Share on other sites

3 minutes ago, diesieben07 said:

Not for installing a server - or you watched very strange tutorials. Even for installing the client, the JSON file is entirely irrelevant to you as the user. You should never touch it or care about it any way shape or form.

i watched that one by the breakdown on the modded server one

Link to comment
Share on other sites

1 hour ago, __Catt__ said:

oh so howd i chang ethat

edit the .bat/.sh file and replace java with full path of java 8

if you not use a .bat/.sh to start the server, here is the example of the .bat file (.sh files are for mac)

Quote

<full path of java> -jar <server file name>.jar
PAUSE

 

Link to comment
Share on other sites

11 minutes ago, Luis_ST said:

edit the .bat/.sh file and replace java with full path of java 8

if you not use a .bat/.sh to start the server, here is the example of the .bat file (.sh files are for mac)

 

ok hopefully this helps

Link to comment
Share on other sites

36 minutes ago, Luis_ST said:

edit the .bat/.sh file and replace java with full path of java 8

if you not use a .bat/.sh to start the server, here is the example of the .bat file (.sh files are for mac)

 

ok so i tried it and it just comes up with my user and then press key to continue

Link to comment
Share on other sites

12 minutes ago, __Catt__ said:

C\Program Files\Java\jre1.8.0_333

this is not the full path, it should be the path to the of the java executable (you find it in the bin folder)

and you need to put the path into quotes

Edited by Luis_ST
Link to comment
Share on other sites

Quote

"C:\Program Files\Java\jre1.8.0_333\bin\java.exe" -jar forgeserver.jar nogui

Try that, if it doesn't work correct it to the java.exe that exists.

Boilerplate:

If you don't post your logs/debug.log we can't help you. For curseforge you need to enable the forge debug.log in its minecraft settings. You should also post your crash report if you have one.

If there is no error in the log file and you don't have a crash report then post the launcher_log.txt from the minecraft folder. Again for curseforge this will be in your curseforge/minecraft/Install

Large files should be posted to a file sharing site like https://gist.github.com  You should also read the support forum sticky post.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.