Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

'Done Loading' error. Forgev4.0.0.206&more MC1.3.1


lakehaze
 Share

Recommended Posts

I've been trying to install Terra Firma Craft for 3 days, which requires Forge. I can't count how many install methods I've tried for Forge. Any time that the forge mod is installed in any configuration, alone or with ModLoader and/or tfcraft, MC freezes at the 'Done Loading' screen.

 

My current goal is to simply start MC running only Forge (and Forge's prerequisites, if any).

 

I am confused about the installation process because there are  many instruction sources and versions. (Even the 'Main Forge Download' thread on this forum links to v3.4.9.171)

I've tried 3.4.9.156, and 171. (Final commit: 1.2.5)

and 4.0.0.200, and 206 (Final commit: unlisted)

I'm still not sure which one is right for me.

Does Forge require ModLoader? It seems that the most recent versions do not.

Will Forge run with 1.3.1 or 1.3.2? I've tried both, but not 1.2.5 (I don't have it. Is it required?).

The thread titled "Forge 4.0.0 Minecraft 1.3.2" seems to imply that Forge v4.0 should be compatible with 1.3.1 or 1.3.2.

Am I mistaken?

 

I've tried installing directly to the .jar file manually using winrar and 7zip.

I've downloaded SKMCLauncher v3.1.5 (exe) (Magic Launcher) and applied the mod through there.

Do I still need the ModLoader.txt file to get support? My understanding was that ModLoader is no longer a prerequisite of Forge.

 

I tried to follow the logfile instructions from here: http://www.minecraftforum.net/topic/1194059-beginners-guide-to-posting-a-crash-log/

but I get the following errors:

 

 

C:\Users\Ta\Desktop>java -Xincgc -Xmx2048M -cp Minecraft.exe net.minecraft.Launc

herFrame

Error occurred during initialization of VM

Could not reserve enough space for object heap

Error: Could not create the Java Virtual Machine.

Error: A fatal exception has occurred. Program will exit.

 

C:\Users\Ta\Desktop>java -Xincgc -Xmx2048M -cp SKMCLauncher.exe net.minecraft.La

uncherFrame

Error occurred during initialization of VM

Could not reserve enough space for object heap

Error: Could not create the Java Virtual Machine.

Error: A fatal exception has occurred. Program will exit.

 

C:\Users\Ta\Desktop>

 

 

 

 

MagicLauncher is the only way I know to acquire a log file:

 

 

SK's Minecraft Launcher, v3.1.5

Parameter: stand-alone=true

Parameter: username=hyungin

Parameter: mppass=hyungin

Parameter: sessionid=5811153863101647134

Base directory: C:\Users\Ta\AppData\Roaming

What Minecraft will use: C:\Users\Ta\AppData\Roaming\.minecraft

Addon: C:\Users\Ta\AppData\Roaming\.minecraft\addons\minecraft.jar\minecraftforge-universal-4.0.0.206.zip

List of classpath entries generated!

Classpath: file:/C:/Users/Ta/AppData/Roaming/.minecraft/addons/minecraft.jar/minecraftforge-universal-4.0.0.206.zip

Classpath: file:/C:/Users/Ta/AppData/Roaming/.minecraft/bin/lwjgl.jar

Classpath: file:/C:/Users/Ta/AppData/Roaming/.minecraft/bin/jinput.jar

Classpath: file:/C:/Users/Ta/AppData/Roaming/.minecraft/bin/lwjgl_util.jar

Classpath: file:/C:/Users/Ta/AppData/Roaming/.minecraft/bin/minecraft.jar

Now launching...

Starting com.sk89q.mclauncher.launch.GameAppletContainer

Starting net.minecraft.client.MinecraftApplet

Initializing Minecraft...

2012-08-18 11:14:09 [iNFO] [ForgeModLoader] Forge Mod Loader version 3.0.84.294 for Minecraft client:1.3.2, server:1.3.2 loading

 

 

 

[EDIT]

After searching the .minecraft folder for 'log', I found 3 files (all seem to have the same content) 'ForgeModLoader-client-[0,1,2].log':

 

 

2012-08-18 09:24:23 [iNFO] [ForgeModLoader] Forge Mod Loader version 3.0.84.294 for Minecraft client:1.3.2, server:1.3.2 loading

2012-08-18 09:24:23 [FINEST] [ForgeModLoader] All core mods are successfully located

2012-08-18 09:24:23 [FINEST] [ForgeModLoader] Discovering coremods

2012-08-18 09:24:23 [FINEST] [ForgeModLoader] Found library file argo-2.25.jar present and correct in lib dir

 

2012-08-18 09:24:23 [FINEST] [ForgeModLoader] Found library file guava-12.0.1.jar present and correct in lib dir

 

2012-08-18 09:24:23 [FINEST] [ForgeModLoader] Found library file asm-all-4.0.jar present and correct in lib dir

 

2012-08-18 09:24:23 [FINEST] [ForgeModLoader] Running coremod plugins

2012-08-18 09:24:23 [FINEST] [ForgeModLoader] Running coremod plugin FMLCorePlugin

2012-08-18 09:24:23 [FINEST] [ForgeModLoader] Coremod plugin FMLCorePlugin run successfully

2012-08-18 09:24:23 [FINEST] [ForgeModLoader] Running coremod plugin FMLForgePlugin

2012-08-18 09:24:23 [FINEST] [ForgeModLoader] Coremod plugin FMLForgePlugin run successfully

2012-08-18 09:24:23 [FINEST] [ForgeModLoader] Validating minecraft

2012-08-18 09:24:23 [FINEST] [ForgeModLoader] Minecraft validated, launching...

 

 

 

What am I doing wrong?

Thanks for you help.

 

[EDIT]

I deleted the meta-inf folder when not using SKMCLauncher.

I've tried installing to 1.3.1 on one machine, and 1.3.2 on another machine.

Link to comment
Share on other sites

3.x is for 1.2.5

Early 4.x builds are for 1.3.1, later builds are for 1.3.2

All you have to do is install it in your jar.

No Forge is not dependent on ModLoader

So make sure you get your versions right, and get a full log.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Patreon: http://www.patreon.com/lexmanos
Paypal: http://paypal.me/LexManos

BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn

Link to comment
Share on other sites

It seems the outdated Forge download link from tfcraft led me astray in the beginning, and MagicLauncher screwed me later.

Using 4.0, and skipping MagicLauncher seems to be working so far. I can get to the main game screen.

 

Thanks.

 

So, Forge is incompatible with SKMCLauncher? Is there a better alternative, or is it recommended to simply do a manual .jar install?

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • Register your own IRecipeSerializer. It is registered like any other registry entry. However note that you should have as much as possible in the JSON. Don't just have a placeholder JSON file and then hardcode all the logic in code. That defeats the point of datapacks. You'll have to have your own repair recipe then (see above for how to make your own serializer) and override getRemainingItems. If the knife is your item, override hasContainerItem and getContainerItem in your Item class. If the knife is not your item, refer to the section about repairing. Use a GlobalLootModifier.
    • So, im kinda new to modding. Trying to make relatively complicated mod(as I see now, it breaks the api a little bit...), and faced into some problems, especially with crafting. I think I should tell a little bit about my mod, you actually can skip this part, but if you don't get something, i strongly suggest to read this part. The goal i'm chasing is to implement similar food mechanics to TFC classic(1.7.10) mechanics. In a nutshell, it's food with durrability, and when you eat, you consume as much as you need(like if you have a steak and 1 hunger, if you eat it, stake's potential wastes, in case of my mod, it shouldn't). That's it, that's already done(with little bugs thou, but done). Now I have to do crafting somehow, using that items and modify durability while crafting. And it doesn't seems to be easy.     And.. question 1 will be: is it possible to hardcode crafts in 1.16.5? I know.. it's kinda not beautifull, but I really hate the json system. I've made as much crafts as possible by using it, but now, when I need to implement some logic, it's such a headache.   2. This question is about repearing. I mean, placing two damaged items in recipe grid. If you add 2 8/10 items, you'll get just one 10/10 item, and nothing more. I'd like 6/10 item to apear in grid after crafting. 3. Also there should be a recipe for extracting seeds with knife(i don't like to loose knife and whole peace of crop after craft). 4. And the last one. Well, I should change drop of crops if it's broken by special tool. I know, it's possible to do it by adding harvest tools, but I can't modify vanilla crops(maybe only by reflection..). Seems like it's reasonable to use onBlockBroken event, or something like that, but I keep finding deprecated code examples in google, and it doesn't work for me. Maybe there is a better solution.   About crafts.. I tried to figure out how CraftSerializers works, and i think it might be a good solution for that crafting stuff. But don't understand how to bind the serializer to regular minecraft crafting. Tried to read ShapelessRecipe class, but don't understand what happens in mathes, so cant do any assumptions how should I modify it. 
    • IP: Play.EpicLandCraft.Com Version: Cualquiera
    • What Im trying to do is to implement a "dash" mechanic on a Shift button.   @SubscribeEvent public static void onEvent(InputEvent.KeyInputEvent event){ KeyBinding runBinding = Minecraft.getInstance().gameSettings.keyBindSprint; int key = event.getKey(); int runKey = runBinding.getKey().getKeyCode(); ClientPlayerEntity player = Minecraft.getInstance().player; if (key == runKey){ //some checks, and then: float yaw = player.rotationYaw; float x = -MathHelper.sin(yaw * 0.017453292F); float z = MathHelper.cos(yaw * 0.017453292F); double groundMotion = 5, airMotion = 2; if (player.isOnGround()) player.setMotion(new Vector3d(x * groundMotion, 0, z * groundMotion)); else player.setMotion(new Vector3d(x * airMotion, 0, z * airMotion)); } } And this code works. The problem is, it causes a lot of lag when the setMotion() is called - my fps drops from 60 to 50-40 and the dash movement looks discrete. I wonder why is it so and how it can be improved...
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.