Jump to content

Help: Howto: Manage different servers with different configs


keybounce

Recommended Posts

I want advice on managing two different servers with two different config files.

 

I have a 1.2.5 server, and a 1.3.2 server. Both have Twilight Forest. But they need different config files, different block ID's, etc.

 

It's easy enough (relatively ...) to enable/disable the different versions for different configs. I can use the 1.2.5 version when talking to one server, and the 1.3.2 version when talking to the other.

 

But I have no idea how to manage the different config files that the different servers need.

 

Suggestions? Ideas?

Jeb! The sheep! The fence pens, they do nothing still leak!

Link to comment
Share on other sites

Alright, I tried renaming the files when I'm not using them.

 

What happens?

 

2012-09-02 20:50:32 [iNFO] [ForgeModLoader] Searching /Volumes/UserData/Users/michael/Library/Application Support/minecraft/mods for mods

2012-09-02 20:50:32 [FINE] [ForgeModLoader] Ignoring unknown file .DS_Store in mods directory

2012-09-02 20:50:32 [FINE] [ForgeModLoader] Found a candidate mod directory MumbleLink

2012-09-02 20:50:32 [FINE] [ForgeModLoader] Found a candidate zip or jar file Ruins-1.3.2.xzip

2012-09-02 20:50:32 [FINE] [ForgeModLoader] Found a candidate mod directory resources

2012-09-02 20:50:32 [FINE] [ForgeModLoader] Found a candidate mod directory sppcommands

2012-09-02 20:50:32 [FINE] [ForgeModLoader] Found a candidate zip or jar file twilightforest-1.11.3.xzip

 

I've tried changing the extension to .Zzip, .xzip, etc.

 

I know that Magic Launcher uses .zipX, but I don't want to use that -- that just means magic launcher will re-enable them fairly often.

 

So, what's a way to leave a mod in place and disable it so that it won't be active? The whole "Everything is active unless you turn it off" is a pain, and I don't see a good working way to say "Only turn things on that you want for this config". (I thought I did, but it has failed me.)

 

So yea, now I'm trying to figure out how to both enable/disable mods in the mods folder, AND adjust which config file is in use when a mod is active.

Jeb! The sheep! The fence pens, they do nothing still leak!

Link to comment
Share on other sites

I want advice on managing two different servers with two different config files.

 

I have a 1.2.5 server, and a 1.3.2 server. Both have Twilight Forest. But they need different config files, different block ID's, etc.

 

But I have no idea how to manage the different config files that the different servers need.

 

Suggestions? Ideas?

 

Maybe I'm missing something, but wouldn't it make sense to have two separate server instances in their own directories?  I do this with my client installation (also keeps me from accidentally corrupting worlds with wrong mods) and it works out great. 

I'm fixing the stupid villagers.  http://www.minecraftforum.net/topic/1588460-

Link to comment
Share on other sites

I want advice on managing two different servers with two different config files.

 

I have a 1.2.5 server, and a 1.3.2 server. Both have Twilight Forest. But they need different config files, different block ID's, etc.

 

But I have no idea how to manage the different config files that the different servers need.

 

Suggestions? Ideas?

 

Maybe I'm missing something, but wouldn't it make sense to have two separate server instances in their own directories?  I do this with my client installation (also keeps me from accidentally corrupting worlds with wrong mods) and it works out great.

That, and with a simple enough batch file, I can choose which server I want to start up. Accommodates CraftBukkit too, since it already requires a bat script to load.

Read the EAQ before posting! OR ELSE!

 

This isn't building better software, its trying to grab a place in the commit list of a highly visible github project.

 

www.forgeessentials.com

 

Don't PM me, I don't check this account unless I have to.

Link to comment
Share on other sites

I want advice on managing two different servers with two different config files.

 

I have a 1.2.5 server, and a 1.3.2 server. Both have Twilight Forest. But they need different config files, different block ID's, etc.

 

But I have no idea how to manage the different config files that the different servers need.

 

Suggestions? Ideas?

 

Maybe I'm missing something, but wouldn't it make sense to have two separate server instances in their own directories?  I do this with my client installation (also keeps me from accidentally corrupting worlds with wrong mods) and it works out great.

 

You are missing something.

 

The servers have different directories, completely separate.

 

But the _CLIENT_ has a single directory, with a single config directory, with a single TwilightForest.cfg file.

 

If I have the 1.3.2 config, the 1.2.5 client crashes when I try to activate the portal, and won't see an already active portal.

If I have the 1.2.5 config, the 1.3.2 client crashes during initialization.

 

Right now I have to manually swap the files each time I switch servers. I'm looking for something better.

 

===

Try setting the system property FML.mod states to a semi colon separated list of modid:true/false, or write the same to config/fmlStates.properties (one mod per line there)

 

Actually, this was for a slightly different issue. I tried using file renames to disable mods that I wasn't using that were in the mod folder, and it did not work.

 

But this holds promise. I can't easily generate a semi-colon seperated list, but I can work with filenames in a text file.

 

Just for exactness: Lets say I've got a file named "mods/ConfigA/Helpful Mod V4-132.zip". Exactly what do I need to write to the config/fmlStates.properties?

 

(Yea, I hate spaces in filenames, but some people give them.)

Jeb! The sheep! The fence pens, they do nothing still leak!

Link to comment
Share on other sites

You are missing something.

 

The servers have different directories, completely separate.

 

But the _CLIENT_ has a single directory, with a single config directory, with a single TwilightForest.cfg file.

 

If I have the 1.3.2 config, the 1.2.5 client crashes when I try to activate the portal, and won't see an already active portal.

If I have the 1.2.5 config, the 1.3.2 client crashes during initialization.

 

Right now I have to manually swap the files each time I switch servers. I'm looking for something better.

 

If you aren't familiar, Magic Launcher will let you configure multiple/different client directories.  Copy your .minecraft directory somewhere else (I use /minecraft/1.3.2/.minecraft, /minecraft/1.2.5/.minecraft, etc).  In Magic Launcher's setup, create a new configuration, and be sure to point the Minecraft.jar and Base Folder to the new location.

I'm fixing the stupid villagers.  http://www.minecraftforum.net/topic/1588460-

Link to comment
Share on other sites

Hmm ... that actually might be the best solution. I actually did try something similar to that back before it was officially supported by Magic Launcher, but the scripting needed to make it work became a bit of a maintenance headache.

 

(Magic Launcher has supported this on windows for a long time, but only recently on macs)

Jeb! The sheep! The fence pens, they do nothing still leak!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • The mobs are moving normally for a second, then freeze, then go back to normal, and this repeats. I describe this as mob lag, bc they stutter as if they were lagging. I don't have the best wifi, but that shouldn't matter since its 10mbps which is enough for a server. I have 8 gigs of ram for it, no optimizations have worked, if there is anything more you may need to help lmk, ill describe. The modlist is pretty hefty: VS_ClockworkSurvivalSupportV1.4 aether-1.20.1-1.2.0-neoforge.jar alexsdelight-1.5.jar alexsmobs-1.22.7.jar appleskin-forge-mc1.20.1-2.5.1.jar backpacked-forge-1.20.1-2.2.5.jar balm-forge-1.20.1-7.2.1.jar bettervillage-forge-1.20.1-3.2.0.jar BiomesOPlenty-1.20.1-18.0.0.598.jar botarium-forge-1.20.1-2.3.2.jar CGM-Unofficial-1.4.11+Forge+1.20.1.jar citadel-2.5.2-1.20.1.jar clockwork-1.20.1-0.1.2-forge-05f5d5fbbb.jar configured-forge-1.20.1-2.2.2.jar connectivity-1.20.1-4.9.jar create-1.20.1-0.5.1.f.jar create-new-age-forge-1.20.1-1.1.2.jar createarmoryv0.6.1n.jar createbigcannons-forge-1.20.1-0.5.3.b.jar createchunkloading-1.6.0-forge.jar createdeco-2.0.1-1.20.1-forge.jar createdieselgenerators-1.20.1-1.2h.jar createendertransmission-2.0.7-1.20.1.jar create_misc_and_things_ 1.20.1_4.0A.jar cristellib-1.1.5-forge.jar cupboard-1.20.1-2.3.jar curios-forge-5.7.0+1.20.1.jar destroy-1.20.1-0.8.jar Dungeon Crawl-1.20.1-2.3.14.jar FallingTree-1.20.1-4.3.4.jar FarmersDelight-1.20.1-1.2.4.jar framework-forge-1.20.1-0.6.26.jar geckolib-forge-1.20.1-4.4.2.jar InsaneLib-1.12.1-mc1.20.1.jar Jade-1.20.1-forge-11.8.0.jar jei-1.20.1-forge-15.3.0.4.jar journeymap-1.20.1-5.9.18-forge.jar JustEnoughResources-1.20.1-1.4.0.247.jar kotlinforforge-4.10.0-all.jar l2library-2.4.23.jar libraryferret-forge-1.20.1-4.0.0.jar macawsbridgesbop-1.20-1.1.jar mcw-bridges-2.1.0-mc1.20.4forge.jar moonlight-1.20-2.9.17-forge.jar morevillagers-forge-1.20.1-5.0.0.jar Mo_ZombiesWave-1.20.1-0.1.0-forge.jar NaturesCompass-1.20.1-1.11.2-forge.jar Placebo-1.20.1-8.6.1.jar refinedstorage-1.12.4.jar soundphysics-forge-1.20.1-1.1.2.jar spark-1.10.53-forge.jar stealing_villagers-forge-1.20.1-1.0.0.jar s_a_b-1.3.0_1.20.1.jar takesapillage-1.0.3-1.20.1.jar TerraBlender-forge-1.20.1-3.0.1.4.jar tombstone-1.20.1-8.6.2.jar Towns-and-Towers-1.12-Fabric+Forge.jar twilightforest-1.20.1-4.3.2145-universal.jar valkyrienskies-120-2.1.3-beta.1.jar veinmining-forge-1.3.0+1.20.1.jar waystones-forge-1.20-14.1.3.jar YungsApi-1.20-Forge-4.0.3.jar YungsBetterDesertTemples-1.20-Forge-3.0.3.jar YungsBetterDungeons-1.20-Forge-4.0.3.jar YungsBetterEndIsland-1.20-Forge-2.0.5.jar YungsBetterJungleTemples-1.20-Forge-2.0.4.jar YungsBetterMineshafts-1.20-Forge-4.0.4.jar YungsBetterNetherFortresses-1.20-Forge-2.0.5.jar YungsBetterOceanMonuments-1.20-Forge-3.0.4.jar YungsBetterStrongholds-1.20-Forge-4.0.3.jar YungsBetterWitchHuts-1.20-Forge-3.0.3.jar YungsBridges-1.20-Forge-4.0.3.jar zaynens_leather_from_rotten_flesh_mod_1.20.1.jar
    • Thank you so much! Unfortunately before reading this I reinstalled my java installer. Now when I try to open the forge installer I receive an error message stating 'Unable to install Java' even though I have definitely downloaded and installed the latest version. Any idea what this could be or how I could fix it?  
    • IT WORKED! THANK YOU!
    • sorry for the stuborn ness ss   test code logs and planks return nothing on minable but i can use the other tags  name minecraft:oak_log BlockTags.LOGS name minecraft:oak_planks BlockTags.PLANKS   it kinda works but its not like like perfect             
    • I'm making a custom modpack for 1.20.1 and everything else seems to work except this Passive skilltree mod. The world loads fine but when I press the keybind to open the mod's GUI, the world immediately saves and crashes with this report: https://pastebin.com/svEPsRty Any help or insight towards the right direction is greatly appreciated!
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.