Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Forge and ID conflicts


PROdotes
 Share

Recommended Posts

So just wondering... hard to search for "id conflict" and get a good results on the forum so I'll do it t his way :)

Is there a way to auto resolve ID conflicts in forge... or a plan to add one...

Just spent about 30 minutes trying to get 1.3.2 mods to run and resolving ID conflicts 1 by 1...

If there is a way, it would still be up to the mod dev to implement it... but it would be nice if mods would check for an existing config file and if it's not there to just go "hey forge... i need these X IDs, are they free?" and forge going "well number 3,6 and 8 are taken, but i can give you these instead"...

 

or, "worst case"... forge generating a list of all ID conflicts before MC crashes and telling you "hey, you need to replace these IDs... here's a few free IDs that might help"

 

something along those lines...

 

just look at the mc forums... there's about 70% of people asking "hey, I get this error" and then they copy/paste an ID conflict... it would prolly help out devs a lot if they don't get spammed with stuff like that... and make installing mods a lot easier...

 

sure, there's more important stuff to add/solve... but depending how/when the id conflicts are loaded in the source, this shouldn't be too hard to do :)

Link to comment
Share on other sites

maybe there should be a general id directory with one config file fir ids pprovided by forge that would every forge mod use and write their block and item ids in it or something like that

"not to scare azanor more , but he's a programmer, which is like the child of an orgy between math, logic, writing, and black magic . without any one of those it just doesn't work" etopsirhc

Link to comment
Share on other sites

You want a mod called IDResolver.  The pre-release for 1.3.2 is buried in the minecraftforum thread.  NotEnoughItems can generate a user/free ID list if you want to do it manually (or for a server, IDResolver is clientl-only).

 

yea but that's more busywork... i can take a week off work and code my own forge ID resolver... you shouldn't need 2 mods to do something like this... it should be something that a "framework" fixes itself... i can also go to the technic modpack and just use their excel table and edit stuff... or make my own excel table before running all the mods... or check the "shared id" table that i remember seeing on the forum here somewhere...

but the point is to make it easy for the players and modders to solve stuff like this... that was a modder can simply say "hey, i need 10 block and 5 item IDs" and forge returns a table with the IDs that are free... mod writes it's config... problem solved...

and if a mod is not using the auto-id function or for some reason there's an id conflict... forge detects the error and handles it like IDResolver does... "here's a list of stuff you need to fix, want me to do it?"

 

if I'm not mistaken, RP2 has the function built in it already, doesn't it? I think i remember a config setting saying resolve ID conflicts or something...

 

so... since it's not something that's built in it seems... is it on any todo list at all or if the official info "there's already a mod that does that?" :)

again... not really a hard thing to code... and it would reduce the number of people asking "hey, I get this error" by... a lot I guess...

only question is... how many new bugs would it bring :)

Link to comment
Share on other sites

yea... but it will still happen... mostly due to "minor" mods picking in the lower 1000s... or around 4000 to be "safe"... mod devs can't know all the other mods and what they pick... i've even had some of the big mods report conflicts from time to time... dunno if it was pre 1.3.2 tho...

 

personally i like having a lot of different blocks to make my houses and world look pretty :)

hm... i think portal and forestry have conflicts? :)

Link to comment
Share on other sites

I highly doubt that MC will get into a state that would make 100% automatic ID management to be feasible.

However, specifically when it comes to mods grabbing ids on first install, Forge already has the tools to make everything that uses forge to work together IF the modder decides to use it.

The 'auto id picker' from RP is actually just the getBlock function in Forge Config.

 

So, ID Resolver style hack and smash, probably not gunna happen without Vanilla MC introducing some things that need to be done.

But if modders take 10 seconds to call a function they can get a free ID without issue. So if you have conflicts, go yell at the modders.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Patreon: http://www.patreon.com/lexmanos
Paypal: http://paypal.me/LexManos

BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • Yeah that's the correct Forum Experience (a lot since he join 2012) and knowledge from other threads with similar problems
    • I had tried using ContainerData before but I didn't notice addDataSlots in AbstractFurnaceMenu. After adding it to the constructor it worked. Thank you.
    • I'm assuming its in the wrong class because of this line ? Which would make it Client side ? @Mod.EventBusSubscriber(modid = MyMod.MODID, bus = Bus.MOD, value = Dist.CLIENT) Would removing this and setting up the MyMod.java like this be correct? I ask because I see other examples use the public static final RegistryObject<> in the same class that they setup the public static final DeferredRegister<>, and not for just particles. public MyMod() { // Register the setup method for modloading IEventBus bus = FMLJavaModLoadingContext.get().getModEventBus(); ParticleRegistration.PARTICLES_TYPES.register(bus); } Or do I need to make further changes to the registration then? Such as moving the registerParticleFactory() to a ClientStartup/ClientProxy ?
    • For this branch, after I wrote the latest commit, it caused the loading percent to be stuck at 0% whenever I create a new world.  This is the latest log:  [19Jan2022 19:38:32.502] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmluserdevclient, --fml.mcpVersion, 20210115.111550, --fml.mcVersion, 1.16.5, --fml.forgeGroup, net.minecraftforge, --fml.forgeVersion, 36.2.20, --assetIndex, 1.16, --assetsDir, C:\Users\david\.gradle\caches\forge_gradle\assets, --version, MOD_DEV, --username, Dev, --accessToken, ❄❄❄❄❄❄❄❄, --userProperties, {}] [19Jan2022 19:38:32.509] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 8.0.9+86+master.3cf110c starting: java version 16.0.2 by Oracle Corporation [19Jan2022 19:38:33.121] [main/INFO] [net.minecraftforge.fml.loading.FixSSL/CORE]: Added Lets Encrypt root certificates as additional trust [19Jan2022 19:38:33.248] [main/INFO] [mixin/]: SpongePowered MIXIN Subsystem Version=0.8.4 Source=file:/C:/Users/david/.gradle/caches/modules-2/files-2.1/org.spongepowered/mixin/0.8.4/4ec7d77d9ab32596ca0b78bb123956734767e3a/mixin-0.8.4.jar Service=ModLauncher Env=CLIENT [19Jan2022 19:38:38.129] [main/INFO] [cpw.mods.modlauncher.LaunchServiceHandler/MODLAUNCHER]: Launching target 'fmluserdevclient' with arguments [--version, MOD_DEV, --gameDir, ., --assetsDir, C:\Users\david\.gradle\caches\forge_gradle\assets, --assetIndex, 1.16, --username, Dev, --accessToken, ❄❄❄❄❄❄❄❄, --userProperties, {}] [19Jan2022 19:38:56.600] [Render thread/INFO] [com.mojang.authlib.yggdrasil.YggdrasilAuthenticationService/]: Environment: authHost='https://authserver.mojang.com', accountsHost='https://api.mojang.com', sessionHost='https://sessionserver.mojang.com', servicesHost='https://api.minecraftservices.com', name='PROD' [19Jan2022 19:38:57.885] [Render thread/ERROR] [net.minecraft.client.Minecraft/]: Failed to verify authentication com.mojang.authlib.exceptions.AuthenticationUnavailableException: null at com.mojang.authlib.yggdrasil.YggdrasilSocialInteractionsService.checkPrivileges(YggdrasilSocialInteractionsService.java:97) ~[authlib-2.1.28.jar:?] at com.mojang.authlib.yggdrasil.YggdrasilSocialInteractionsService.<init>(YggdrasilSocialInteractionsService.java:40) ~[authlib-2.1.28.jar:?] at com.mojang.authlib.yggdrasil.YggdrasilAuthenticationService.createSocialInteractionsService(YggdrasilAuthenticationService.java:152) ~[authlib-2.1.28.jar:?] at net.minecraft.client.Minecraft.createSocialInteractions(Minecraft.java:551) ~[forge-1.16.5-36.2.20_mapped_official_1.16.5.jar:?] at net.minecraft.client.Minecraft.<init>(Minecraft.java:383) ~[forge-1.16.5-36.2.20_mapped_official_1.16.5.jar:?] at net.minecraft.client.main.Main.main(Main.java:149) ~[forge-1.16.5-36.2.20_mapped_official_1.16.5.jar:?] at jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:?] at jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:78) ~[?:?] at jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:?] at java.lang.reflect.Method.invoke(Method.java:567) ~[?:?] at net.minecraftforge.userdev.FMLUserdevClientLaunchProvider.lambda$launchService$0(FMLUserdevClientLaunchProvider.java:52) ~[forge-1.16.5-36.2.20_mapped_official_1.16.5.jar:?] at cpw.mods.modlauncher.LaunchServiceHandlerDecorator.launch(LaunchServiceHandlerDecorator.java:37) [modlauncher-8.0.9.jar:?] at cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:54) [modlauncher-8.0.9.jar:?] at cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:72) [modlauncher-8.0.9.jar:?] at cpw.mods.modlauncher.Launcher.run(Launcher.java:82) [modlauncher-8.0.9.jar:?] at cpw.mods.modlauncher.Launcher.main(Launcher.java:66) [modlauncher-8.0.9.jar:?] at net.minecraftforge.userdev.LaunchTesting.main(LaunchTesting.java:108) [forge-1.16.5-36.2.20_mapped_official_1.16.5.jar:?] [19Jan2022 19:38:57.903] [Render thread/INFO] [net.minecraft.client.Minecraft/]: Setting user: Dev [19Jan2022 19:38:58.300] [Render thread/INFO] [net.minecraft.client.Minecraft/]: Backend library: LWJGL version 3.2.2 build 10 [19Jan2022 19:39:00.295] [modloading-worker-2/INFO] [net.minecraftforge.common.ForgeMod/FORGEMOD]: Forge mod loading, version 36.2.20, for MC 1.16.5 with MCP 20210115.111550 [19Jan2022 19:39:00.302] [modloading-worker-2/INFO] [net.minecraftforge.common.MinecraftForge/FORGE]: MinecraftForge v36.2.20 Initialized [19Jan2022 19:39:05.738] [Render thread/INFO] [com.mojang.text2speech.NarratorWindows/]: Narrator library for x64 successfully loaded [19Jan2022 19:39:05.961] [Render thread/INFO] [net.minecraft.resources.SimpleReloadableResourceManager/]: Reloading ResourceManager: Default, Mod Resources [19Jan2022 19:39:06.499] [Forge Version Check/INFO] [net.minecraftforge.fml.VersionChecker/]: [forge] Starting version check at https://files.minecraftforge.net/net/minecraftforge/forge/promotions_slim.json [19Jan2022 19:39:07.319] [Forge Version Check/INFO] [net.minecraftforge.fml.VersionChecker/]: [forge] Found status: UP_TO_DATE Current: 36.2.20 Target: null [19Jan2022 19:39:23.497] [Worker-Main-11/WARN] [net.minecraft.client.renderer.model.ModelBakery/]: Unable to load model: 'multiverse:dimension_slasher#inventory' referenced from: multiverse:dimension_slasher#inventory: java.io.FileNotFoundException: multiverse:models/item/dimension_slasher.json [19Jan2022 19:39:29.402] [Render thread/INFO] [net.minecraft.client.audio.SoundSystem/]: OpenAL initialized. [19Jan2022 19:39:29.403] [Render thread/INFO] [net.minecraft.client.audio.SoundEngine/SOUNDS]: Sound engine started [19Jan2022 19:39:30.198] [Render thread/INFO] [net.minecraft.client.renderer.texture.AtlasTexture/]: Created: 1024x512x4 minecraft:textures/atlas/blocks.png-atlas [19Jan2022 19:39:30.419] [Render thread/INFO] [net.minecraft.client.renderer.texture.AtlasTexture/]: Created: 256x128x4 minecraft:textures/atlas/signs.png-atlas [19Jan2022 19:39:30.421] [Render thread/INFO] [net.minecraft.client.renderer.texture.AtlasTexture/]: Created: 512x512x4 minecraft:textures/atlas/banner_patterns.png-atlas [19Jan2022 19:39:30.431] [Render thread/INFO] [net.minecraft.client.renderer.texture.AtlasTexture/]: Created: 512x512x4 minecraft:textures/atlas/shield_patterns.png-atlas [19Jan2022 19:39:30.443] [Render thread/INFO] [net.minecraft.client.renderer.texture.AtlasTexture/]: Created: 256x256x4 minecraft:textures/atlas/chest.png-atlas [19Jan2022 19:39:30.446] [Render thread/INFO] [net.minecraft.client.renderer.texture.AtlasTexture/]: Created: 512x256x4 minecraft:textures/atlas/beds.png-atlas [19Jan2022 19:39:30.451] [Render thread/INFO] [net.minecraft.client.renderer.texture.AtlasTexture/]: Created: 512x256x4 minecraft:textures/atlas/shulker_boxes.png-atlas [19Jan2022 19:39:32.221] [Render thread/INFO] [net.minecraft.client.renderer.texture.AtlasTexture/]: Created: 256x256x0 minecraft:textures/atlas/particles.png-atlas [19Jan2022 19:39:32.274] [Render thread/INFO] [net.minecraft.client.renderer.texture.AtlasTexture/]: Created: 256x256x0 minecraft:textures/atlas/paintings.png-atlas [19Jan2022 19:39:32.279] [Render thread/INFO] [net.minecraft.client.renderer.texture.AtlasTexture/]: Created: 128x128x0 minecraft:textures/atlas/mob_effects.png-atlas [19Jan2022 19:39:33.070] [Realms Notification Availability checker #1/INFO] [com.mojang.realmsclient.client.RealmsClient/]: Could not authorize you against Realms server: Invalid session id [19Jan2022 19:54:25.061] [Render thread/INFO] [net.minecraft.world.storage.SaveFormat/]: Attempt 1... [19Jan2022 19:54:28.360] [Render thread/WARN] [net.minecraft.command.Commands/]: Ambiguity between arguments [teleport, destination] and [teleport, targets] with inputs: [Player, 0123, @e, dd12be42-52a9-4a91-a8a1-11c01849e498] [19Jan2022 19:54:28.361] [Render thread/WARN] [net.minecraft.command.Commands/]: Ambiguity between arguments [teleport, location] and [teleport, destination] with inputs: [0.1 -0.5 .9, 0 0 0] [19Jan2022 19:54:28.362] [Render thread/WARN] [net.minecraft.command.Commands/]: Ambiguity between arguments [teleport, location] and [teleport, targets] with inputs: [0.1 -0.5 .9, 0 0 0] [19Jan2022 19:54:28.363] [Render thread/WARN] [net.minecraft.command.Commands/]: Ambiguity between arguments [teleport, targets] and [teleport, destination] with inputs: [Player, 0123, dd12be42-52a9-4a91-a8a1-11c01849e498] [19Jan2022 19:54:28.364] [Render thread/WARN] [net.minecraft.command.Commands/]: Ambiguity between arguments [teleport, targets, location] and [teleport, targets, destination] with inputs: [0.1 -0.5 .9, 0 0 0] [19Jan2022 19:54:28.370] [Render thread/INFO] [net.minecraft.resources.SimpleReloadableResourceManager/]: Reloading ResourceManager: Default, main, forge-1.16.5-36.2.20_mapped_official_1.16.5.jar [19Jan2022 19:54:29.923] [Render thread/INFO] [net.minecraft.item.crafting.RecipeManager/]: Loaded 7 recipes [19Jan2022 19:54:30.966] [Render thread/INFO] [net.minecraft.advancements.AdvancementList/]: Loaded 927 advancements [19Jan2022 19:54:31.653] [Render thread/INFO] [com.mojang.authlib.yggdrasil.YggdrasilAuthenticationService/]: Environment: authHost='https://authserver.mojang.com', accountsHost='https://api.mojang.com', sessionHost='https://sessionserver.mojang.com', servicesHost='https://api.minecraftservices.com', name='PROD' [19Jan2022 19:54:31.725] [Server thread/INFO] [net.minecraft.server.integrated.IntegratedServer/]: Starting integrated minecraft server version 1.16.5 [19Jan2022 19:54:31.726] [Server thread/INFO] [net.minecraft.server.MinecraftServer/]: Generating keypair [19Jan2022 19:54:31.809] [Server thread/WARN] [net.minecraftforge.common.ForgeConfigSpec/CORE]: Configuration file .\saves\New World\serverconfig\multiverse-server.toml is not correct. Correcting [19Jan2022 19:54:31.812] [Server thread/WARN] [net.minecraftforge.common.ForgeConfigSpec/CORE]: Incorrect key Server config for Multiverse mod was corrected from null to its default, SimpleCommentedConfig:{}. [19Jan2022 19:54:31.813] [Server thread/WARN] [net.minecraftforge.common.ForgeConfigSpec/CORE]: Incorrect key Server config for Multiverse mod.maxDimensions was corrected from null to its default, 25. [19Jan2022 19:54:31.814] [Server thread/WARN] [net.minecraftforge.common.ForgeConfigSpec/CORE]: Incorrect key Server config for Multiverse mod.biomeTypeChance was corrected from null to its default, 0.1. [19Jan2022 19:54:31.815] [Server thread/WARN] [net.minecraftforge.common.ForgeConfigSpec/CORE]: Incorrect key Server config for Multiverse mod.fixedTimeChance was corrected from null to its default, 0.25. [19Jan2022 19:54:31.816] [Server thread/WARN] [net.minecraftforge.common.ForgeConfigSpec/CORE]: Incorrect key Server config for Multiverse mod.inverse was corrected from null to its default, false. [19Jan2022 19:54:31.816] [Server thread/WARN] [net.minecraftforge.common.ForgeConfigSpec/CORE]: Incorrect key Server config for Multiverse mod.riftChance was corrected from null to its default, 20. [19Jan2022 19:54:31.822] [Server thread/WARN] [net.minecraftforge.common.ForgeConfigSpec/CORE]: Configuration file .\saves\New World\serverconfig\forge-server.toml is not correct. Correcting [19Jan2022 19:54:31.823] [Server thread/WARN] [net.minecraftforge.common.ForgeConfigSpec/CORE]: Incorrect key server was corrected from null to its default, SimpleCommentedConfig:{}. [19Jan2022 19:54:31.823] [Server thread/WARN] [net.minecraftforge.common.ForgeConfigSpec/CORE]: Incorrect key server.removeErroringEntities was corrected from null to its default, false. [19Jan2022 19:54:31.823] [Server thread/WARN] [net.minecraftforge.common.ForgeConfigSpec/CORE]: Incorrect key server.removeErroringTileEntities was corrected from null to its default, false. [19Jan2022 19:54:31.824] [Server thread/WARN] [net.minecraftforge.common.ForgeConfigSpec/CORE]: Incorrect key server.fullBoundingBoxLadders was corrected from null to its default, false. [19Jan2022 19:54:31.824] [Server thread/WARN] [net.minecraftforge.common.ForgeConfigSpec/CORE]: Incorrect key server.zombieBaseSummonChance was corrected from null to its default, 0.1. [19Jan2022 19:54:31.825] [Server thread/WARN] [net.minecraftforge.common.ForgeConfigSpec/CORE]: Incorrect key server.zombieBabyChance was corrected from null to its default, 0.05. [19Jan2022 19:54:31.825] [Server thread/WARN] [net.minecraftforge.common.ForgeConfigSpec/CORE]: Incorrect key server.logCascadingWorldGeneration was corrected from null to its default, true. [19Jan2022 19:54:31.826] [Server thread/WARN] [net.minecraftforge.common.ForgeConfigSpec/CORE]: Incorrect key server.fixVanillaCascading was corrected from null to its default, false. [19Jan2022 19:54:31.828] [Server thread/WARN] [net.minecraftforge.common.ForgeConfigSpec/CORE]: Incorrect key server.dimensionUnloadQueueDelay was corrected from null to its default, 0. [19Jan2022 19:54:31.829] [Server thread/WARN] [net.minecraftforge.common.ForgeConfigSpec/CORE]: Incorrect key server.treatEmptyTagsAsAir was corrected from null to its default, false. [19Jan2022 19:54:31.830] [Server thread/WARN] [net.minecraftforge.common.ForgeConfigSpec/CORE]: Incorrect key server.fixAdvancementLoading was corrected from null to its default, true. [19Jan2022 19:54:35.808] [Server thread/INFO] [net.minecraft.server.MinecraftServer/]: Preparing start region for dimension minecraft:overworld [19Jan2022 19:54:36.159] [Render thread/INFO] [net.minecraft.world.chunk.listener.LoggingChunkStatusListener/]: Preparing spawn area: 0% [19Jan2022 19:54:36.359] [Render thread/INFO] [net.minecraft.world.chunk.listener.LoggingChunkStatusListener/]: Preparing spawn area: 0% [19Jan2022 19:54:36.858] [Render thread/INFO] [net.minecraft.world.chunk.listener.LoggingChunkStatusListener/]: Preparing spawn area: 0% [19Jan2022 19:54:37.341] [Render thread/INFO] [net.minecraft.world.chunk.listener.LoggingChunkStatusListener/]: Preparing spawn area: 0% I'm really confused as to what I changed to cause this. The versions before did not have this issue, but it appeared after the latest commit. 
    • thank you it worked, but 2 things, tell me where i have tu pubish my posts, i publish them in modder support isnt that right?   and Diesieben how do you quickly find how to solve modding errors, i can do it but if i create my own program or something but im minecraft modding, what goes through your mind to solve those problems? for example i still cant solve my problem with drawing correctly a glowing line even if i look the minecraft classes  
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.