Jump to content

Forge server with pixelmon problem


Recommended Posts

hello everybody


I'm trying to install pixelmon to my server, but it isn't working out so well. You need Forge for it too, but i don't think that's working as well :S


What I've done:


- I've made a new folder for my server

- I've downloaded the server jar from minecraft.net and placed it into the folder

- I've downloaded minecraft forge (latest version) and placed it in the folder too

- I've changed the extension of the forge-zip to a jar file

- I've ran the 'new' jar file so files like 'coremods' and 'ForgeModloader-server-0.log.lck' popped up

- Then I have downloaded pixelmon and placed the 'mods' and 'database' folders in the folder as well

- But then, if I run the server jar and my server goes online, nothing special happens, it looks like a normal server and when i join it, I can't choose a starter like in singleplayer and I can't find any mobs around the map


Offcourse my server is portforwarded and I added the correct server-ip too in the properties-file. I also have forge and pixelmon installed on my minecraft through magiclauncher. It gives one error with forge, but it works perfectly on my singleplayer.


Can anyone please help me? :3


Sorry for the bad english 

Link to comment
Share on other sites

You didn't install Pixelmon correctly. Re-read the forum post.

There's an EAQ for a reason. Read it!

"Note that failure to read this will make you look idiotic. You don't want that do you?" -- luacs1998


First rule of bug reports: More information is always better.

Oh, and logs OR IT DIDN'T HAPPEN!!

Link to comment
Share on other sites


Install Forge (as per forges instructions) in the minecraft.jar

-> Extract Pixelmon1.9.zip into .minecraft folder



*Note: If upgrading from previous version of pixelmon, please delete the pixelmon.cfg in your .minecraft/config folder. If you do not, none of the new Pokemon will spawn!



Install Forge (as per instructed) in the minecraft_server.jar

-> Extract Pixelmon1.9.zip into server folder



*Note: If upgrading from previous version of pixelmon, please delete the pixelmon.cfg in your .minecraft/config folder. If you do not, none of the new Pokemon will spawn!"


That's from the pixelmon topic on minecraft forum.


I did place all the files from the Pixelmon1.9.zip(mod-folder and database-folder) in the server folder... Or did I do somehing else wrong?

Link to comment
Share on other sites

When you ran forge you generated the world. You probably want to delete that world and try again..


Nope, I tried that too. I didn't work either.


So, to summarise:


- First I made a folder named "PixelmonServer"

- Then I copied the Minecraft_Server-jar that I downloaded from http://minecraft.net/download to my "pixelmonServer"-folder

- Then I copied the Forge-zip that I downloaded from http://adf.ly/673885/http://files.minecraftforge.net/minecraftforge-universal-latest.zip to the folder

- Then I changed the extension of that zip to .jar and I ran it

- This generated the files "coremod", "lib", "ForgeModLoader-server-0.log" and "ForgeModLoader-server-0.log.lck"

- Then I extracted the files from the pixelmonzip (from http://adf.ly/GQMV7) to my "PixelmonServer"-folder

- Then I ran the Minecraft_Server-jar and after it was done I used the command /stop

- Then all the essential files were generated and I added my Ip in the "properties"-file

- Then I ran the Minecraft_Server-jar again and nothing special happened (besides the fact that the server went online ofcourse..)

  When I enter the server, I encounter normal mobs, I can't find Pokémon in my map and the game doesn't ask me to choose a starterpokémon

I have Forge and pixelmon installed through my magiclauncher and on singleplayer it works fine


Here are links to the installation guides:




And here are some screenshots:





Again, sorry for the bad english, I hope you understand what I'm trying to say :)

Link to comment
Share on other sites

Don't run minecraft_server.jar, run the forge-zip renamed to  a jar.


But that would just generate 2 more files (ForgeModLoader-Server-0.log.1 and ForgeModeloader-server-0.log1.lck) and nothing else. Only If I run the Minecraft_server.jar, it launches my server.

Link to comment
Share on other sites

Post the contents of ForgeModLoader-server-0.log.

There's an EAQ for a reason. Read it!

"Note that failure to read this will make you look idiotic. You don't want that do you?" -- luacs1998


First rule of bug reports: More information is always better.

Oh, and logs OR IT DIDN'T HAPPEN!!

Link to comment
Share on other sites

You posted an IMAGE of it, which isn't really helpful. In this case I can tell you what you did wrong: You didn't read the freaking error, it says all you need to know:

This Version of FML is build for Minecraft 1.4.7, we have detected Minecraft 1.4.6

and then, even in CAPITALS:


How hard is it to understand that?


Owww, I didn't knew there was a minecraft 1.4.7 :P And before you said something about the log, I didn't knew there was "human" text in it. Sorry! But thanks a lot then! Really!

Lets go search for 1.4.7 then... :D


Wait, there is no 1.4.7 -.- then I will go search for 1.4.6 Forge ModLoader :D

Again, thanks a lot!

Link to comment
Share on other sites

The version of Minecraft that forge is built for is in the file name -.-

And yes there is a 1.4.7, its in the pre-release stage, hence why it's not bumped to the recomended version yet.

If you're running a server use the RECOMENDED version of forge, not the latest.


Anyways, running the forge zip DOES start your server, it just doesn't popup the window like double clicking the minecraft_server.jar

If you run the forge zip from the command line you'll notice that it actually prints out all that info thats in the log.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Consider supporting the team on Patreon

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • I had a similar issue to what you do above. Given this is an old post, you've probably sorted this now In my case, I had Java (JDK) 22 installed. After uninstalling that and installing 17.0.11 (having both installed gives the same error), then running the startserver.bat worked for me. I managed to get to the EULA section and then start my server correctly- I hope it helps anyone else who may have this issue!
    • Make a test with another Launcher like MultiMC, AT Launcher or Technic Launcher
    • I opened up Minecraft today for the first time in a month and whenever I try and play forge I get an error 1 message. I restarted my computer, tried reinstalling both Minecraft and Forge and have updated all of my drivers. Nothing seems to work so I'm stumped. I have absolutely no mods installed ATM so I have no idea what could be causing the problem. I hope yall are able to help.   DebugLog:   [19May2024 20:33:51.600] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [--username, dmoy18, --version, 1.20.1-forge-47.2.0, --gameDir, C:\Users\dmoyf\AppData\Roaming\.minecraft, --assetsDir, C:\Users\dmoyf\AppData\Roaming\.minecraft\assets, --assetIndex, 5, --uuid, c083972cd92d4dd2894beb25b82ebe82, --accessToken, ????????, --clientId, MDljMzIwMjYtOTJiNS00YWUxLTk1M2EtN2ExMGExZWM0MDAw, --xuid, 2535417310772497, --userType, msa, --versionType, release, --quickPlayPath, C:\Users\dmoyf\AppData\Roaming\.minecraft\quickPlay\java\1716168829421.json, --launchTarget, forgeclient, --fml.forgeVersion, 47.2.0, --fml.mcVersion, 1.20.1, --fml.forgeGroup, net.minecraftforge, --fml.mcpVersion, 20230612.114412] [19May2024 20:33:51.604] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 10.0.9+10.0.9+main.dcd20f30 starting: java version 17.0.8 by Microsoft; OS Windows 11 arch amd64 version 10.0 [19May2024 20:33:51.634] [main/DEBUG] [cpw.mods.modlauncher.LaunchServiceHandler/MODLAUNCHER]: Found launch services [fmlclientdev,forgeclient,minecraft,forgegametestserverdev,fmlserveruserdev,fmlclient,fmldatauserdev,forgeserverdev,forgeserveruserdev,forgeclientdev,forgeclientuserdev,forgeserver,forgedatadev,fmlserver,fmlclientuserdev,fmlserverdev,forgedatauserdev,testharness,forgegametestserveruserdev] [19May2024 20:33:51.653] [main/DEBUG] [cpw.mods.modlauncher.NameMappingServiceHandler/MODLAUNCHER]: Found naming services : [srgtomcp] [19May2024 20:33:51.668] [main/DEBUG] [cpw.mods.modlauncher.LaunchPluginHandler/MODLAUNCHER]: Found launch plugins: [mixin,eventbus,slf4jfixer,object_holder_definalize,runtime_enum_extender,capability_token_subclass,accesstransformer,runtimedistcleaner] [19May2024 20:33:51.681] [main/DEBUG] [cpw.mods.modlauncher.TransformationServicesHandler/MODLAUNCHER]: Discovering transformation services [19May2024 20:33:51.688] [main/DEBUG] [net.minecraftforge.fml.loading.FMLPaths/CORE]: Path GAMEDIR is C:\Users\dmoyf\AppData\Roaming\.minecraft [19May2024 20:33:51.689] [main/DEBUG] [net.minecraftforge.fml.loading.FMLPaths/CORE]: Path MODSDIR is C:\Users\dmoyf\AppData\Roaming\.minecraft\mods [19May2024 20:33:51.689] [main/DEBUG] [net.minecraftforge.fml.loading.FMLPaths/CORE]: Path CONFIGDIR is C:\Users\dmoyf\AppData\Roaming\.minecraft\config [19May2024 20:33:51.689] [main/DEBUG] [net.minecraftforge.fml.loading.FMLPaths/CORE]: Path FMLCONFIG is C:\Users\dmoyf\AppData\Roaming\.minecraft\config\fml.toml
  • Topics

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.