Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Forge Installer Not Opening


kyle123cool123
 Share

Recommended Posts

Hi everyone! So I've been trying to get forge running on my machine for about 2 days now to no avail. My issue is that I can't get the installer to run no matter what I try, and unfortunately because I can't install it in the first place I don't think I can provide you guys any logs. I download the installer file and then upon double clicking it I get a black window for a fraction of a second and then a Java window pops up that says, "Java(TM) Platform SE binary has stopped working" and it forces me to close the installer. I'm on Windows 10. I've tried reinstalling Java a dozen or so times and once I even went into my files and searched for anything with the word "Java" in it and deleted it, but that didn't seem to help me. I have a feeling this is a Windows 10 specific issue because I was able to install forge on a windows 7 computer in my house but when I tried simply transferring the files over onto this one the forge Minecraft profile wouldn't launch. Whether I use the "windows installer" or the "installer" has no effect either. I've tried changing file extensions to .jar but that also had no effect. Minecraft on its own runs fine so it's not like my computer somehow can't run Java... If anyone has some advice to give me it would be much appreciated because I feel like I'm losing my mind here trying to get mods working. All of my Nvidia drivers are up to date 100%.

 

What I've tried:

-Uninstalling Java completely + reinstalling it

-Uninstalling/reinstalling JRE (Java Runtime Environment) separately from the regular Java program

-Moving the files from another computer

-A program called "Jarfix" that has supposedly helped many other people with this issue

-Changing file extensions

 

Thanks for your time guys.

Edited by kyle123cool123
Link to comment
Share on other sites

Download the Windows Installer, not the plain Installer. And also don't just open the Java file by clicking it twice, open the Command Prompt and go to the file directory, then run the Java file through there.

 

In the Command Prompt, type:
java -[YOUR JAVA FILE NAME].jar [optional modifiers here]

Edited by Differentiation
Link to comment
Share on other sites

Just now, kyle123cool123 said:

It said, "Setting up logger: C:\Users\darai\Desktop\forge-1.12.2-14.23.1.2602-installer.jar.log" but then Java still crashed like before. Guess it'll look for an older version of java to use :P

You should. And also, download recommended Forge version for Minecraft 1.12.2 (i.e. 1.12.2 - 14.23.1.2555)

(Recommended versions bode well with your system.)

Link to comment
Share on other sites

Alright. I downloaded Java Version 8 Update 144 which is 2 versions older than the most recent one. Now instead of giving an error message the file just doesn't open at all. The cursor turns into the loading hourglass when I double click it but ultimately nothing happens, and Java doesn't appear to be opening in task manager. When I use cmd to open it I get this:

Link to comment
Share on other sites

4 minutes ago, kyle123cool123 said:

When I click on the windows version of the download nothing happens and it generates a blank log file. When I click the non-windows version Java crashes :( I'm starting to lose hope here

I'm not sure what the problem might be. Your best bet is waiting for @diesieben07 to wake up and help because I'm pretty sure he lives in Germany and is asleep at the moment :( 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • I am trying to create a custom anvil for my mod and the approach i am trying is to create a normal vanilla anvil with custom recipe container - i tried creating the block and passing a custom container to it but i do feel a bit stuck and confused on how to do this. Some explanation and guidence would be great! Thanks in advance. package com.vassdeniss.makoru.blocks; import net.minecraft.block.Block; import net.minecraft.block.BlockState; import net.minecraft.entity.player.PlayerEntity; import net.minecraft.inventory.container.INamedContainerProvider; import net.minecraft.inventory.container.SimpleNamedContainerProvider; import net.minecraft.stats.Stats; import net.minecraft.util.ActionResultType; import net.minecraft.util.Hand; import net.minecraft.util.IWorldPosCallable; import net.minecraft.util.math.BlockPos; import net.minecraft.util.math.BlockRayTraceResult; import net.minecraft.util.text.ITextComponent; import net.minecraft.util.text.TranslationTextComponent; import net.minecraft.world.World; import net.minecraftforge.fml.network.NetworkHooks; public class AngelAnvilBlock extends Block { private static final ITextComponent AngelAnvilContainer = new TranslationTextComponent("container.crafting"); public AngelAnvilBlock() { super(Block.Properties.create()); } @Override public ActionResultType onBlockActivated(BlockState p_225533_1_, World worldIn, BlockPos p_225533_3_, PlayerEntity player, Hand p_225533_5_, BlockRayTraceResult p_225533_6_) { if (worldIn.isRemote) { return ActionResultType.SUCCESS; } else { NetworkHooks.openGui(player, ); player.addStat(Stats.INTERACT_WITH_ANVIL); return ActionResultType.CONSUME; } } @Override public INamedContainerProvider getContainer(BlockState state, World world, BlockPos pos) { return new SimpleNamedContainerProvider((id, inventory, player) -> new AngelAnvilContainer(id, inventory, IWorldPosCallable.of(world, pos)), AngelAnvilContainer); } } package com.vassdeniss.makoru.blocks; import com.vassdeniss.makoru.util.RegistryHandler; import net.minecraft.entity.player.PlayerEntity; import net.minecraft.entity.player.PlayerInventory; import net.minecraft.inventory.container.RepairContainer; import net.minecraft.util.IWorldPosCallable; public class AngelAnvilContainer extends RepairContainer { private final IWorldPosCallable field_217070_e; public AngelAnvilContainer(int id, PlayerInventory playerInventory, IWorldPosCallable p_i50102_3_) { super(id, playerInventory, p_i50102_3_); this.field_217070_e = p_i50102_3_; } @Override public boolean canInteractWith(PlayerEntity player) { return isWithinUsableDistance(this.field_217070_e, player, RegistryHandler.ANGEL_ANVIL.get()); } }  
    • I'm making some tools and I'm using a Set of type Block to specify on what blocks the tools would work. This is all in my ItemInit class which I use to register items. See below. private static Set<Block> EFFECTIVE_ON = Sets.newHashSet(Blocks.ANDESITE); This works fine with minecraft blocks. Problems occur when I want to use mod blocks like this: private static Set<Block> EFFECTIVE_ON = Sets.newHashSet(BlockInit.AMBER_BLOCK.get());   I get an error while loading the game, which is a NullPointerException.  Exception message: java.lang.NullPointerException: Registry Object not present: extinctioncraft:amber_block   It seems my block can't be found by this set despite the block working fine in the game itself.    I already tried the following without success: - Checked if the BlockInit is registered in the main class. ( BlockInit.BLOCKS.register(bus); ) - Checked if the block is registered in the BlockInit class. 
    • As the name implies I am trying to make a block with a "condition" value. I am doing this because I will be adding future features where a very strong type of block would be useful. I have started out with making a simple custom blockstate property (1-4) which determines the model (Polished, Un-polished, scuffed, cracked). However, I want those 4 states to then be determined by a larger number (more wiggle room with how much damage a certain event can do to this type of block). I was thinking 3000-5000, which I can then say "oh the block durability has to be at 200 to be cracked, but 750 for scuffed". I think the large health number think could be done with a tile entity I also want certain states to be maintained even after it has been picked up such as the larger number (maybe not the 1-4 since I think I would have to do something funky with datagen for my 90 items to have 360 item models), so perhaps NBT (which I have never done before). ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ I could probably figure this out on my own given a good bit of time, but dual-enrollment does not allow much time in a day. So, basically just looking either for a github repos that shows persistent data & some funky tile entities (if that is the best route for the block health thing), or suggestions.    
    • ObfuscationReflectionHelper methods always take SRG names, even in the development environment. In development, the SRG name is automatically remapped to the corresponding MCP name.
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.